Ubuntu

Boot failure after update and system crash 11.10

Asked by Al on 2012-06-20

I'm using:
Dell XPS M1330 laptop, Ubuntu 11.10 32bits, single boot (only Linux OS), Virtualbox (with Windows XP on virtual machine).

System crashed while working with a very heavy image on GIMP (and Virtualbox was on). During the same session, I made an automatic system update, but don't know what was exactly updated. After the crash the system doesn't boot. Always freezes on terminal screen but at different stages, ""Starting CUPS printing spooler/server", "Checking battery state", "mountall: plymouth command failed", etc. Sometimes indicates [failed] in some of the processes and sometimes they're all [ok].

Did a Boot info summary with boot-repair and gave me this report http://paste.ubuntu.com/1050743/

This is not a new install, have been using it for almost 6 months...though since last month it couldn't halt..it started shutting down and stopped at black screen with fan on and on/off light still on (I used to finish the shutdown process by forcing halt with a long-press of the power button). I don't know if these has anything to do with the boot failure.

Is there anyway I can solve this issue (the boot failure) or make some sort of system check to find out what is the cause of the problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Al
Solved:
2012-06-22
Last query:
2012-06-22
Last reply:
2012-06-21

Hold shift at boot, select recovery mode, select root then run:

sudo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a

Should kickstart the update process and may help fix the issue.

Al (afrpublic-ubuntu) said : #2

Did what you said but got the following:

after sudo fuser -vki /var/lib/dpkg/lock it only showed an explanation of what fuser does with a list of "modifiers" like -a, -i, -k, etc. and what they do.

after sudo dpkg --configure -a only got the following error "dpkg: error: can't access dpkg status area: file system is read-only".

Any suggestion?

Al (afrpublic-ubuntu) said : #3

Also tried to boot holding shift, which showed grub menu. My kernel is 3.0.0-21-generic, so I selected to boot with previous kernels (20, 19, 18, 17 and 16 all of them in normal or recovery mode), and none worked.

On the GRUB menu, also tried other options (sorry, don't remember exactly which one of them)...but none worked either.

Then installed Boot-repair from a Live-USB (https://help.ubuntu.com/community/Boot-Repair) and chose the basic options...didn't work.

Again boot-repair, but this time selecting:
- Reinstall GRUB
- Unhide boot menu
- Repair file systems
- Purge GRUB before reinstalling it
- Purge kernels then reinstall last kernel
- Place the boot flag on: sda1 (Ubuntu 11.10)

It worked!!! However...some issues appeared:

1) When starting Thunderbird, a message error appears ... something like "unable to write in inbox folder". When started the second time, it appears to work normally, but e-mails are being redownloades, creating duplicates.

2) When starging Virtual machine (Windows XP) through Virtualbox, an error appears "Virtualbox - Error in suplibOsInit: Kernel driver not installed (rc=-1908). Please install the virtualbox-dkms package and execute 'modprobe vboxdrv' as root."

Don't know if other errors will appear.

Al (afrpublic-ubuntu) said : #4

After checking the issue on http://ubuntuforums.org/showthread.php?t=1885936 followed the last comment (sudo apt-get remove virtualbox-dkms & sudo apt-get install virtualbox-dkms) with these results (sorry some text is in catalan, my system lenguage):

jo@jo-XPS-M1330:~$ sudo apt-get remove virtualbox-dkms
[sudo] password for jo:
S'està llegint la llista de paquets… Fet 0%
S'està construint l'arbre de dependències
S'està llegint la informació de l'estat… Fet%
Els paquets següents s'han instaŀlat automàticament i ja no són necessaris:
  nvidia-settings libspatialite2 libgdal1-1.7.0 libgdal1-1.8.0
Empreu «apt-get autoremove» per a suprimir-los.
Es SUPRIMIRAN els paquets següents:
  virtualbox-dkms
0 actualitzats, 0 nous a instaŀlar, 1 a suprimir i 0 no actualitzats.
Després d'aquesta operació s'alliberaran 4407 kB d'espai en disc.
Voleu continuar [S/n]? s
(S'està llegint la base de dades… hi ha 182039 fitxers i directoris instaŀlats actualment.)
S'està desinstaŀlant virtualbox-dkms…
jo@jo-XPS-M1330:~$ sudo apt-get install virtualbox-dkms
S'està llegint la llista de paquets… Fet 0%
S'està construint l'arbre de dependències
S'està llegint la informació de l'estat… Fet%
Els paquets següents s'han instaŀlat automàticament i ja no són necessaris:
  nvidia-settings libspatialite2 libgdal1-1.7.0 libgdal1-1.8.0
Empreu «apt-get autoremove» per a suprimir-los.
S'instaŀlaran els paquets NOUS següents:
  virtualbox-dkms
0 actualitzats, 1 nous a instaŀlar, 0 a suprimir i 0 no actualitzats.
S'ha d'obtenir 665 kB d'arxius.
Després d'aquesta operació s'empraran 4407 kB d'espai en disc addicional.
Bai:1 http://mx.archive.ubuntu.com/ubuntu/ oneiric/universe virtualbox-dkms all 4.1.2-dfsg-1ubuntu1 [665 kB]
S'ha baixat 665 kB en 2s (246 kB/s)
S'està seleccionant el paquet virtualbox-dkms prèviament no seleccionat.
(S'està llegint la base de dades… hi ha 181780 fitxers i directoris instaŀlats actualment.)
S'està desempaquetant virtualbox-dkms (de …/virtualbox-dkms_4.1.2-dfsg-1ubuntu1_all.deb)
S'està configurant virtualbox-dkms (4.1.2-dfsg-1ubuntu1)
Loading new virtualbox-4.1.2 DKMS files...
First Installation: checking all kernels...
Building only for 3.0.0-21-generic
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
 * Stopping VirtualBox kernel modules [ OK ]
 * Starting VirtualBox kernel modules * No suitable module for running kernel found
                                                                         [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
jo@jo-XPS-M1330:~$

To my unexperienced opinion, this and the boot issue comes from the kernel update, so I'll keep trying to solve Virtualbox issue at Ubuntu forums and otherwise, will try to downgrade to kernel 20 (GRUB menu doesn't show previous Linux kernels after Boot-repair...so one more to solve).

PS: So far other software is working fine (Firefox, QGIS, Banshee, etc.)

ok, what is the output of:

uname -a; lsb_release -a

Thanks

Al (afrpublic-ubuntu) said : #6

actionparsnip,

before I read your comment, I did the following:

- Tried another syntax on the same thread on Virtualbox (http://ubuntuforums.org/showthread.php?t=1885936) with no success ($ sudo apt-get install virtualbox-dkms & $ sudo modprobe vboxdrv).

-Tried to downgrade kernel to 3.0.0-20-generic but Boot-repair had erased all my old kernel versions from the system, so the GRUB menu only showed version 21 and Synaptic only showed some files of previous versions (some headers files, but not the Linux kernel image files). Therefore, followed the advice of Paulo Arruda on http://askubuntu.com/questions/82140/how-can-i-boot-ubuntu-11-10-with-an-old-kernel-version but using version 20 instead of 12 (sudo apt-get install linux-image-3.0.0-20-generic linux-headers-3.0.0-20-generic). Then booted with shift --> GRUB menu and selecting kernel 3.0.0-20-generic...it worked!!!

-Now, I can start Virutalbox with the WinXp machine, and all the software that had been installed in that machine seems to work fine.

The shutdown problem has been solved too!! (check last but one paragraph of my initial question)

The only small issue now is that screen gets messy (half black with random colored pixels) on startup before the login screen.

PS: Regarding output of uname -a; lsb_release -a ...I guess it doesn't make much sense now because I have downgraded kernel version, but this is the output when I do it now:

jo@jo-XPS-M1330:~$ uname -a
Linux jo-XPS-M1330 3.0.0-20-generic #34-Ubuntu SMP Tue May 1 17:28:21 UTC 2012 i686 i686 i386 GNU/Linux

jo@jo-XPS-M1330:~$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

YannUbuntu (yannubuntu) said : #7

Hi
You should report the bugs that you have with kernel 21 (and that you don't have with kernel 20), via the command:
ubuntu-bug linux

Regards