Willing to Pay someone to install Ubuntu!!!

Asked by coljohnhannibalsmith on 2007-12-13

Can anyone post the contact info for some companies here in the US, preferably California that are able to install Ubuntu on MY Laptop?

Gutsy Gibbon AMD64 will not boot after install and I've tried all of the "Boot Options." I'm out of patience and I just want to PAY someone to install it for me and get me Broadcom 43xx WiFi working. I'm NOT interested in having a private individual do it. I'm looking for a real company with a Store-Front and a business reputation to do it!

I'm brand new to Ubuntu and I just don't want to mess with it anymore.

Thanks, John

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2007-12-15
Last query:
2007-12-15
Last reply:
2007-12-14
Jim Hutchinson (jphutch) said : #1

I'm afraid I don't know anyone in California, but you might be able to call some local computer businesses and see if any have experience with Linux. I'm sure there are some in the area. Mom and pop type shops might be better than large chain stores.

One thought, however, are you sure your laptop is 64bit compatible. Even if it is, you might be the 32 bit version a try. Run the live CD first as a test of what works and what doesn't.

What is the model and specs of the laptop. We might be able to give you some feedback on common issues and how to address them.

Thanks for the response Jim,

Here's the info you requested:

I've loaded GG on an Acer 5102WLMi Laptop. 2x AMD TL50 64 bit processors, ATI Radeon Xpress 1100 Graphics, SB600 Southbridge Chipset, 4GB Ram, 160GB Seagate Momentus 5400 rpm ATA/100 HDD.

I've tried all the Boot Options suggested at https://help.ubuntu.com/community/BootOptions and none of them allow my systen to boot.

Also, when booting I get about 8 messages of the following nature:

Cannot allocate resource region 7 device 0000:00:04:0
Cannot allocate resource region 8 device 0000:00:04:0
Cannot allocate resource region 9 device 0000:00:05:0
Cannot allocate resource region 7 device 0000:00:05:0

,etc.

I had a lot more device installation errors in FF; but it did'nt have any problems booting. What's up with GG?!

Oh, I almost forgot: The Live CD works fine. It just won't boot after install.

Thanks, John

Jim Hutchinson (jphutch) said : #4

Hmmm, sorry but I don't have a clue about that issue. A bit of searching suggested it could be related to the ATI graphics card but I didn't see a lot of support for that idea. In any case, you are not alone :)

http://ubuntuforums.org/showthread.php?t=580833

peter b (b1pete) said : #5

hello,

I have the same laptop and used gutsy amd64 ALTERNATE CD; it installed with no problems whatsoever. I'd suggest to download and burn an alternate CD and try another install -it'll give full control of the install. If you're receptive to this idea then let me know and I'd be more than happy to walk you through the whole proccess. By the way, is there any other os's currently installed on your laptop?.

regards,
peter b

Hello Peter,

Thank you for your response. Ubuntu is the only OS I have on this HDD. I have another HDD with Vista x64, which I do most of my work on and another HDD with Vista x32, which I use for troubleshooting purposes between the x64 and x32 versions. Until install to USB becomes commonplace, I will probably to continue to rely on this solution to my multiple OS needs.

Thank you for your suggestion. I'm downloading the GG alternate-install at the time of writing and would love to have your help with the install.

So, after I burn the new CD, where do I start?

Thanks, John

peter b (b1pete) said : #7

hello,

Glad to hear that you did not give up. The start is v simple, basically the same as the live CD except that in this case it'll ask you quite a few questions re language, keyboard, checking the cd, detecting the internet connection, etc before opening the partitioner. At this point I strongly recommend to pay special attention --> it will identify your HDD starting with sda, sdb etc.

From what I understand, you have an internal 160GB HDD that DOES NOT HAVE any os on it. If that's the case you'll have displayed sda with FREE SPACE the entire drive. If that's what you see, pls confirm by e-mail. Please, please do not be tempted to go beyond this point until I have an answer. Another point, at any time at this point you can GO BACK and abort the installation with NO CHANGES MADE TO THE SYSTEM.

If you feel comfortable with the above, then we can proceed with partitioning the HDD. You have quite a few options available in terms of having the installation taylored as you wish

- minimum install --> two partitions --> one for / and the other one for swap. the / may be the entire size of HDD less the swap that i'd recommend in your case 1GB
- install /home on separate partition --> advisable because in case of upgrade /home is not touched; still mandatory / and swap
- install /usr and /home on separate part --> stll / and swap mandatory. and so on

sizes, make / something like 20GB; /home as large as you wish; swap as I said 1GB.

So here we go,
choose MANUAL partitioning and highlight FREE SPACE --> create new partition --> enter the size in GB --> create at the beginning --> choose / and ext 3 file system --> highlite do not boot --> press enter --> BOOT WILL BE BOOT NOW ; finish creating this partition;

you'll be sent back to your main partitioner screen where, if everything was done right, yo'll see the new partition displayed as / est3 and the latter B mining BOOT

highlite FREE SPACE again and follow same BUT create /home AND DO NOT HIGHLITE DO NOT BOOT --> leave it as is DO NOT BOOT; finish creating this part

back to your main partitioner screen where / and /home will be displayed BUT /home DOES NOT HAVE the letter B --> v important

highlite FREE SPACE again and create swap partition --> this a special file system ATTENTION!! DO NOT CHOOSE ext3 or anything else BUT ONLY swap!!!

on your main partitioner screen there must be now 3 partitions --> first / ext3 Bootable; second /home ext3 with no B; third swap with no B

AT THIS POINT PLEASE WRITE DOWN ON PAPER THE PARTITION WHERE THERE IS THE B (the one for /) --> it should be something like sdaX where X is a number; in your case probably is 1.

If you have everything displayed as such please send me an e-mail to confirm and I'll answer immediately back to proceed with WRITING THE CHANGES TO DISK. VV IMPORTANT, YOU STILL CAN ABORT THE INSTALL AT THIS POINT GOING BACK ALL THE WAY -there is still nothing written to the HDD

The tough part is behind us; once the partitioning is done the rest is pretty straight forward UP TO WRITING GRUB screen. At this point DO NOT ACCEPT WRITING GRUB TO MBR WHICH IS THE DEFAULT. SO CHOOSE NO AND ON THE NEW SCREEN ENTER /dev/sdaX which is the ONE COPIED ON PAPER WHEN PARTITIONING FINISHED.

This is pretty much it; if you feel comfortable and confident with the above please feel free and do the whole install without any e-mails. However, should you have any doubts during the install do not hesitate to contact me.

Good luck!!

peter b

peter b (b1pete) said : #8

reading the entire thread before retiring for the day I noticed that on the 160GB internal HDD you have ubuntu from a previous unsuccessful install. The following do not alter at all the previous post EXCEPT that when you're in the partitioner in order to get the FREE SPACE for the entire disk as mentioned

please delete all partitions that appear under sda --> they are of no use -you could not get ubuntu to boot. after this the entire HDD capacity should be displayed as FREE SPACE then proceed with the partitioning as described.

peter b

Peter,

Thank you for your help. After I burned the CD last night I thought I'd try installing it, just to see how far I could get. Since I planned on completely overwriting the previous install attempt, it seemed harmless to try. I simply selected text based install and answered the questions with what I believed were the most reasonable responses. When I got to the Partitioner a choice was available to use the entire disk, which I selected, and it installed / as ext3 and Swap as Swap. It completed sucessfully and is booting without problems. It wasn't until this morning that I had a working internet connection and was able to read your response. You mentioned something about a /home and /usr directory. I don't know what these are and wasn't asked for this durring the install. Since I don't have any programs or files on this disk, I can repeat the install manually if necessary.

My next problem is getting my internal Broadcom 43xx WiFi working. There's a tutorial on this at:

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty

but; I'm having trouble understanding it.

It mentions three things to accomplish:

1. Obtain the firmware from Broadcom. I suspect I can just download this from their site; but I'm not really sure what to look for. I'll surf there this afternoon and see if I can find anything that looks like what I need.

2. Use fwcutter to extract the firmware. I'm not even sure what fwcutter is or where I get it from. Then once I've extracted the firmware, where and how do I install it?

3. The article mentions something about an Acer ACPI package. Do I need this or is there any advantage to installing it?

Thanks, John

Best peter b (b1pete) said : #10

hello,

Let's talk first things -the subject of this ticket- first; glad to hear that you got it going, I mean you have an install that works well, less the internet connection that is not the subject of this ticket.

I'm going to give you a cople of insides re /home, /usr and so on; as I said linux in this case ubuntu, requires A MINIMUM 2 distinct partitions a / and swap which were created by the partitioner as a default when you accepted ENTIRE DISK option -there is nothing wrong with this --> proof, you have a working linux install. However, you entered the big world now and in this world of linux one can basically do almost everything as far as customizing.

If you would have chosen the MANUAL option you could have 'carved' your install at your heart desire --> you could have created the partitions the size you wanted, you could have assigned various linux folders like /home, /usr, /var, etc. to separate partitions, you could have made the / partition bootable WITHOUT touching the MBR and on and on it goes. So, it's up to you if you wish to experiment with more intricate installs than the default entire disk option. Just a piece of my mind, probably this is the best time to experiment since you have no data to worry about and it'll give you a good, solid understanding of what linux is capable of. Now, the wisdom behind having a separate partition for /home --> be aware that linux is a os that is in continuous development that is driven by the users; you for that matter have full control of doing your own kernel as an example, so new kernels are developed daily by everyone knowlegeable; ubuntu has new kernels every 6 months or so that go through extensive testing and debugging prior to being made available to the community; it is advisable in this circumstances to have /home on a separate partition from the main linux tree that can be upgraded without creating havoc so to speak in the user's data that sits usually in /home. So, again, feel free to do whatever suits you best --> create or not a separate part for /home; I strongly advise you to do that. As far as the other separate partitions /usr /var etc I think that for the time being you're better off leaving them to sit on the /.

What follows is just a little insight into how I set up my acer --> when I bought it I had no choice but have vista installed by the manufacturer; it was inst on 50 GB of the HDD -I didn't like it, So I shrank that part to 25GB then created another 25 GB for xp and the rest an extended part where I have installed feisty and gutsy on separate volumes. Every one of the four os's boot separately from a menu. Needless to say, vista boot is on MBR and the others on the respective partitions.

Let's discuss briefly your other problem --> internet connection. My acer has an Atheros chipset for wireless; it was configured automatically, the router 'saw' it at the time of ubuntu install -no mas no fuss, simple without any problems. It's news to me your broadcom wifi. Secondly, I looked up the web page mentioned --> attention, it is for FEISTY NOT FOR GUTSY. A suggestion, use your RJ45 connection when you try a new install --> chances are that this conn will succeed and have internet until you could find a solution to your problem. I will not continue with this here for the simple reason that it is not part of this ticket. Feel free to open another ticket for this problem.

Hope this helps.

peter b

Thanks peter b, that solved my question.