Ubuntu

nVidia GeForce GTX 555 with ubuntu 12.04

Asked by Jacopo Canton on 2012-05-31

Hello,

i've installed ubuntu 12.04 on a Dell Alienware Aurora R4 with nVidia GeForce GTX 555 graphics card.
I have two problems:
   - booting: i have a purple screen of death on boot if i don't set grub to boot with 'nomodeset' option
   - screen resolution: i have tried to install all kinds of drivers from nVidia and Xorg but none sees the correct max resolution of my screens (tried with 2 different ones), i can't set them on more than 640x480 (without nVidia drivers, using nuoance, i can get up to 800x600). I am now running on nVidia driver 302.something (BETA) which at least (using xrandr) sees that i have a DVI output connected and correctly sees the other DVI and the HDMI as disconnected (with previous drivers xrandr gave me errors). Also, in the nVidia control panel, it sees my screen as CRT-0 and it allows me to manually set a high res but if i do it leaves the screen to 640x480 and lets me "navigate" the screen in the desktop (as if i was zooming).

Anyone has had similar problems?
Anyone can help?

thanks in advance
Jack

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-01
Last reply:
2012-06-17

I suggest you remove whatever drivers you installed and the run:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Will work just dandy

Jacopo Canton (jacopo-canton) said : #2

Hello andrew and thanks for your reply.
I have already tried to do as you suggested (as i read it in another post somewhere on the ubuntu forums) but it doesn't work, it still gives me the problems i described in my previous post...do you know why?

What happens when you try the PPA? What results do you get? Instead of sayinig "gives me problems", if you DESCRIBE the issues instead its more helpful.

Jacopo Canton (jacopo-canton) said : #4

Sorry, maybe i haven't been clear, when in my first post i wote that i already tried Xorg drivers i meant ppa drivers for X.org (it was damn late night).
As i described in the first post i have installed them and opened both the "display" menu in "system settings" and the "nvidia control panel". In both menus i am not allowed to set a screen resolution higher than 640x480 and the screen doesn't get recognized ad DVI-I-0 as it should but as CRT-0. I still get the purple screen of death on boot if i don't use 'nomodeset'. The graphic card gets recognized by the nvidia control panel as it correctly shows the model, the different clock speeds of memory, gpu etc and temperature (and all of the usual stuff) it looks as if it doesn't see the screen correctly.

Have you got any suggestions or any tests to make me do to have more details? I'm gonna send to nVidia a bug report generated with
   sudo sh /usr/bin/nvidia-bug-report.sh
as they've asked me to do when i contacted them, i can post it here too if it can be of any help

Thanks again

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.