long wait for kde launch icon / window, how to disable

Asked by edA-qa

I run firefox as a different user with the command 'gksudo -u someuser /usr/bin/firefox' which results in the cursor showing the loading icon for a very long period of time (it continues until long after firefox has started).

I have two questions:
1) How can I reduce the timeout of this loading icon for this shortcut link? That is, for this icon I'd like to set it to 1 second, knowing that kde itself can never figure out when the launch is completed.

2) How can I change the icon used (it is always using a generic icon, I'd like it to use the Firefox icon)?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
edA-qa (eda-qa) said :

I know where to completely turn off the launch feedback, but I would like at least momentary feedback so that I can actually know that I clicked the icon.

Revision history for this message
Wim van der Meer (wim-zaf) said :

Go to K-menu --> System Settings, then click on the icon in the top row that says "Panel". Now click on the icon on the left hand side that says "Launch Feedback". Now you have a dialog box with a slider to adjust the startup indication timeout.

Hope this helps.

Revision history for this message
edA-qa (eda-qa) said :

Okay, that'll work. Though on my system I do:

KMenu->Settings->Appearance & Themes->Launch Feedback

Revision history for this message
Frode M. Døving (frode) said :

If this is kubuntu i suggest using
'kdesu -u username -i /usr/share/icons/crystalsvg/48x48/apps/firefox.png firefox'

That will give you a nice password dialog with the firefox icon and the launch feedback will stop once the password prompt appears.

- Frode

Can you help with this problem?

Provide an answer of your own, or ask edA-qa for more information if necessary.

To post a message you must log in.