Kubuntu Gutsy 7.10 64 bit fresh install of Flash md5sum mismatch

Asked by Trebacz on 2007-12-06

I've checked off in adept to have the flash plugin installed. I realized it failed when flash didn't work in Firefox. Adept may have reported a problem, but I didn't know what it was.

I ran the following commands in konsole that were suggested elsewhere:

To remove lingering parts of the uninstall:
sudo apt-get remove nspluginwrapper

To attemp to reinstall:
sudo apt-get install flashplugin-nonfree

Konsole displays the following error:

Download done.
md5sum mismatch install_flash_player_9_linux.tar.gz
The Flash plugin is NOT installed.

I'm assuming something needs to be updated somewhere in the system. I'll attempt to update the checksum manually to get it installed, but I though someone should know so it can be fixed.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Trebacz
Solved:
2007-12-07
Last query:
2007-12-07
Last reply:
2007-12-06
Wepiha Te Ata (wepiha) said : #1

This is caused with an update in adobe flashplayer (9.0 r115) that is not reflected in the flashplugin-nonfree package. This should be updated in the repositories soon.

If you require flash urgently then you should download and install the flash player from the adobe site.

Trebacz (david-trebacz) said : #2

I did try and instal from Adobe directly, but when installing the installer reports that it doesn't support x64 installations. I'll just wait for the library update.

Dara Adib (daradib) said : #3

Wepiha Te Ata is right.

This is a very recent bug, caused by Adobe's update of Flash 9.0 update 3 (9.0.115.0) codename "Moviestar" on December 4th.

http://www.adobe.com/aboutadobe/pressroom/pressreleases/200712/120407adobemoviestar.html

This caused Ubuntu to not install the flash plugin, detecting a change in the flash plugin installer file (via MD5 checksums). See bug 173890. This bug has been fixed in the next release of Ubuntu (Hardy 8.04) and it should soon come as an update to Ubuntu 7.10.

If you want an immediate fix, do the following.

Using Synaptic Package Manager, remove the package flashplugin-nonfree. For more information on how to do this, see the Ubuntu documentation here: https://help.ubuntu.com/7.10/add-applications/C/advanced.html#synaptic

Alternatively, you can run this command in the Terminal (Applications -> Accessories -> Terminal): sudo apt-get remove flashplugin-nonfree

Since you have 64-bit Ubuntu (not likely or recommended for a person new to Ubuntu), you currently need to build a binary package from this source package: http://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/9.0.115.0ubuntu2

To compile/build a binary package from a source package, extract the archive (a tar.gz file), cd into the directory of the extracted file in terminal, and in terminal run dpkg-buildpackage -b -rfakeroot

You can then install the generated debian package.

Please feel free to respond if you wish me to elaborate on building a binary package from a source package (exact terminal instructions).

Dara Adib (daradib) said : #4

Sorry about "(not likely or recommended for a person new to Ubuntu)". Please disregard that. Also, if you have Ubuntu 32-bit, you can just download this package and install it (it is identical to the current package in the next release of Ubuntu, Hardy 8.04): http://launchpadlibrarian.net/10761023/flashplugin-nonfree_9.0.115.0ubuntu2_i386.deb

Trebacz (david-trebacz) said : #5

I'll hold off until the updated package is in the 64 bit repositories. This is my alternate machine and it's only flash.... I just wanted to make sure the problem was being addressed.

Dara Adib (daradib) said : #6

Yes, I understand. I have been requesting that it get into 7.10 repositories; it should soon be there. I also should add that I have uploaded a binary deb package for 64-bit http://launchpadlibrarian.net/10804892/flashplugin-nonfree_9.0.115.0ubuntu2_amd64.deb which can use, if you wish to do so. I recommend that you build the packages yourself, however, because you should exercise caution when downloading a random package (the source package is trusted as it is from an included Hardy source package) since that lets anything be executed that the creator of the package made (and possibly malicious). (Although of course I compiled that package and therefore trust myself- :-))

Rashad Tatum (rmtatum) said : #7

I tried Cyrus's deb package and one I built using pbuilder from the source package posted at https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/9.0.115.0ubuntu2 . Both packages cause firefox to crash when I first open the browser. Konqueror doesn't load the flash plugin.

Rashad Tatum (rmtatum) said : #8

I tried Cyrus's deb package and one I built using pbuilder from the source package posted at https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/9.0.115.0ubuntu2 . Both packages cause firefox to crash when I first open the browser. Konqueror doesn't load the flash plugin.

Dara Adib (daradib) said : #9

Mr. Tatum, please try running firefox from the terminal, and posting the result. See http://ubuntuforums.org/showthread.php?t=636397 for more information on the Flash player plugin bug. If you haven't done so, completely remove the flashplugin-nonfree package and install the new package. Please specify more information about your system. I hope you are using *buntu 7.10.

Hey!

I'm running Ubuntu + Kubuntu Desktop on 7.10 Gutsy Gibbon AMD64 version, and the above package for Hardy works amazing! Thanks so much for the link, it saves a lot of headaches!

-Tres

Dara Adib (daradib) said : #11

No problem.

Although the plugin works excellent for the most part, there appear to be two problems.

The new version of flash may be incompatible with Konqueror. That could cause problems for an update through the repositories. Some sites, including disney.com and nick.com do not load properly. It would be great if someone tests these sites with an older flash plugin and with Windows Flash Update 3.

buntu_hugenewbie11 (dwozniak) said : #12

I am trying to build the package as I am using 64 bit and I get the following error:
root@dave-laptop:/home/dave/flashplugin-nonfree-9.0.115.0ubuntu2# dpkg-buildpackage -b -rfakeroot
dpkg-buildpackage: source package is flashplugin-nonfree
dpkg-buildpackage: source version is 9.0.115.0ubuntu2
dpkg-buildpackage: source changed by Brandon Holtsclaw <email address hidden>
dpkg-buildpackage: host architecture amd64
dpkg-buildpackage: source version without epoch 9.0.115.0ubuntu2
dpkg-checkbuilddeps: Unmet build dependencies: cdbs
dpkg-buildpackage: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: (Use -d flag to override.)

Dara Adib (daradib) said : #13

You should run the command sudo apt-get build-dep flashplugin-nonfree

That will automatically satisfy all dependencies for building a flash package, including cdbs.

See this thread: http://ubuntuforums.org/showthread.php?t=636397

Rashad Tatum (rmtatum) said : #14

Cyrus,

I reinstalled Kubuntu Gutsy and the package worked.

Dara Adib (daradib) said : #15

64-bit packages have been built. http://ubuntuforums.org/showthread.php?t=636397