how to: ctrl alt del = system monitor

Asked by metrekare on 2007-12-03

I want to see my system monitor when I press ctrl alt del. is there any way to do it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
ed0t
Solved:
2007-12-05
Last query:
2007-12-05
Last reply:
2007-12-03
david (trashedgm) said : #1

 if you want you can add the systems monitor to your top or bottom panel, right click on the panel and choose add to panel, then add the systems monitor. now about using windows default keys you might be able to write a script for it, but why

metrekare (abdunal) said : #2

a shortcut on my panel would be ok. but when I urgently want to quit a program that doesn't respond, when even my cursor doesn't move smooth, it takes too much time to open the menu and find the monitor...

Best ed0t (edoardo-tosca) said : #3

if you want to enable Ctrl Alt Del to open System Monitor you have to do this 2 things:
- First of all go to System->Preferences->Keyboard Shortcuts
- Search for "Logout" action that is under Desktop actions.
you will see that Ctrl+Alt+Del combination is associated to Logout shortcut (even if it does not work for me ;) )
- click on that shortcut and press Backspace if you want to disable it or choose another combination.

Close it and open the Configuration Editor (if you have installed it you will find it under Applications->System Tools)
- On left tree select: apps->metacity
- Select "Global_keybindings" and search for a "run_command_X" value where X is between 1 and 12 and it is not used (i have used run_command_9)
- Add this value: <Control><Alt>Delete
- Now select "Keybindings_commands" on left tree. Goto "command_X" where X is the same number selected in run_command_X option. (For me is command_9)
- Add this value: gnome-system-monitor

If you don't have the Gconf editor open a terminal and write this two commands:

gconftool-2 -t str --set /apps/metacity/global_keybindings/run_command_9 "<Control><Alt>Delete"
gconftool-2 -t str --set /apps/metacity/keybinding_commands/command_9 "gnome-system-monitor"

metrekare (abdunal) said : #4

Thanks ed0t, that solved my question.

ayonbd2000 (ayonbd2000) said : #5

Thanks ed0t

mujaheddin (mujaheddin) said : #6

just for the quick reader, it is <Control><Alt>Delete, so delete /without/ brackets :)

Joe (fakeaddress2005) said : #7

Hi ed0t,

I was able to go into keyboard shortcuts and disable the Control Alt Delete shortcut for logout. But I cannot seem to do the next step: getting into the Configuration Editor from System Tools. I checked my add/remove applications menu and I do have Configuration Editor installed- why can't I find it in my system tools?

Thanks... Joe

Kyle Dobbs (kyle-dobbs) said : #8

Joe,

Alt-f2 (or launch your terminal)

gconf-editor

If that doesn't work, put this into your terminal and try again: sudo apt-get install gconf-editor