Booting from external HD crashes

Asked by Marty1983 on 2006-09-25

Hey :-)

 After ordering a second CD I was able to install Ubuntu successfully onto my External HD, correct partitions and everything, fab! Dead happy thus far.

 I altered my BIOS so that it enabled booting frm USB Mass Storage. Everything hunky-dorey.

 HOWEVER when I came to boot my lovely new Ubuntu installaion it began ok, reached the third stage (hard to tell EXACTLY what it was doing given that I have wide screen and that splits the boot screen, but it became clear nothing was happening. And then it crashed and I pieced together the following error message

"Your PnP BIOS caused a fatal error
You need to reboot with 'pnpbios=off' to operate stably"

I have no idea what a PnP BIOS is nor why this affects Ubuntu loading for me.
Any help at all would be gratefully appreciated so that I can FINALLY begin to work out if/how to move from windows to Linux.

This isn't a bug as it appears to be something my computer needs setting up with, but I'd just appreciate a hand in getting over what appears to be the final hurdle.
My kindest regards,

Martin

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Alexandre Vassalotti
Solved:
2006-09-30
Last query:
2006-09-30
Last reply:
2006-09-29

If you want to disable it, you need will need to play with GRUB, the boot loader (Instructions below). These will cause the kernel to interact differently with your hardware and things may work better.

To pass the option "pnpbios=off", press 'e', in GRUB. Press 'e' again on the line that start with "kernel". Append "pnpbios=off" (without quotes) at the end of the line. Finally, press Enter, then 'b'. It should boot fine.

To make the change permanent, you will need to edit to /boot/grub/menu.lst file. Here how to do that:

$ gksudo gedit /boot/grub/menu.lst

Now, find those lines:
## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

Add "noapic" to defoptions (do not uncomment it):
# defoptions=quiet splash pnpbios=off

Save and close.

Finally, generate you new menu.lst:
$ sudo update-grub

Marty1983 (martin-oxby) said : #2

Hey,

 I hate to sound dumb, but could you explain in layman's terms where GRUB is when I start the process?

 I'm ENTIRELY new to anything outside of Windows (I might have used a Mac ONCE before) so I don't know WHEN I can do any of those things. If one required Ubuntu to have been loaded I'm snuffed because It doesn't load.

Please help and thank you for your patience.
Kind Regards,

Martin

Martin-

Just follow the directions that Alexandre left you. The first set of instructions (before "To make the change permanent") is to be done while booting up (when you see the Ubuntu boot menu).

This is to see if the problem is fixed by passing the pnpbios=off switch.

If it boots fine, then follow the rest of the instructions to make the change permanent (so that you won't have to do the first set of instructions every boot cycle).

The lines beginning with $ are to be done at the command line in a terminal. You can get a terminal by choosing Applications -> Accessories -> Terminal

What you are basically doing, with his instuctions, is:

1. Opening a Terminal

2. Launch an editor (gedit) as root (with gksudo) so that you can edit the Grub menu (/boot/grub/menu.lst). You need to be root so that you can write the changes back to disc.

3. Edit the line in the file that he mentions.

4. Save the file (it will save it back to /boot/grub/menu.lst).

5. Then shut down you system and restart it to see if the changes worked.

Just a note on the Linux file system. The root directory of the traditional unix/linux file system is denoted as /.

Everything else hangs off the root file system. So, for instance, the boot directory traditionally holds files needed by Linux to boot and is off the root directory so it is demarcatedy by /boot. The grub subdirectory off of /boot is listed at /boot/grub.

If these comments answered your question, please consider closing the this ticket.

Thanks

Good Luck. Welcome to Linux... and the Ubuntu community. It is a VERY powerful operating system.

Marty1983 (martin-oxby) said : #4

If I follow them carefully enough then yes, thank you, this is answered :-)
My kindest regards,

Martin