mime types gone wrong

Asked by jamie on 2007-11-25

I clicked on a Desktop icon of a DVD (Team America!) and when promted selected VLC Media player and "Always open with this application"
Now VLC Media player is trying to open almost anything that I click on including .deb files and even the "Home Folder" icon in Konqeror's "Conquer your Desktop" default screen. I can't seem to find the mime editor tool to undo this mess. Any ideas welcome (Gutsy Gibbon on Dell Inspiron 7500, KDE 3.5.6)

Brilliant distro, I'm very happy with it otherwise. Wi-Fi and DVD writer work out of the box :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Pedro Fragoso
Solved:
2007-11-26
Last query:
2007-11-26
Last reply:
2007-11-26
Best Pedro Fragoso (ember) said : #1

You can try this:

sudo update-mime-database
sudo update-desktop-database

KDE uses is on mime database but you can try it.

jamie (jgwild) said : #2

I fixed it by using Krusader to find the mime editor for me.
Type "settings:/Components" into the path bar at the top of a panel. Hit Enter and you wil see a list of utilities.
The second one down is "File Associations" and I used this remove the VLC entry under "inodes/directory"
I still don't know how to get to this utility any other way, maybe someone does?
Thanks Pedro, I will use your way when I really mess up my computer :)

jamie (jgwild) said : #3

Thanks Pedro Fragoso, that solved my question.