windows avoiding panels—how?

Asked by Bogdan Butnaru on 2007-11-24

Hello! (Gutsy, up-to-date.)

Currently when I move windows around on the desktop, they are constrained to avoid the Gnome panels. This is normally useful, especially for panels that extend the complete width of the screen.

However, I have good reasons why I'd prefer this another way. I'd want the panel to be always above normal windows (but below full-screen ones), but not allow windows to go below them. I can't figure out which component actually handles that. Is it Compiz? One of its plug-ins? Some Gnome program?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Bogdan Butnaru
Solved:
2008-02-04
Last query:
2008-02-04
Last reply:
2007-12-10
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Bogdan Butnaru (bogdanb) said : #2

I found the answer: This behavior appears to be caused by the Compiz plug-in "Move Window".

The setting in question is "Constrain Y". When it is disabled, I am freely able to move the windows out off the window's border.

Bogdan Butnaru (bogdanb) said : #3

Solved.