"Event Sounds" Slider missing on KMix

Asked by DriverLand on 2011-12-27

Hi! Any of you guys know how to enable that “Event Sounds” slider under the “Playback Streams” tab? I’ve made a re-install of Kubuntu 10.10 on my desktop, and I’ve lost this slider, I don’t know why. I’ve tried uninstalling both pulseaudio and alsa and reinstalling again, as I did on the first install, and also deleting the kmix config files, but none worked…
The only way I can restore that slider is deleting the ~/home/.pulse folder. But, unfortunately, it is only useful until the next boot...
Any idea?
Thanks a lot!

http://i2.photobucket.com/albums/y9/imageuser/KMix_PulseAudio_Playback_Streams.jpg

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu kdemultimedia Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
DriverLand (driverland87) said : #1

I think it may be related to this:

<<Commit by cguthrie :: r1226951 kmix/trunk/KDE/kdemultimedia/kmix/backends/mixer_pulse.cpp: (link)
kmix: Fix the 'Event Sounds' slider.

When the volume/channel map parts of a stream restore rule are invalid
(which is allowed as these are optional in the restore rules) then we
cannot draw a slider. As we need to draw the slider for the event sounds
rule, silently fix it up.

Other restore rules need to be kept as is, for the Move option to work
correctly.>>

From:
http://cia.vc/stats/author/cguthrie/

But I don't know exactly what to do, I can't locate the mixer_pulse.cpp file.

DriverLand (driverland87) said : #2

By the way, I'm using KDE 4.5.5...

DriverLand (driverland87) said : #3

Could anyone with a KDE 4.5.* version, with that "Event Sounds" slider working, post a list of the installed packages, just to compare which am I missing?
Thanks!

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.