command line display

Asked by citizenthom on 2007-11-19

i have GNOME Terminal 2.18.0 through ubuntu. how can i stop the current directory being displayed on the command line as this can become annoying in extensive directories?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-11-19
Last reply:
2007-11-19
Ansgar Burchardt (aburch) said : #1

You have to change the environment variable PS1. If you still want to see the name of the current directory (not the full path) set it to "\u@\h:\W$ ". Other settings are described in the man page for bash.

To make the change permanent add
  export PS1="\u@\h:\W$ "
to your ~/.bashrc.

Can you help with this problem?

Provide an answer of your own, or ask citizenthom for more information if necessary.

To post a message you must log in.