driver 'sd' needs updating

Asked by Flanagan on 2006-09-16

Ubuntu Dapper, kernel 2.6.15-26-386, is loaded into my Dell Latitude CPi Pentium II - 400. As I boot up in "recovery mode", after Loading Hardware Drivers begins, the line:
"driver 'sd' needs updating - please use bus-type methods"
flies past.

Repeated searches of all of the ubuntu "help" sites give me no clue about what this line means or what I should do to make it stop.

Additionally, Ubuntu boot-up hangs after a later line:
"nm256: mapping port 1 from 0x2709a0 - 027ec00"
sometimes it is immediately after this line, sometimes a few more lines will pass before the boot-up hangs. Usually, boot-up will be successful after a few more tries. The problem is intermittent and unpredictable.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Luca Falavigna (dktrkranz) said : #1

I do not think you have to worry too much about "driver 'sd' needs updating" statement, unless you notice some strange behaviours with SCSI devices such as USB sticks and so on (e.g.,
Concerning nm256, see bug #45208.

Flanagan (ml-flanagan) said : #2

Thank you Luca.
It sounds like there isn't much that can be done to make Ubuntu work reliably on this computer! That's a pity.

HPNadig (hpnadig) said : #3

I'm having the same problem after I tried installing a kernel from repository with smp support on Synaptic. The generic kernel still has no problems, but on others I get:

"driver 'sd' needs updating - please use bus-type methods"

and couple of more things like:

"SCSI device sda : drive cache: write back"

and it just hangs there.

This msg is also appearing with BUG#32123 on May 2008 8.04 AMD+ distribution. Thought worthwhile to mention!

I updated to Kernel 2.6.24-17-generic today [to no avail] and noticed this msg [and initramfs loop].

Could it be that the driver for SATA related disk errs may be fixed to relieve this lingering chronic bug in Linux architecture?

It only happens on my new Dell/Vostro machine (dual boot w/XP). I am new to Ubuntu and would open an incident with Dell if I could define more of this issue [they must have some Linux interest/people!]. Any ideas to resolve?

Flanagan (ml-flanagan) said : #5

The initial question was posed nearly 2 years ago. Sad that it isn't resolved, yet. I'm no longer using the computer that I noticed the problem with. And two more computers that I'm running up-to-date Ubuntu on are not showing the problem. One is running at 64 bits, the other at 32 bits.

No, I don't have any ideas to resolve.


I appreciate the feedback.

Incidently, dmesg shows this "Driver 'sd' needs updating -" on all of my machines but only my newest, most expensive Dell has problem [aka will not boot]. Go figure!

I may contact Dell questioning why this popular Vostro 200 hardware configuration fails, where 'cheap' HPs run fine. Thanks

David A. Cobb (superbiskit) said : #7

I'm seeing the same using Hardy (8.04 LTS) installed from the CD. In fact, I see the same gripe about "driver 'sr' needs updating".

This happened right after I had a scary boot-up, where the system apparently could not mount /var or /tmp [2 partiitions on same drive. No surprise that nothing much worked that time and I had to push the panic (a.k.a 'stop') button.

Since I seem to be OK now, I guess I won't worry much.

Can you help with this problem?

Provide an answer of your own, or ask Flanagan for more information if necessary.

To post a message you must log in.