10-APIC not connected

Asked by Rollo on 2006-09-16

new laptop Packard Bell R3563 easy notebook loading ubuntu 6.06 LTS second line following error report
[4294668.401000]..MP-BIOS bug: 8254 timer not connected to IO-APIC
Please help as I prefer to use Linux to WIndows
Thanks
Rollo

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2006-09-16
Last reply:
2007-01-30

If I remember well, you can pass the option "noapic" to the kernel, and it will boot correctly. I don't know what's cause of this error, but I know it's fixed on Edgy (next Ubuntu release).

To pass the option noapic, you press 'e', in GRUB, on the boot option you want to edit. Then, press 'e' again on the line that start with kernel. Append "noapic" (without quotes) at the end of the line. Press Enter, then 'b'. It should boot fine.

To make the change permanent, you will need to edit to /boot/grub/menu.lst file. Here how to do that:

$ gksudo gedit /boot/grub/menu.lst

Now, find those lines:
## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

Add "noapic" to defoptions (do not uncomment it):
# defoptions=quiet splash noapic

Save and close.

Finally, generate you new menu.lst:
$ sudo update-grub

Rollo (rollo) said : #2

Hi Alexandre

Thanks for your reply, much appreciated - but the error occurs before I
have down loaded the program and before I get to GRUB

Rollo

Alexandre Vassalotti wrote:
> Support request #1808 on Ubuntu changed:
> https://launchpad.net/distros/ubuntu/+ticket/1808
>
> Comment:
> If I remember well, you can pass the option "noapic" to the kernel, and it will boot correctly. I don't know what's cause of this error, but I know it's fixed on Edgy (next Ubuntu release).
>
> To pass the option noapic, you press 'e', in GRUB, on the boot option you want to edit. Then, press 'e' again on the line that start with kernel. Append "noapic" (without quotes) at the end of the line. Press Enter, then 'b'. It should boot fine.
>
> To make the change permanent, you will need to edit to /boot/grub/menu.lst file. Here how to do that:
>
> $ gksudo gedit /boot/grub/menu.lst
>
> Now, find those lines:
> ## additional options to use with the default boot option, but not with the
> ## alternatives
> ## e.g. defoptions=vga=791 resume=/dev/hda5
> # defoptions=quiet splash
>
> Add "noapic" to defoptions (do not uncomment it):
> # defoptions=quiet splash noapic
>
> Save and close.
>
> Finally, generate you new menu.lst:
> $ sudo update-grub
>
>
>
>
>
>

It very unlikely that the error you are describing is happening before GRUB (not to say impossible). This is a typical error message from the Linux kernel.

You need to press ESC to enter GRUB at the countdown, which happen before the splash screen appears. Then, edit the boot line as I described. If it works, then you can move on to make the change permanent.

Did you figured out how to fix the problem?

Michael Monreal (mimox) said : #5

I also see this message when booting a kernel newer than 2.6.17... at least it does not show up when booting a stock edgy kernel but the 2.6.20rc kernel show it. Is the edgy kernel patched not to show this or is this detection newly introduced? also, any idea what this actually means? my sytem works fine even with this

Can you help with this problem?

Provide an answer of your own, or ask Rollo for more information if necessary.

To post a message you must log in.