my entire /usr directory and /home partition were replaced with symlinks

Asked by Luke Faraone on 2007-11-15

I was just running my OS normaly yesterday, when I started to be unable to launch applications.
I rebooted, and then got the error "too many levels of symlinks" while I booted.
Nothing starts but recoverymode, and then I can not run any non-built-into-bash commands.
Attached will be the output from ls -l of my /

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Luke Faraone
Solved:
2007-11-18
Last query:
2007-11-18
Last reply:
2007-11-16

This question was reopened

zimbatm (zimbatm) said : #2

I don't know what happened, but it would be useful if you could post the result of `mount`, `cat /proc/partitions` and `cat /etc/fstab`

Luke Faraone (lfaraone) said : #3

Uh, I am running from a live cd, since I cannot boot properly, but here is what I get:
ubuntu@ubuntu:~$ mount
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /lib/modules/2.6.22-14-generic/volatile type tmpfs (rw,mode=0755)
tmpfs on /lib/modules/2.6.22-14-generic/volatile type tmpfs (rw,mode=0755)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
/dev/scd0 on /media/Ubuntu 7.10 i386 type iso9660 (ro,nosuid,nodev,uid=999,utf8)
/dev/sda3 on /media/disk type ext3 (rw,nosuid,nodev)
/dev/sda4 on /media/disk-1 type ext3 (rw,nosuid,nodev)
ubuntu@ubuntu:~$ cat /proc/partitions
major minor #blocks name

   8 0 117220824 sda
   8 1 819315 sda1
   8 2 1 sda2
   8 3 60067035 sda3
   8 4 51175026 sda4
   8 5 4458006 sda5
   7 0 657224 loop0
ubuntu@ubuntu:~$ cat /etc/fstab
unionfs / unionfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0
ubuntu@ubuntu:~$ cat /media/disk-1/etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda4
UUID=a12eead7-9dc8-42ba-921a-ecbeda5e8fc4 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda3
UUID=0ea7a973-8030-4728-9617-3c72bc5a7ec0 /home ext3 defaults 0 2
# /dev/sda5
UUID=782be3a2-d6d4-4a88-93f2-0561f8c82891 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0
ubuntu@ubuntu:~$

Luke Faraone (lfaraone) said : #4

oops, wrong button

zimbatm (zimbatm) said : #5

Hmm. So the "ls -l" was also generated from the livecd ? In the fact is was "ls -l /media/disk-1/etc/fstab" ?

Luke Faraone (lfaraone) said : #6

I just reinstalled.