Bad video mode used during the graphical startup (and shutdown) and text console.

Asked by Jarno Suni on 2006-09-13

During the graphical startup and during text console launched by Ctrl+Alt+F1, for instance, the screen is barrel distorted and my monitor (MAG DJ707) displays some text that advises to select certain video mode. The text is on top of everything else displayed on the screen, and I have to use the monitor button to get rid of it. How can I tell linux to use a more suitable video mode ?

Graphichs card is Matrox Graphics, Inc. Millennium G450 32Mb SDRAM Dual Head. The problem has been only with the MAG DJ707 monitor, not with other monitors.

My distro is Xubuntu Dapper.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Dean Sas
Solved:
2006-09-16
Last query:
2006-09-16
Last reply:
2006-09-15
Jarno Suni (jarnos) said : #1

To be more specific, the monitor advices to select different video mode. Preferred modes, one of which is 1024x768 75Hz, are displayed.

Dean Sas (dsas) said : #2

I think the page https://help.ubuntu.com/community/FixVideoResolutionHowto has a section on this problem - that may prove to be useful.

Jarno Suni (jarnos) said : #3

Thanks, but I did not find a way to change the video mode used during startup before the login screen or during text console.

Dean Sas (dsas) said : #4

Oh sorry, I didn't realise what part of startup you meant.

It seems like a bit of a misfeature of your monitor to stomp all over your resolution choice, but that's just my opinion.

I've never tried to do this but this page has something you might try: http://www.linuxquestions.org/questions/showthread.php?t=478202

Jarno Suni (jarnos) said : #5

Well the mode is unusable anyway, since it is heavily distorted. The screen is not distorted in the very beginning, but during the graphical part of startup (when there is the growing horizontal bar indicating the phase of loading Xubuntu).

The 'a' command did not work in grub menu. Should I edit menu.lst instead?

Dean Sas (dsas) said : #6

If you're comfortable with doing that it should give the same effect yes.

Jarno Suni (jarnos) said : #7

I have not yet got into Grub, but do you think configuring Grub would affect the video mode of a text console launched from Xfce, too? (I am going to try it on floppy so I don't corrupt the Grub on hard disk.) On the other hand, in which phase of startup xorg.conf is applied first time? (When using the latest Matrox driver and XFree86, there is an option "UseMode3Vga" for XF86Config, that might be related to the problem: ftp://ftp.matrox.com/pub/mga/archive/linux/2006/readme-mga-4.4.0.txt provided I got it right. But this is xorg.conf...)

Dean Sas (dsas) said : #8

The link I gave above effects startup and consoles launched through ctrl+alt+F*, it works by grub passing on extra options to the linux kernel rather than grub actually doing anything itself.

if you mean a console as in a ctrl+alt+f1 then xorg doesn't have anything to do with that as far as I know.

Jarno Suni (jarnos) said : #9

You are right. I got better mode working by following instructions at
http://www.ubuntuforums.org/showpost.php?p=1327258&postcount=2

toxic (nesehare) said : #10

hi i have installed ubuntu for the first time,was exited to test it..i come to the startup option where i must chose between windows xp or ubuntu..

i press ubuntu..it loads....then the only picture i see is many collors.cant see anything else....

i have am2 6400 x2 with 1024mb ram
grafic card is a nvidia g-force 7600 GT

what is wrong??

Jarno Suni (jarnos) said : #11

toxic: Maybe better to ask that in its own thread.