Tibia works good in Fluxbox but behaves strange in GNOME

Asked by Fred on 2007-11-13

I am using Ubuntu 7.10 Gutsy Gibbon.
I am playing this game called 'Tibia', an MMORPG game.

It works perfectly when using Fluxbox.

But when I use GNOME the game behaves strange in windowed-mode (running it fullscreen makes it work perfect though).
Example, you can't open chat channels with people, by right-clicking their name and selecting "Message <player>" in the menu.
You cant safe-trade with players by right-clicking on them, and selecting "Trade with..." in the menu.

Game works perfectly in Fluxbox.
Game works perfectly in GNOME when game runs in fullscreen-mode.
Game behaves a bit strange when running in GNOME in windowed-mode. Why?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Clóvis Fabrício
Solved:
2007-11-13
Last query:
2007-11-13
Last reply:
2007-11-13
Best Clóvis Fabrício (nosklo) said : #1

Are you using 3D desktop effects (aka compiz)?
If so, disable them and try again.
You can go System -> Preferences -> Appearance to disable them.

Fred (eldmannen+launchpad) said : #2

Thanks for your help.

This worked now. When I turn of Visual Effects, the game works as intended.

But I pretty recently installed Ubuntu on my computer. Before I was running Windows XP (I still run it some).
And one of reasons I installed Ubuntu, is that I saw people using these totally awesome cool visual effects on videos on YouTube.
So I wanted to have those cool visual effects, so I installed Ubuntu.

Why does the game behave strange when visual effects are enabled?

Can't I have desktop visual effects enabled and it still work?

Clóvis Fabrício (nosklo) said : #3

Desktop effects are still pretty much experimental. Some software have issues, specially graphic intensive ones (games).

You can make a script to disable them when launching tibia and reenable when tibia is closed.

Fred (eldmannen+launchpad) said : #4

Okay..

Please, tell the Compiz guys to fix this, so that in the future, I can enjoy a pretty desktop that is also functional.
So that I can enjoy a pretty desktop and also enjoy games.

Fred (eldmannen+launchpad) said : #5

Thanks ClovisFabricio, that solved my question.

Clóvis Fabrício (nosklo) said : #6

You can tell them yourself, the "compiz guys" can be reached here:

http://www.compiz-fusion.org/

They have a forum: http://forum.compiz-fusion.org/
And a bugtracking system: http://bugs.opencompositing.org/

Fred (eldmannen+launchpad) said : #7

I don't have account on forum or bugstracker. :(