VMWare-player fails to load monitor with the latest kernel (2.6.15-26)

Asked by Júlio Santos Monteiro on 2006-09-10

When installing vmware-player in a fresh installed Ubuntu, I get the following error:

------------------------cut it here------------------------
Starting VMware services:
Virtual machine monitor failed
Virtual ethernet failed
Module vmnet is not loaded. Please verify that it is loaded before
running this script.

invoke-rc.d: initscript vmware-player, action "start" failed.
dpkg: erro processando vmware-player (--configure):
subprocesso post-installation script retornou código de saída de error 1
Erros foram encontrados durante processamento de:
vmware-player
E: Sub-process /usr/bin/dpkg returned an error code (1)
------------------------cut it here------------------------

I have already trying reinstalling and purging it. I alwayis recieve this strange error.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Júlio Santos Monteiro
Solved:
2006-09-10
Last query:
2006-09-10
Last reply:

My goal is installing vmware-player in the Ubuntu 6.06.1 machine :-).

The apt-get is with all repo's in the source list, and is apt-get updated and upgraded.

Problem solved.

It is installed the kernel 2.6.15-26 (the lattest), but there are only modules for kernel 2.6.15-23 (the vmware-player-kernel-modules-2.6.15-23 package).

I installed the 2.6.15-23 kernel, rebooted in it and retryed to reinstall vmware, and it worked!

Thanks for the attention :-)