app install problem

Asked by jason sanche on 2006-09-09

I just installed Dapper Drake 6.06 LTS and some applications have been failing to install. Everything through the application manager and synaptic has worked but at least 3 installs from other sources had problems.

firstly, YamiPod, a standalone binary file application which should open according to the instructions I followed in http://www.linuxjournal.com/article/9266 (command: sudo cp libfmodex.so.* /usr/lib) and then the binary file for the application just wouldn't open and the developer suggested the following which I did:

komuso@komuso:~$ cd yam-linux
komuso@komuso:~/yam-linux$ sudo chmod 777 YamiPod
Password:
komuso@komuso:~/yam-linux$ ./YamiPod
Cannot find libxine
Segmentation fault
komuso@komuso:~/yam-linux$

after which the developer of Yamipod asked if I had a 64 bit CPU. ? I assume I have as it is intel pentium II (but not sure how to verify).

secondly I tried to install gpixpod from sourceforge (a version made for ubuntu) which opens in gdebi and comes up with: error: dependancy is not satisfiable python-support

thirdly I tried to install gnupod which returned a script to install xml parser which I then tried and failed, script below. If anyone has any ideas it would be greatly appreciated. :]

komuso@komuso:~$ cd gnupod-0.99
komuso@komuso:~/gnupod-0.99$ #./configure
komuso@komuso:~/gnupod-0.99$ #make install
komuso@komuso:~/gnupod-0.99$ ./configure
checking for perl-5.8... no
checking for perl-5.6... no
checking for perl... /usr/bin/perl
GNUpod will use /usr/bin/perl
checking for Digest::MD5... ok
checking for XML::Parser... failed!
** You need to install XML::Parser
** Visit <http://search.cpan.org> to get the module
** Or try this:
# perl -MCPAN -e 'install XML::Parser'

which I tried and after a lot of script and what seems like building the parser kit I got:

Checking if your kit is complete...
Looks good
Writing Makefile for XML::Parser::Expat
Writing Makefile for XML::Parser
    -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Luca Falavigna
Solved:
2006-09-16
Last query:
2006-09-16
Last reply:
2006-09-16
Luca Falavigna (dktrkranz) said : #1

Try to install the the following packages with Synaptic: libxine-dev, libxine-main1 python-support and libxml-parser-perl.

jason sanche (jsan321) said : #2

That seems to work for yamipod, it opened after installing libxine-dev. Although after installing python-support, gpixpod install on gdebi still gave the same "error: dependancy is not satisfiable python-support" message. Are there other python packages that might be needed to run it?

Thanks for the help. :}

jason sanche (jsan321) said : #3

The gpixpod app is now returning error: dependancy not satisfiably libc6 and synaptic shows it as being installed. Also, as I try to install several packages like java and flashplugin, and others through synaptic, the download often fails, connection reset by peer. Is there anything I can do? I've downloaded frostwire but it just doesn't open, which I suspect is due to a java error. I used automatix as a last resort but it also seemed to return failures and the programs requested don't seem to be installed... vat to do?

Luca Falavigna (dktrkranz) said : #4

Could you please send me the dependencies of these packages?

jason sanche (jsan321) said : #5

How do I find the dependencies? I'm sorry Im new to linux.

All I can gather for gpixpod is that the dependecy libc6 is causing an error (not satisfiable) but libc6 is installed according to synaptic. Frostwire, which runs on java is installed but not opening because java isn't installed and java wont install because when I try to install something through either synaptic or get-app the download fails: "104 connection reset by peer".

I get these warnings from synaptic after trying to install java:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/u/unixodbc/odbcinst1debian1_2.2.11-11build1_i386.deb
  503 Service Unavailable [IP: 195.248.90.54 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/u/unixodbc/unixodbc_2.2.11-11build1_i386.deb
  503 Service Unavailable [IP: 195.248.90.54 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/multiverse/s/sun-java5/sun-java5-bin_1.5.0-06-1_i386.deb
  Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.54 80]
....

And when I re-added the universe and multiverse repository just to be sure it was added, it returned:

http://archive.ubuntu.com/ubuntu/dists/dapper/universe/binary-i386/Packages.gz: Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.23 80]

Is something wrong with the ubuntu side? My internet connection is working fine... But then again, when I tried to install plugins for a page in firefox that needed flash and java there were failures too... Sorry I can't be more specific...

The following is script from java install attempt:

komuso@komuso:~$ sudo apt-get install sun-java5-bin
Password:
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  odbcinst1debian1 sun-java5-jre unixodbc
Suggested packages:
  sun-java5-plugin ia32-sun-java5-plugin sun-java5-fonts libmyodbc
  odbc-postgresql libct1
Recommended packages:
  gsfonts-x11
The following NEW packages will be installed:
  odbcinst1debian1 sun-java5-bin sun-java5-jre unixodbc
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 29.8MB of archives.
After unpacking 84.4MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  odbcinst1debian1 unixodbc sun-java5-bin sun-java5-jre
Install these packages without verification [y/N]? y
Get:1 http://archive.ubuntu.com dapper/main odbcinst1debian1 2.2.11-11build1 [63.8kB]
Get:2 http://archive.ubuntu.com dapper/main unixodbc 2.2.11-11build1 [269kB]
Err http://archive.ubuntu.com dapper/main unixodbc 2.2.11-11build1
  Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.54 80]
Get:3 http://archive.ubuntu.com dapper/multiverse sun-java5-bin 1.5.0-06-1 [22.1MB]
Err http://archive.ubuntu.com dapper/multiverse sun-java5-bin 1.5.0-06-1
  Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.54 80]
Get:4 http://archive.ubuntu.com dapper/multiverse sun-java5-jre 1.5.0-06-1 [7341kB]
Err http://archive.ubuntu.com dapper/multiverse sun-java5-jre 1.5.0-06-1
  Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.54 80]
Fetched 63.8kB in 5m8s (207B/s)
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/u/unixodbc/unixodbc_2.2.11-11build1_i386.deb Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.54 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/multiverse/s/sun-java5/sun-java5-bin_1.5.0-06-1_i386.deb Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.54 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/multiverse/s/sun-java5/sun-java5-jre_1.5.0-06-1_all.deb Error reading from server - read (104 Connection reset by peer) [IP: 195.248.90.54 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Laurens Simonis (laurens.s) said : #6

At the moment you were trying to download, there were very clearly trouble somewhere between your PC and ubuntu's server. Have you tried it again since?

jason sanche (jsan321) said : #7

Yes, after the weekend the connection was much better and I was able to download and install everything on the first or second try.

At first, frostwire continued to generate errors looking for Java upon opening even though java was installed and it wasn't until I selected both Frostwire and Java to install together through automatix (which didn't install anything since they were both already installed but did something minor to link the dependency or something like that..) which corrected the problem and frostwire opened. Similarly, yamipod worked when I used easybuntu to install all the various multimedia packages etc.

The only unresolved problem is with a program called gpixpod, http://sourceforge.net/project/showfiles.php?group_id=157492&package_id=176164&release_id=446180
as mentioned above, which installs with gdebi and generates the error: dependency is not satisfiable: libc6 even though libc6 is already installed. This one I can't figure out what else it needs... Is there a way to have a .deb file install manually in terminal so I can see what is going on?

Thanks for your help, Jason

Luca Falavigna (dktrkranz) said : #8

Do you have Sun's Java Virtual Machine installed or another package?

Dean Sas (dsas) said : #9

gpixpod is a python program, so it must be a dependency of a dependency that's causing the issue.

Could you run "dpkg --info gpixpod.deb | grep Depends" in a terminal (applications -> accessories -> terminal) You might need to change "gpixpod.deb" to the actual name of the .deb file you're trying to install.

jason sanche (jsan321) said : #10

I ran the above and got:

komuso@komuso:~$ dpkg --info gpixpod_0.6.0-0ubuntu1_i386.deb | grep Depends
 Depends: libatk1.0-0 (>= 1.9.0), libc6 (>= 2.4-1), libcairo2 (>= 1.0.2-2), libfontconfig1 (>= 2.3.0), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.8.0), libpango1.0-0 (>= 1.12.3), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxfixes3, libxi6, libxinerama1, libxrandr2, libxrender1, python (<< 2.5), python (>= 2.4), python-support (>= 0.2), python2.4-gtk2 (>= 2.8), python2.4-glade2 (>= 2.8)

Then cross-checked with synaptic and though I have all the dependencies listed, two of them (in fact the ones that have been causing the error message) are an earlier version than what is called for by gpixpod. Synaptic showed the following: libc6 (2.3.6-0ubuntu20) and python-support (0.1.1ubuntu1) and also that those are the latest versions available. gpixpod calls for libc6 (>= 2.4-1) and python-support (>= 0.2)

Is there a way to get later versions for ubuntu?

BTW, Luca, I do have SunJava5 JRE and webstart installed. Is that what you mean by virtual machine?

Thanks again:)

We're getting warmer...

Dean Sas (dsas) said : #11

The good answer is yes you can get the later versions (http://packages.ubuntu.com), the bad answer is, it may break your system in doing so. libc6 is one of the main packages on your system that lots of programs depend upon, upgrading it may break any one of them, I wouldn't risk it.

Ubuntu 6.10 when released will be able to satisfy all of those dependencies, if you can wait until October to use gpixpod that will be the best course of action.

jason sanche (jsan321) said : #12

Okay, I can wait until October. Thanks for your help!