Better 5250 (AS/400) Emulation Software for Ubuntu

Asked by Mattes on 2006-09-09

I am looking for a 5250 emulation software, that runs in Ubuntu.

I should be the same functions as the software IBM iSeries Access.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Luca Falavigna
Solved:
2006-09-18
Last query:
2006-11-16
Last reply:
2006-11-20
Mattes (schattematthias) said : #2

I have already installed tn5250, but ist has no grafical user interface.

I am looking for iseriesaccess for ubuntu linux (i have still downloaded iseriesaccess for suse linux, but it doesn't run under ubuntu).

Luca Falavigna (dktrkranz) said : #3

If you have the .rpm package, you can use alien to convert it into a .deb package.

Mattes (schattematthias) said : #4

I had used alien but, when i try to install the deb package, there are a lot of errors. So i can't install it.

Luca Falavigna (dktrkranz) said : #5

Have you tried with alien --script package.rpm?

Mattes (schattematthias) said : #6

I have downloaded RPM for Ubuntu.
I tryed:
rpm -ivh iSeriesAccess-5.2.0-1.14.i386.rpm
but there are this error messages:
Fehler: Failed dependencies:
        /bin/sh is needed by iSeriesAccess-5.2.0-1.14.i386
        ld-linux.so.2 is needed by iSeriesAccess-5.2.0-1.14.i386
        libICE.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libSM.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libX11.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libXext.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libXm.so.3 is needed by iSeriesAccess-5.2.0-1.14.i386
        libXmu.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libXp.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libXpm.so.4 is needed by iSeriesAccess-5.2.0-1.14.i386
        libXt.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libc.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libc.so.6(GLIBC_2.0) is needed by iSeriesAccess-5.2.0-1.14.i386
        libc.so.6(GLIBC_2.1) is needed by iSeriesAccess-5.2.0-1.14.i386
        libc.so.6(GLIBC_2.1.3) is needed by iSeriesAccess-5.2.0-1.14.i386
        libc.so.6(GLIBC_2.2) is needed by iSeriesAccess-5.2.0-1.14.i386
        libdl.so.2 is needed by iSeriesAccess-5.2.0-1.14.i386
        libdl.so.2(GLIBC_2.0) is needed by iSeriesAccess-5.2.0-1.14.i386
        libdl.so.2(GLIBC_2.1) is needed by iSeriesAccess-5.2.0-1.14.i386
        libgcc_s.so.1 is needed by iSeriesAccess-5.2.0-1.14.i386
        libgcc_s.so.1(GCC_3.0) is needed by iSeriesAccess-5.2.0-1.14.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by iSeriesAccess-5.2.0-1.14.i386
        libm.so.6 is needed by iSeriesAccess-5.2.0-1.14.i386
        libm.so.6(GLIBC_2.0) is needed by iSeriesAccess-5.2.0-1.14.i386
        libm.so.6(GLIBC_2.1) is needed by iSeriesAccess-5.2.0-1.14.i386
        libm.so.6(GLIBC_2.2) is needed by iSeriesAccess-5.2.0-1.14.i386
        libodbc.so.1 is needed by iSeriesAccess-5.2.0-1.14.i386
        libodbcinst.so.1 is needed by iSeriesAccess-5.2.0-1.14.i386
        libpthread.so.0 is needed by iSeriesAccess-5.2.0-1.14.i386
        libpthread.so.0(GLIBC_2.0) is needed by iSeriesAccess-5.2.0-1.14.i386
        libpthread.so.0(GLIBC_2.1) is needed by iSeriesAccess-5.2.0-1.14.i386
        libstdc++.so.5 is needed by iSeriesAccess-5.2.0-1.14.i386
        libstdc++.so.5(CXXABI_1.2) is needed by iSeriesAccess-5.2.0-1.14.i386
        libstdc++.so.5(GLIBCPP_3.2) is needed by iSeriesAccess-5.2.0-1.14.i386
        libstdc++.so.5(GLIBCPP_3.2.2) is needed by iSeriesAccess-5.2.0-1.14.i386

Mattes (schattematthias) said : #7

With the command
rpm -ivh iSeriesAccess-5.2.0-1.14.i386.rpm --nodeps

i have installes iSeriesAccess successfully, but when i call the Programm:
./setup5250
./setup5250: error while loading shared libraries: libXm.so.3: cannot open shared object file: No such file or directory

What can i do with this error Message?

Luca Falavigna (dktrkranz) said : #8

Try to install package libmotif3: it provides libXm.so.3.

Mattes (schattematthias) said : #9

After i had installed libmotif3 there come other error messages:

setup5250: [ INFORMATIONAL ]: Build Date: 28 April 2006 (1.14)
setup5250: [ INFORMATIONAL ]: ./setup5250
setup5250: [ ERROR ]: Xt Warning: locale not supported by C library, locale unchanged.
setup5250: [ ERROR ]: Xt Warning: Missing charsets in String to FontSet conversion.
Segmentation fault

Luca Falavigna (dktrkranz) said : #10

It is very difficult to solve these problems without iSeries Access source code.
If you really need a graphical user interface, you can try TN5250j (located at http://tn5250j.sourceforge.net/).

Martin Kreiner (languste) said : #11

The IBM iSeries Access software can't handle UTF-8 and needs fallbacks. You have to generate *.ISO-8859-1 locales.
For example if your locale-settings are "de_DE.uft8" you need to:

~$ sudo locale-gen de_DE
Generating locales...
  de_DE.ISO-8859-1...

this schould help.

Mattes (schattematthias) said : #12

Hello Martin,

i have tried your solution and now it works fine.

Thanks!!!

Hi ,

I have the same problems - but ?! where can I found "RPM for Ubuntu" ????

thanx

Holger

Mattes (schattematthias) said : #14

Hello Holger,

use the program alien to convert the RPM package into a deb package.

Mattes

Mattes (schattematthias) said : #15

Hello,

now i have installed Ubuntu 6.10.
When i call ibm5250, i type my as/400 ip, user an password and klick OK, i get error messages:

5250: [ INFORMATIONAL ]: Build Date: 28 April 2006 (1.14).
5250: [ ERROR ]: NSC0017: Xt Warning: Missing charsets in String to FontSet conversion.
5250: [ ERROR ]: NSC0017: Xt Warning: Cannot convert string "-*-lucidatypewriter-medium-r-normal-*-19-*-75-75-m-*" to type FontSet.

What can i do?

Mattes

Allen S. (aschmitz) said : #16

I am getting the same error, any updated info for the fix to this.
Thanx,
Allen

Andrew Davis (papyromancer) said : #17

Check out these posts from the forums:

http://www.ubuntuforums.org/showthread.php?t=165337&highlight=iseries
http://ubuntuforums.org/archive/index.php/t-1261.html

@Mattes you need to install msttcorefonts with the with the univers repository enabled.

<pre>sudo apt-get install msttcorefonts
sudo fc-cache -f -v</pre>