mzscheme .deb broken in dapper?

Asked by krumms on 2006-09-08

Just tried to install drscheme + mzscheme. I got the following output:

tom@vanilla:~$ sudo apt-get install mzscheme
Reading package lists... Done
Building dependency tree... Done
Suggested packages:
  menu
The following NEW packages will be installed
  mzscheme
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/10.7MB of archives.
After unpacking 53.3MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package mzscheme.
(Reading database ... 234341 files and directories currently installed.)
Unpacking mzscheme (from .../mzscheme_1%3a209-9ubuntu2_i386.deb) ...
Setting up mzscheme (209-9ubuntu2) ...
Completing install...Running setup...
setup-plt: Setup version is 209
setup-plt: PLT home directory is /usr/lib/plt
setup-plt: Collection paths are
setup-plt: /usr/lib/plt/collects
setup-plt: Installing MrEd launcher /usr/lib/plt/bin/drscheme
setup-plt: Installing MrEd launcher /usr/lib/plt/bin/help-desk
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/mzc
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/mzpp
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/mztext
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/setup-plt
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/slatex
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/pdf-slatex
setup-plt: Installing MrEd launcher /usr/lib/plt/bin/slideshow
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/swindle
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/tex2page
setup-plt: Installing MrEd launcher /usr/lib/plt/bin/web-server
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/web-server-text
setup-plt: Installing MzScheme launcher /usr/lib/plt/bin/web-server-monitor
setup-plt: Post-Installing MrEd
setup-plt: Done setting up
PLT installation done.
finished
Building MzScheme zo files: This can take a LONG time (10 minutes in some cases!)
finished.
Cataloging SLIB routines...
reference to undefined identifier: with-load-pathname
dpkg: error processing mzscheme (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 mzscheme
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2006-09-08
Last reply:
2006-09-14
Michael Bienia (geser) said : #1

It is a known problem.
See https://launchpad.net/bugs/38936 for more information on the bug.

Seems like this is answered.

Can you help with this problem?

Provide an answer of your own, or ask krumms for more information if necessary.

To post a message you must log in.