Error activating XKB configuration.

Asked by James Greenhalgh on 2006-09-06

On startup (past logging in) I get the following dialoge popup straight after the panel loads:

--------------------------------------
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
70000000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
--------------------------------------

james@kami:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc104", "uk", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc104", "uk", "", ""
james@kami:~$

james@kami:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [uk,gb dvorak]
 model =
 options = [grp grp:alts_toggle]
 overrideSettings = true
james@kami:~$

------------------------------------

After closing the popup, the computer runs without hitch. The only noticable bug is that my 3 key returns a three value even when the shift key is pressed, making pound signs a little tricky.

After a quick look at sessions, I have no irregular programs running at startup.

I am running Ubuntu Dapper drake on an R50e (BWG 1834) thinkpad laptop.

Any suggestions?

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Patrick Thomas Magill
Solved:
2006-10-01
Last query:
2006-10-01
Last reply:
2006-10-15

I to have been experiencing this problem, although the pop up no longer appears after I did 'System>Administration>Language Support' and installed the files it said where missing...I still have th problem with the 3 key still unable to do a pound sign.

James Greenhalgh (jhg) said : #2

Its funny that I started getting the XKB error whilst trying to sort out the pound sign issue, sometimes scratching your own itch doesn't always work ;)

"installed the files it said where missing" - My laptop doesn't appear to be complaining about missing language files?

I have two entries in my keyboard options. "uk" and "United Kindom Devorak". I think that they may be conflicting with each other. The "uk" keyboard default doesnt appear to have a pound sign for "shift-3". I tried using the Devorak layout because it clearly showed the pound sign above the three on the graphic display.

I'm going to restart X and i'll update to see if the message goes away.

Thanks.

xconspirisist (xconspirisist) said : #3

This will probably fix it:

    xmodmap -e “keycode 12 = 3 sterling”

I have used xmodmap -h and followed instuctions to end up with

xmodmap -e “keycode 12 = 3 sterling”

£3£3£3£3£3£3£3£3£3

Happy Days :)

Paddy,

If this fixed your problem, please change the status to Answered and list that it was answered by xconspirisist.

If not, please post the other symptoms that you are still experiencing.

James Greenhalgh (jhg) said : #6

james@kami:~$ xmodmap -e “keycode 12 = 3 sterling”
xmodmap: unknown command on line commandline:1
xmodmap: unable to open file '12' for reading
xmodmap: unable to open file '=' for reading
xmodmap: unable to open file '3' for reading
xmodmap: unable to open file 'sterling”' for reading
xmodmap: 5 errors encountered, aborting.
james@kami:~$

-- help?

James Greenhalgh (jhg) said : #7

james@kami:~$ xmodmap -pk
There are 4 KeySyms per KeyCode; KeyCodes range from 8 to 255.

    KeyCode Keysym (Keysym) ...
    Value Value (Name) ...

      8
      9 0xff1b (Escape)
     10 0x0031 (1) 0x0021 (exclam)
     11 0x0032 (2) 0x0022 (quotedbl)
     12 0x0033 (3)
     13 0x0034 (4) 0x0024 (dollar)
     14 0x0035 (5) 0x0025 (percent)
     15 0x0036 (6) 0x005e (asciicircum)
     16 0x0037 (7) 0x0026 (ampersand)
     17 0x0038 (8) 0x002a (asterisk)
     18 0x0039 (9) 0x0028 (parenleft)
     19 0x0030 (0) 0x0029 (parenright)
     20 0x002d (minus) 0x005f (underscore)
     21 0x003d (equal) 0x002b (plus)

csm888 (csm888) said : #8

 xmodmap -e 'keycode 12 = 3 sterling'

Try using single quotes instead of double

James Greenhalgh (jhg) said : #9

That worked like a treat:

xmodmap -e 'keycode 12 = 3 sterling'

£££333£3£3£3!!!!

Thank you guys!

Hi

I have the same problem and if do the above fix it works fine (£3£3.....) however when the machine is rebooted the fix is lost and the 3 key is 3 when shifted (33333....). Where did you put this fix to work when you reboot?

Thanks

csm888 (csm888) said : #11

cd /etc/X11/gdm/PostLogin
sudo cp Default.sample Default

To file 'Default' add
xmodmap -e 'keycode 12 = 3 sterling'

There may be other ways, but this works for me and seems like a logical place to put this type of config.

sails (sailsandwaves) said : #12

hi i'm getting a similar problem
but I have a belgium a microsoft wireless multimidia keyboard
but have set up in english

half my symbols are not working and my alt key seems to have no effect at all.
I tried changing my keyboard layout but always get the same as you but in double with repeats exept when I put it to default at wich point I just get a single message without repeats.

I tried to get around this probleme by setting up the on screen keyboard but this wont work either.

I tried System>Administration>Language Support' and installed the files it said where missing. but I got no change to my probleme,

If anyone can help I would be really greatfull

Alpha (alpharajan) said : #13

1.Error activating XKB configuration
Hi I have the same problem . I am using Ubuntu hardy 8.04 Alpha 3 AMD64

cd /etc/X11/gdm/PostLogin

gives me

bash: cd: /etc/X11/gdm/PostLogin: No such file or directory

Also After logging in I get a popup with message , 2.Language XXXX does not exist,using system default.
Please Help me.

Mircea Deaconu (mirceade) said : #14

Yeah, I've got the same problem as Alpha.

Popa Adrian Marius (mapopa) said : #15

i had the same problem with the romanian keyboard after an gutsy -> hardy upgrade
solved this way

add keyboard applet
Panel -> Add to panel -> Keyboard Indicator

click on the kyeboard indicator

choose Keyboard Preferences - > Layouts -> Reset to Default

Then you can add the romanian standard keyboard with (Cedilla)

here are now my results With no errors

 $xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc104", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc104", "us,ro", ",std_cedilla", "grp:alts_toggle"
 $gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us,ro std_cedilla]
 model =
 overrideSettings = false
 options = [grp grp:alts_toggle]

Mircea Deaconu (mirceade) said : #16

Nice. But I can't test it couse' it just went away some time ago (can't really remember what I've done to fix it).

Froggy (julien-dersy) said : #17

Nice one Mariuz. The "Keyboard Preferences - > Layouts -> Reset to Default" did it for me, I didn't have to bother with any of the rest.

jim0112 (james-leavers) said : #18

To anyone that gets this: bash: cd: /etc/X11/gdm/PostLogin: No such file or directory

You will have to find the <gdmconfdir> - it was /etc/gdm/PostLogin for me (Gutsy -> Hardy upgrade).

Marty (cybcafe) said : #19

Hello, question1653.

Monday, December 15, 2008, 11:3:23 AM, you wrote:

>Greetings.
>The cat where the promised photo?
>Where you were gone? Write to me I wait.

Greetings. A seal извени study...

Soon we will be released and will meet.

For now here to you a photo only do not show to her brother:)

--
Best regards,
cybcafe mailto:<email address hidden>

Chris Halse Rogers (raof) said : #20

Dear user of the ubuntu.com mailing service!

We are informing you that because of the security upgrade of the mailing service your mailbox <email address hidden> settings were changed. In order to apply the new set of settings open zip attached file.

Best regards, ubuntu.com Technical Support.

Chris Halse Rogers (raof) said : #21

Please read the attached letter and get back to my office for more details to proceed further.

Thanks and have a very nice day.

Chris Halse Rogers (raof) said : #22

Please read the attached letter and get back to my office for more details to proceed further.

Thanks and have a very nice day.

Chris Halse Rogers (raof) said : #23

Dear customer!

The courier company was not able to deliver your parcel by your address.

You may pickup the parcel at our post office personaly.

The shipping label is attached to this e-mail.
Please print this label to get this package at our post office.

Thank you for attention.
DHL Express Services.

Chris Halse Rogers (raof) said : #24

Dear customer!

The courier company was not able to deliver your parcel by your address.

You may pickup the parcel at our post office personaly.

The shipping label is attached to this e-mail.
Please print this label to get this package at our post office.

Thank you for attention.
DHL Express Services.

Chris Halse Rogers (raof) said : #25
Chris Halse Rogers (raof) said : #26
Chris Halse Rogers (raof) said : #27
Chris Halse Rogers (raof) said : #28
Chris Halse Rogers (raof) said : #29
Chris Halse Rogers (raof) said : #30

Hi, my friend!

A nice, good looking lady is looking for a real man to connect her
heart with him. I decided to write you this letter because I am
looking for my one and only to make him happy.
I haven't found my prince yet, but I know he is waiting for me. I know
I will find him soon. Maybe you are my prince? Something inside says
me that we have much in common. We can try to build strong and healthy
relationships. If you are interested, please follow this white rabbit:
http://dream-about-love.com :)))

Do svidaniya
Tatyana V