Cannot load the atheros module on gutsy server

Asked by Tom Goh

I have installed the restricted drivers for gutsy server. I can see the modules in

/lib/modules/2.6.22-14-generic/madwifi

But it is not in

/lib/modules/2.6.22-14-server

So I am not sure if the module is getting recognized when I boot.

lsmod does not show it. Have tried to mess around with depmod and modprobe but not successful.

Can provide the instructions to get the ath_pci module to load. If that is the correct module to load.

Thanks,

Tom

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Tom Goh
Solved:
Last query:
Last reply:
Revision history for this message
odysiuss (bilal-hmouda) said :
#1

try
modinfo ath_pci
either will show an error or it will show the recent version you have
http://patches.aircark-ng.org/madwifi-ng-r2277.patch
this is the latest ,i installed it but for some reason ubuntu still using the older one 2.6

Revision history for this message
Tom Goh (tomgohj) said :
#2

Actually I got everything working at first using the desktop version so I know everything works.

when I run uname -a I get 2.6.22-14-server

So I know it is loading modules from

/lib/modules/2.6.22-14-server

So I attempted to copy the madwifi modules from

/lib/modules/2.6.22-14-generic/madwifi
to
/lib/modules/2.6.22-14-server

and ran

sudo modprobe -v ath_pci

insmod /lib/modules/2.6.22-14-server/wlan.ko
WARNING: Error inserting wlan (/lib/modules/2.6.22-14-server/wlan.ko): Invalid module format
insmod /lib/modules/2.6.22-14-server/ath_pci.ko
FATAL: Error inserting ath_pci (/lib/modules/2.6.22-14-server/ath_pci.ko): Invalid module format

So my presumption is that the kernel module ath_pci and its dependencies is not compile for the 2.6.22-14-server kernel (but I am not an expert so I am only guessing).

I am presuming I have to recompile the module.

Just found out something else

when I run modinfo ath_pci I get

....
vermagic: 2.6.22-14-generic SMP mod_unload 586
....

Revision history for this message
Stephen Drake (spd106) said :
#3

You need the linux-restricted-modules-2.6.22-14-server package.

But I don't think it actually exists.
https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.22/+bug/153011

Your options are:

1) Contact the kernel team and ask nicely for a -server build.
2) Make a -server build yourself.
3) Download the madwifi source from madwifi.org and build the modules yourself.

You will have to repeat 2 or 3 every time a kernel update is released.

Revision history for this message
Tom Goh (tomgohj) said :
#4

I have solved the problem.

What I did was to recompile new madwifi modules using module assistant. Also I had to plug in via a wired network to get internet first.

First download the madwifi-source from Debian, for some reason it is not on the Ubuntu repository.

wget http://http.us.debian.org/debian/pool/non-free/m/madwifi/madwifi-source_0.9.3.2-2_all.deb

sudo dpkg -i madwifi-source_0.9.3.2-2_all.deb

Install packages (Note that some of the packages may not be necessary but this is how a I did it.)

sudo apt-get install module-assistant gcc linux-headers-$(uname -r)

sudo apt-get install linux-headers-server

sudo apt-get install build-essentials

Run Module assistant

sudo module-assistant autoassistant

> Select "Update"
> Select "Prepare" (think it only tries to install build-essentials so doesn't do anything) just did it incase...
> Select "Select" > Select "Madwifi" > Selected "Build" > Follow instructions I think it will ask you if you want to install it. I selected yes
> Select "Install" (Think it is already done but just did it anyway)

If you run into trouble there should be a log and you can also check out if you are missing stuff in the section
> Select "Select" > Select "Madwifi" > list/search

Revision history for this message
Tom Goh (tomgohj) said :
#5

good project would be to learn how to make it a deb file