I've deprevided my rootrights

Asked by Tim Feddern on 2006-09-06

Hello,

i'am German, but i'll try to tell you my problem in English.

I am a new Ubuntuuser. I don't usesd Linux before.

Ubuntu is really easy to install - but now i've deleted my own administrationrights.

I can log in wih "tim" and my password.
I tryed already to change teh user to root wih the console.

"su root"
Then i had to enter the password. I took my own for the tim-account. This failed.

How i can reget my rights? I don't want to reset my system.

I hope you understood my little problem and want to help me.
Please awnser in 5th-klass-english :)!

Best regards
Tim

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2006-09-07
Last reply:
2006-09-07
Luca Falavigna (dktrkranz) said : #1

root account is disabled for security reasons.
In order to get root privileges, you have to use "sudo -i" and type in your tim's password.

Tim Feddern (tim-feddern-hh) said : #2

Okay,

i wrode "sudo -i" and enterd my password.

But now i've still under System > Administration only five irrelevant points. This list was before much bigger.

That sounds like you have deleted some administration programs. Search for them in synaptics.

Dean Sas (dsas) said : #4

What groups are you in? I think perhaps you need to be in the admin group for those administration programs (gnome-system-tools) to show up.

Luca Falavigna (dktrkranz) said : #5

You could also use Alacarte menu editor to manage those items.

Tim Feddern (tim-feddern-hh) said : #6

I don't know what "synaptics" is.

I don't know in wich group i am.

And i don't know what i can do withe the editor to get my rights back.

Sorry, i am a blody beginner, i don't know anything ;)!

Dean Sas (dsas) said : #7

synaptic is the package manager (system->administration->synaptic package manager), you could check that gnome-system-tools is installed (I don't think this is your problem) using it.

To get a list of the groups you are in, open a terminal (applications -> accessories -> terminal) then type "groups". (I'm unsure this is your problem either tbh)

Dean Sas (dsas) said : #8

could you also see whether running "gksudo services-admin" in a terminal starts up a program?

Tim Feddern (tim-feddern-hh) said : #9

I found under Acelerate meue Editor the Options for the Admiistrationsofftware (Update ...).

They all are checked, but i can't start them :(.

Tim Feddern (tim-feddern-hh) said : #10

And as i wrode "groups" into the terminal he schowed me only my account.

Dean Sas (dsas) said : #11

That's odd, you shouldn't be able to run any sudo command if you're not in the admin group.

Can you try running "sudo usermod -G admin tim" ?

Tim Feddern (tim-feddern-hh) said : #12

I tryed: "sudo usermod -G admin tim".
Then i enterd my password.

Nothin happend, i can now write in the next line^^. The Adminpanel istn't there.

Dean Sas (dsas) said : #13

You shouldn't need to use the quotation marks when typing it in the terminal BTW

What does the groups command give you now?

Tim Feddern (tim-feddern-hh) said : #14

Of couse i didn't used the quotation marks!

There is only my name after the password.

Can you help with this problem?

Provide an answer of your own, or ask Tim Feddern for more information if necessary.

To post a message you must log in.