Can't enable desktop effects

Asked by Chris Cranford on 2007-11-05

Is there any way to get an ATI card to be able to have desktop effects?

I finally got Ubuntu working, and I'm liking it so far... Having the snazzy effects and all would be the icing on the cake (and the thing that would make me abandon Vista).

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jan-Philipp Litza (jplitza) said :
#1

Basically, yes, it should be possible to get the effects with an ATI card. But it hardly depends on what card you have. The problem probably lies in the direct rendering not being supportet by the 'ati' driver. You need either the 'radeon' or the 'fglrx' driver. Look here to determine which one's right for your card: https://help.ubuntu.com/community/RestrictedDrivers/ATI
When you have found out, which one you need, you'll find more information here how to install them:
https://help.ubuntu.com/community/BinaryDriverHowto/ATI (for fglrx)
https://help.ubuntu.com/community/RadeonDriver (for radeon)

Revision history for this message
Qwerty Maniac (qwertymaniac) said :
#2

Install the drivers using Envy for ATi and you should be ready to go with Desktop Effects:

Envy and instructions can be found here:
http://blog.shevin.info/2007/04/how-to-implement-babylon-dictionaries.html

Revision history for this message
Qwerty Maniac (qwertymaniac) said :
#3

Oops, wrong link, damn Clipboard:
Its here -> http://albertomilone.com/nvidia_scripts1.html

Regrets

Revision history for this message
Hamad Alshehhi (sezoom) said :
#4
Revision history for this message
Chris Cranford (cccranford) said :
#5

Well, I had the fglrx driver installed with composite enabled, and it just tells me that it can't enable the effects.

I'm trying the Envy thing Qwerty suggested right now... Hopefully it'll work!

Revision history for this message
Chris Cranford (cccranford) said :
#6

Okay, tried the Envy thing, still getting 'Desktop effects could not be enabled.'

Trying Hamad's suggestion now. I have a question, though. Will those instructions (which are for Feisty) work with Gutsy?

Thanks.

Revision history for this message
Albert Damen (albrt) said :
#7

Which ATI card do you have precisely?
Some ATI cards are not supported by Compiz and have been blacklisted. These are the identification numbers of the blacklisted cards:
T=" 1002:5954 1002:5854 1002:5955" # ati rs480
T="$T 1002:4153" # ATI Rv350
T="$T 1002:3152 1002:3150 1002:5462 1002:5653 " # ati X300 X600,X600 X700

You can find the identification number for your card by using the following command in a terminal window:
lspci -vn | grep VGA

If the number consisting of "4 characters : 4 characters" is listed above, compiz will not work on your ATI card.

Revision history for this message
Hamad Alshehhi (sezoom) said :
#8

This is must work for you, this solution for all ATI RADEON X600 ATI RADEON X800 ATI RADEON X1300 ATI RADEON X1600 ATI RADEON 9000 and OTHER radeons

http://ubuntuforums.org/showthread.php?t=592016&highlight=ati

wish u get ride of it

Can you help with this problem?

Provide an answer of your own, or ask Chris Cranford for more information if necessary.

To post a message you must log in.