When i turn off my computer a warning concerning Network Manager is displayed and the PC is not turned off automatically

Asked by Darina on 2007-11-03

When i shut down my computer a black screen appears with the following message:

Network Manager: <WARN> nm_hal_deinit(): libhal shutdown failed - Connection is closed

Network Manager: nm_dbus_signal_device_status_change: assertion 'cb_data -> data -> dbus_connection' failed

Then the computer is not turned off. To turn it off i need to reboot the hard way then turn off before any system loaded.

I connect to Internet via PPPOE protocol, the Roaring Penguin is configured. There are no problems with my Internet connection. Any ideas what that might be and how to remove this message and shut down my PC normally?

***
Ubuntu 7.10 Gutsy Gibbon
I-net connection via lan card and the pppoe protocol
***

Thanks :) Your help is much appreciated!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
Last query:
Last reply:
Revision history for this message
Darina (darina-gr) said :
#1

Some additional info. Today when i turned off my PC it gave me more info:

Network Manager: <WARN> nm_signal_handler (): Caught signal 15, shutting down normally

Network Manager: <info> Caughjt termination signal

Network Manager: <debug> [1194085800.188683] nm_print_open_socks (): Open sockets List:

Network Manager: <debug> [1194085800.188817] nm_print_open_socks (): Open Sockets List Done.

Network Manager: <info> Deactivating device eth0

Network Manager: <WARN> nm_hal_deinit(): libhal shutdown failed - Connection is closed

Network Manager: nm_dbus_signal_device_status_change: assertion 'cb_data -> data -> dbus_connection' failed

This all started after the upgrade from Fiesty Fawn to Gutsy Gibbon.

Thanks in advance.

Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :
#2

First try the acpi=force kernel option parameter solve your issue

Reboot your pc, after bios messages, when you see the Grub row press ESC key
Select the kernel row and press edit select
Select the "kernel /boot/......" row and press "e" to edit this row
add the acpi=force parameter at the end of the row
then press "enter" and then press "b" to boot

If this work

To make this "acpi=force" kernel boot parameter permanent

Please open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo gedit /boot/grub/menu.lst

give your user password when requested, you don't see nothing when you type it, then press enter.

Search your default kernel option
# defoptions=nosplash locale=it_IT

and add at the end of the row the
acpi=force
parameter

save and exit

Then to update Grub type
sudo update-grub

HTH

Revision history for this message
Darina (darina-gr) said :
#3

Hello :)

Thanks for the reply.

However, this problem appears not when i boot my system but when i shut it down. Does the Grub has anything to do with it as well? I tried the acpi=force parameter but there was not any difference.

Please help!

Than you.

Revision history for this message
Jan-Philipp Litza (jplitza) said :
#4

No, Grub doesn't have anything to do with the shutdown. But Grub passes some options to the kernel, the basis of the operating system, which is responsible for shutting down. ACPI is used to tell the hardware to power off at the end of the shutdown process. But when the kernel doesn't detect that your computer "speaks" ACPI, it doesn't even try to send the signal and the hardware doesn't power off. The acpi=force parameter tells the kernel to ignore the assumed absence of ACPI and send the signal nevertheless.

Revision history for this message
Darina (darina-gr) said :
#5

Hi,

Jan-Philipp Litza thanks for the explanation! It helped me understand this better.

elart.it thanks. It was 'problem in user (me)' :) I added the command in the menu.lst file and it is working now. I might have done something wrong when performing the first step.

Thank you, guys, you're great :)

Revision history for this message
Darina (darina-gr) said :
#6

Thanks elart.it, that solved my question.

Revision history for this message
Abner Williams2 (pcamann) said :
#7

It worked for me, too.

Revision history for this message
nguyen_viet_ha05 (nguyenvietha05) said :
#8

Thanks for your help

Revision history for this message
Drakkor (mkantrim) said :
#9

Unfortunately, I tried both of marcobra's solutions,and still the same shutdown messages, Hardy Heron. :(

Revision history for this message
Drakkor (mkantrim) said :
#10

This did work,thanks to Greg
 Originally Posted by Greg T. View Post
I can confirm that this fix works for me as well. I've just tried it and had two successful reboots and two successful shutdowns in row for the first time since upgrading to Hardy. I had a bit of trouble following the shorthand references in the posts above, so I'll offer a lengthier description for those who may wish to try this.

Go to "System" -> "Administration" -> "Login Window". In the "General" tab, press "Edit Commands...", which will launch a window titled "Reboot, Halt, Suspend and Custom Command Preferences". In this window, select "Halt command" in the drop-down box for "Command Type:". Underneath it, in the "Path:" box, cut the verbiage in quotes: "Shut Down via gdm." After doing so, press "Apply Command Change", then paste the quoted phrase back into the "Path:" box and hit the "Apply Command Change" button again. Finally, go through the same process for the "Reboot command" in the "Command Type:" drop-down, again cutting the quoted phrase, applying the change, pasting the quote, and applying the change.

Revision history for this message
Baim (thd-02) said :
#11

Please Help me... Everytime i shutdown mp PC there's always show message :
Network Manager: <WARN> nm_hal_deinit(): libhal shutdown failed - Connection is closed
Network Manager: nm_dbus_signal_device_status_change: assertion 'cb_data -> data -> dbus_connection' failed

I hate like this.... can u help me to prevent this message...

Revision history for this message
Jim Hutchinson (jphutch) said :
#12

Baim, you should use the link at the bottom of the page to open your own question. This question is marked solved and your question will likely go unanswered. However, I can say that I see that too and as far as I know it's nothing to worry about. It's probably a low priority bug that doesn't really affect anything.

Revision history for this message
Drakkor (mkantrim) said :
#13

What version of Ubuntu ? Gutsy,Hardy ? Anyways , If you wait awhile , I think this is fixed in Ibex

Revision history for this message
lfierro (luisgfierro) said :
#14

I have Ubuntu 8.04 and SOLVED the problem entirely by doing the following on a terminal (Application, Accessories, Terminal) and then typing:

sudo gedit /etc/modules

Then I added the following line:

apm power_off=1

Then I saved it.

(PS, this is not my own contribution; I found it at some other forum, tested it, and it worked ! I don't even know where I found it, but it had to do with and IDE bug. I think the author was Francesco Bolzoni or perhaps Carl Friis-Hansen. )