Unable to mount external USB hard drives

Asked by andrew on 2007-11-02

Unable to mount external USB hard drives
sorry folks, all a bit above me...
install ubuntu yesterday, wow this is great, dell e1505 laptop, no problems and then the wi-fi did not work so i spent 4 hours and now it does, and now any of the 2 external HD will not mount. i only have ubuntu running, windows is gone !

i have spent 4 hours again trying to fix this
the error says unable to mount the volume...

also i can not get my ipod to mount, it sees it as a camera.

i am not very good with the command funtions yet so still learning. i have entered code in to terminal but i am not up to speed to what other functions i do thru there

again slow irish man here, learning and loving the whole ubuntu programe

Thank you
Andrew

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
andrew
Solved:
2007-11-03
Last query:
2007-11-03
Last reply:
2007-11-03

Open a terminal from Applications->Accessories->Terminal and install the ntfs-config package, type:

sudo apt-get install ntfs-config

Give your user password when requested, you don't see nothing when you type it, then press enter.

Then go to Applications->System Tools->NTFS configuration tools
and simply configure it

Now try disconnect and reconnect your external USB drives, if they are recognized you must see a desktop grey colour "hard-disk" icon

If you hard disk are recognized now, before to unplug them, don't forget to unmount them by right click on icon and select unmount menu item.

HTH

andrew (andrew-vr66) said : #2

that did not work , i see the ntfs config now but it still gives same message
does the hardrive have to be pluged in when i run the command ?

With this command you have enable for any NTFS plugged or future plugged NTFS devices the ability of write on them.
Are your external hard-disk with NTFS partition...?
Are your external hard-disk password protected...?

Unplug and plug your external hard-disk then please open a terminal and type:

sudo lsusb

and

sudo fdisk -l

copy and paste the result here.

Thank you.

andrew (andrew-vr66) said : #4

i have no password on the HD device

andrew@andrew-laptop:~$ sudo lsusb
[sudo] password for andrew:
Bus 005 Device 011: ID 067b:2506 Prolific Technology, Inc.
Bus 005 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 046d:c510 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
andrew@andrew-laptop:~$ sudo fdisk -l

Disk /dev/sda: 58.5 GB, 58506416640 bytes
255 heads, 63 sectors/track, 7113 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe686f016

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 6817 54757521 83 Linux
/dev/sda2 6818 7113 2377620 5 Extended
/dev/sda5 6818 7113 2377588+ 82 Linux swap / Solaris

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8867c4de

   Device Boot Start End Blocks Id System
/dev/sdb1 1 60801 488384001 7 HPFS/NTFS
andrew@andrew-laptop:~$

Unplug your external device redo the:

sudo lsusb

command

then type:

tail -F /var/log/messages

plug in your device check system messages for error or any other warning message

then redo the

sudo lsusb

check for changed data and or error

Thank you

andrew (andrew-vr66) said : #6

same message again

andrew@andrew-laptop:~$ sudo lsusb
Bus 005 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 046d:c510 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
andrew@andrew-laptop:~$ tail -F /var/log/messages
Nov 2 16:11:50 andrew-laptop kernel: [ 6934.672000] scsi7 : SCSI emulation for USB Mass Storage devices
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.704000] scsi 7:0:0:0: Direct-Access WDC WD50 00AAKB-00UKA0 07.0 PQ: 0 ANSI: 0
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.708000] sd 7:0:0:0: [sdb] 976773168 512-byte hardware sectors (500108 MB)
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.708000] sd 7:0:0:0: [sdb] Write Protect is off
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.712000] sd 7:0:0:0: [sdb] 976773168 512-byte hardware sectors (500108 MB)
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.712000] sd 7:0:0:0: [sdb] Write Protect is off
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.712000] sdb: sdb1
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.720000] sd 7:0:0:0: [sdb] Attached SCSI disk
Nov 2 16:11:55 andrew-laptop kernel: [ 6939.720000] sd 7:0:0:0: Attached scsi generic sg1 type 0
Nov 2 16:15:21 andrew-laptop kernel: [ 7145.604000] usb 5-3: USB disconnect, address 12
Nov 2 16:16:19 andrew-laptop kernel: [ 7203.760000] usb 5-3: new high speed USB device using ehci_hcd and address 13
Nov 2 16:16:19 andrew-laptop kernel: [ 7203.892000] usb 5-3: configuration #1 chosen from 1 choice
Nov 2 16:16:19 andrew-laptop kernel: [ 7203.892000] scsi8 : SCSI emulation for USB Mass Storage devices
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.924000] scsi 8:0:0:0: Direct-Access WDC WD50 00AAKB-00UKA0 07.0 PQ: 0 ANSI: 0
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.928000] sd 8:0:0:0: [sdb] 976773168 512-byte hardware sectors (500108 MB)
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.928000] sd 8:0:0:0: [sdb] Write Protect is off
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.928000] sd 8:0:0:0: [sdb] 976773168 512-byte hardware sectors (500108 MB)
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.932000] sd 8:0:0:0: [sdb] Write Protect is off
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.932000] sdb: sdb1
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.944000] sd 8:0:0:0: [sdb] Attached SCSI disk
Nov 2 16:16:25 andrew-laptop kernel: [ 7208.944000] sd 8:0:0:0: Attached scsi generic sg1 type 0
sudo lsusb

andrew (andrew-vr66) said : #7

yes
same message again

andrew (andrew-vr66) said : #8

is see this message on my dvd/cd burner player....same error well kind of..

mount: special device /dev/scd0 does not exist

Ok your device is seen by the system as /dev/sdb
and the partition is the
/dev/sdb1 1 60801 488384001 7 HPFS/NTFS

Open a terminal and type:

sudo mount

Please copy and paste result here.

Thank you.

andrew (andrew-vr66) said : #10

andrew@andrew-laptop:~$ sudo mount
[sudo] password for andrew:
/dev/sda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.22-14-generic/volatile type tmpfs (rw)
securityfs on /sys/kernel/security type securityfs (rw)
andrew@andrew-laptop:~$

Well your device is not mounted.

Be sure you have the ntfs-3g package to manage the NTFS filesystem open a terminal and type.
sudo apt-get update
sudo apt-get install ntfs-3g ntfsprogs

Try to unplug and plug your external device and look for a new disk icon on the desk.

Only if this don't work try to manually ( via terminal ) mount, open a terminal and type :
sudo mkdir /media/hd-ntfs
sudo chmod 777 /media/hd-ntfs
sudo mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs

look on your desk for new mounted disk-icon

To unmount your device, open a terminal and type:

sudo umount /media/hd-ntfs

Give me some feedback. Thank you.

andrew (andrew-vr66) said : #12

no luck
same erro message
i did this twice

Andrew

Please specify which command get error...?
Please specify detail of error...?

Thank you

andrew (andrew-vr66) said : #14

error i mean cannot mount volume

andrew@andrew-laptop:~$ sudo apt-get update
[sudo] password for andrew:
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016) gutsy/main Translation-en_US
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016) gutsy/restricted Translation-en_US
Get:1 http://security.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://security.ubuntu.com gutsy-security/main Translation-en_US
Get:2 http://us.archive.ubuntu.com gutsy Release.gpg [191B]
Ign http://us.archive.ubuntu.com gutsy/main Translation-en_US
Ign http://security.ubuntu.com gutsy-security/restricted Translation-en_US
Ign http://security.ubuntu.com gutsy-security/universe Translation-en_US
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-en_US
Hit http://security.ubuntu.com gutsy-security Release
Ign http://us.archive.ubuntu.com gutsy/restricted Translation-en_US
Ign http://us.archive.ubuntu.com gutsy/universe Translation-en_US
Ign http://us.archive.ubuntu.com gutsy/multiverse Translation-en_US
Get:3 http://us.archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://us.archive.ubuntu.com gutsy-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com gutsy-updates/restricted Translation-en_US
Hit http://security.ubuntu.com gutsy-security/main Packages
Ign http://us.archive.ubuntu.com gutsy-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com gutsy-updates/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com gutsy Release
Hit http://security.ubuntu.com gutsy-security/restricted Packages
Hit http://security.ubuntu.com gutsy-security/main Sources
Hit http://security.ubuntu.com gutsy-security/restricted Sources
Hit http://us.archive.ubuntu.com gutsy-updates Release
Hit http://security.ubuntu.com gutsy-security/universe Packages
Hit http://security.ubuntu.com gutsy-security/universe Sources
Hit http://security.ubuntu.com gutsy-security/multiverse Packages
Hit http://security.ubuntu.com gutsy-security/multiverse Sources
Hit http://us.archive.ubuntu.com gutsy/main Packages
Hit http://us.archive.ubuntu.com gutsy/restricted Packages
Hit http://us.archive.ubuntu.com gutsy/main Sources
Hit http://us.archive.ubuntu.com gutsy/restricted Sources
Hit http://us.archive.ubuntu.com gutsy/universe Packages
Hit http://us.archive.ubuntu.com gutsy/universe Sources
Hit http://us.archive.ubuntu.com gutsy/multiverse Packages
Hit http://us.archive.ubuntu.com gutsy/multiverse Sources
Hit http://us.archive.ubuntu.com gutsy-updates/main Packages
Hit http://us.archive.ubuntu.com gutsy-updates/restricted Packages
Hit http://us.archive.ubuntu.com gutsy-updates/main Sources
Hit http://us.archive.ubuntu.com gutsy-updates/restricted Sources
Hit http://us.archive.ubuntu.com gutsy-updates/universe Packages
Hit http://us.archive.ubuntu.com gutsy-updates/universe Sources
Hit http://us.archive.ubuntu.com gutsy-updates/multiverse Packages
Hit http://us.archive.ubuntu.com gutsy-updates/multiverse Sources
Fetched 3B in 1s (3B/s)
Reading package lists... Done
andrew@andrew-laptop:~$ sudo apt-get install ntfs-3g ntfsprogs
Reading package lists... Done
Building dependency tree
Reading state information... Done
ntfs-3g is already the newest version.
ntfsprogs is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
andrew@andrew-laptop:~$

Well there is no error here...

Open a terminal and type :

sudo mkdir /media/hd-ntfs
sudo chmod 777 /media/hd-ntfs
sudo mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs

look on your desk for new mounted disk-icon

To unmount your device, open a terminal and type:

sudo umount /media/hd-ntfs

Give me some feedback. Thank you.

HTH

andrew (andrew-vr66) said : #16

no
that did not work

andrew (andrew-vr66) said : #17

are you still there ?

- Open a terminal (A) please type:
sudo tail -F /var/log/messages

- Open another terminal (B) please type:
sudo mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs

You must get error or the command is successful
Read messages warnig or error on terminal A

If you don't have any error please type:
sudo mount | grep -i sdb1

I must go bed now... i will see your answer tomorrow.

Thank you

andrew (andrew-vr66) said : #19

andrew@andrew-laptop:~$ sudo tail -F /var/log/messages
[sudo] password for andrew:
Nov 2 21:50:44 andrew-laptop kernel: [27268.104000] usb 5-1: configuration #1 chosen from 1 choice
Nov 2 21:50:44 andrew-laptop kernel: [27268.104000] scsi18 : SCSI emulation for USB Mass Storage devices
Nov 2 21:50:49 andrew-laptop kernel: [27273.136000] scsi 18:0:0:0: Direct-Access WDC WD50 00AAKB-00UKA0 07.0 PQ: 0 ANSI: 0
Nov 2 21:50:49 andrew-laptop kernel: [27273.140000] sd 18:0:0:0: [sdb] 976773168 512-byte hardware sectors (500108 MB)
Nov 2 21:50:49 andrew-laptop kernel: [27273.140000] sd 18:0:0:0: [sdb] Write Protect is off
Nov 2 21:50:49 andrew-laptop kernel: [27273.140000] sd 18:0:0:0: [sdb] 976773168 512-byte hardware sectors (500108 MB)
Nov 2 21:50:49 andrew-laptop kernel: [27273.144000] sd 18:0:0:0: [sdb] Write Protect is off
Nov 2 21:50:49 andrew-laptop kernel: [27273.144000] sdb: sdb1
Nov 2 21:50:49 andrew-laptop kernel: [27273.148000] sd 18:0:0:0: [sdb] Attached SCSI disk
Nov 2 21:50:49 andrew-laptop kernel: [27273.148000] sd 18:0:0:0: Attached scsi generic sg1 type 0
sudo mount | grep -i sdb1

andrew@andrew-laptop:~$ sudo mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs
[sudo] password for andrew:
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sdb1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs -o force

    Or add the option to the relevant row in the /etc/fstab file:

            /dev/sdb1 /media/hd-ntfs ntfs-3g defaults,force 0 0
andrew@andrew-laptop:~$ sudo mount | grep -i sdb1

andrew (andrew-vr66) said : #20

wow
i hope you are not loosing patience with me, i am lost now and worried, any other solutions ?

Jim Hutchinson (jphutch) said : #21

I think you might find your answer (or at least an understanding of the problem) in this bug:

https://bugs.launchpad.net/ubuntu/+source/ntfs-3g/+bug/153099

Sounds like it might be a problem with how windows used the drive and left it in an unclean state. There is a link in the bug to a package that may help but seems the download link in broken. You might also be able to fix this if you connect it to a windows box and let it check it and then cleaning unmount it.

andrew (andrew-vr66) said : #22

that solution has already been done...

andrew (andrew-vr66) said : #23

it is not working on any of my hard drive enclosers... so no

Jim Hutchinson (jphutch) said : #24

According to the bug it's not an enclosure issue. The drive needs to be connected to a computer running windows and checked then cleanly unmounted. According to the bug, the problem is caused by not cleanly unmounting from windows. If you don't have access to a windows computer there does seem to be a Linux solution but the link given wasn't working. If the info in the bug is correct, the easiest way to fix this might be letting windows fix its own problem.

If that is exactly what you have tried then sorry for not fully understanding the issue and solutions tried.

Andrew, have you tried to force the mount:

sudo mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs -o force

HTH

andrew (andrew-vr66) said : #26

sudo mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs -o force

this worked

oh thank you so much guys

thank you thank you
you are the best........

so much help and what a great job

Andrew, you must modify your /etc/fstab to force mount
open a terminal and type

sudo gedit /etc/fstab

and add this row

/dev/sdb1 /media/hd-ntfs ntfs-3g defaults,force 0 0

Save and exit

HTH

andrew (andrew-vr66) said : #28

do i do this even after it is working ?

elart.it wrote:
> Your question #16872 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/16872
>
> elart.it posted a new comment:
> Andrew, you must modify your /etc/fstab to force mount
> open a terminal and type
>
> sudo gedit /etc/fstab
>
> and add this row
>
> /dev/sdb1 /media/hd-ntfs ntfs-3g defaults,force 0 0
>
> Save and exit
>
> HTH
>
>

andrew (andrew-vr66) said : #29

again thank you
you guys are great.

andrew wrote:
> Your question #16872 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/16872
>
> andrew posted a new comment:
> do i do this even after it is working ?
>
>
> elart.it wrote:
>
>> Your question #16872 on Ubuntu changed:
>> https://answers.launchpad.net/ubuntu/+question/16872
>>
>> elart.it posted a new comment:
>> Andrew, you must modify your /etc/fstab to force mount
>> open a terminal and type
>>
>> sudo gedit /etc/fstab
>>
>> and add this row
>>
>> /dev/sdb1 /media/hd-ntfs ntfs-3g defaults,force 0 0
>>
>> Save and exit
>>
>> HTH
>>
>>
>>
>
>

Yes do this, to force the mount of this dirty marked drive.

By the way you are working on a bad state device.
Try to address the dirty status of this device.

The system message suggest howto do this to you in the previous message:
---------------------------------------------------------------------------------------------------
...
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sdb1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sdb1 /media/hd-ntfs ntfs-3g defaults,force 0 0
---------------------------------------------------------------------------------------------------

HTH

Ricci (riccisayer) said : #31

Just wanted to thank all you guys, this solved a non urgent problem for us on two different machines, with a normal USB external and an IDE/USB external link we use different IDE drives on.
Thanks again to all

eoalvarez (eoalvarez) said : #32

Ok similar problem
Normal Usb external drive

ive gotten for lsub this
Bus 005 Device 006: ID 0bc2:2000 Seagate RSS LLC
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 002: ID 413c:8126 Dell Computer Corp.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

for sudo fstab

Unable to open -

Ive tried the force mount
sudo mount -t ntfs-3/dev/sdb1/media/hd-ntfs -o force

and get

man 8 mount

eoalvarez (eoalvarez) said : #33

$LogFile indicates unclean shutdown (0, 0)
WARNING: Forced mount, reset $LogFile.
fuse: failed to access mountpoint /media/hd-ntfs: No such file or directory

eoalvarez (eoalvarez) said : #34

Problem solved

sudo mkdir /media/external
sudo mount -t ntfs-3g /dev/sdb1 /media/external

this worked....

Thanks!

I just received my everex computer on the 13Th of this month and I have to say that I'm very satisfied with the product. But every time I connect my Scan-Disk Micro Cruzer flash drive in I get this message.Unable to mount location DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken. I'm unable to hear my music and see my pictures that I have on my flash drive. Please help I'm new at this. Thanks!

I have tried everything and I can't get my flashdrive to mount. I even tried these instrutions. Please someone help. I keep getiing this message. DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken. Bye!

tried these instructions and nothing:

Go to Applications -> Accessories -> Terminal

Type "sudo apt-get install pysdm" without the quotes, then enter your
password when prompted

When it is finished installing, close the terminal window

Restart the computer, insert the flash drive and then go to System ->
Administration -> Storage Device Manager

Once it opens, select the drive, then the partition you want to access (on
the left hand side of the GUI) and then click mount.

If this does not work you may need to backup your drive, format as FAT file
format, and then copy your pictures and music back onto the drive. Make
sure you don't have any program files on the drive after formatting.

Thanks for choosing Everex,

cesgab (cesgab) said : #37

well guys im a ubuntu neeeeewbe im trying to mount a flash drive and it just wont work i've tried forcing it but it just wonthere is some info on the issue
cesarherrera@cesarherrera-laptop:~$ sudo mkdir /media/externa
cesarherrera@cesarherrera-laptop:~$ sudo mount -t ntfs-3g /dev/sdb1 /media/external
ntfs-3g: Failed to access volume '/dev/sdb1': No such file or directory
Please type '/sbin/mount.ntfs-3g --help' for more information.
cesarherrera@cesarherrera-laptop:~$
any information on how to address this problem is helpfull thanks in advance

Xiaoqi Zhao (xiaoqi) said : #38

[machinename]:~$ sudo apt-get install ntfs-config
[sudo] password for [myname]:
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
[machinename]p:~$

Why still get this error message?
Thanks.

shay (smith-phx) said : #39

lane@lane-desktop:~$ sudo mount -t ntfs-3g /dev/sdb1 /media/hd-ntfs -o force
[sudo] password for lane:
NTFS signature is missing.
Failed to mount '/dev/sdb1': Invalid argument
The device '/dev/sdb1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I was copying files to the external hard drive and the power was unplugged. Now it won't mount. I tried following the post but this is what I got. Any suggestions?

COKEDUDE (cokedude) said : #40

~ $ sudo mount -t ntfs-3g /dev/sdb /media/hd-ntfs -o force
NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

COKEDUDE (cokedude) said : #41

I also get this.

~ $ sudo mount -t ntfs-3g /dev/sdb /media/hd-ntfs -o force
NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?