Every startup NTFS disk needs to be mounted (Xubuntu 7.10)

Asked by Paul on 2007-10-31

Hallo people! Well I recently installed Xubuntu 7.10 on my IBM X40 without any problems.

But then every time I start up Xubuntu, I have to mount one of the partitions that is part of the hard disk, even using the keyring manager (for "security issues"). My hard disk has the following 4 partitions:

1. 20 gig Windows XP-dualboot disk (ntfs)
2. 2 gig linux swap file
3. 10 gig Xubuntu file drive (ext3)
4. 8 gig media files drive (ntfs)

It is number 4 that is causing the problem. I'm quite new to Linux, so I'm absolutely not sure what could be causing the problem. I looked through many other sites, including launchpad, but none of the solutions seemed to be suited for this problem. Many of the sites did tell me however, to give the fstab text, so I pasted that here.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=8f5d65e1-7ba6-4922-9f2b-503593e9d749 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=127C5BBB7C5B97F5 /media/sda1 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda4
UUID=004E-CF25 /media/sda4 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sda2
UUID=0390da11-2868-4a4f-8440-0809edb61a4f none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0

Also, when opening the partition editor, the media disk (listed as /media/sd4 and mounted under /media/disk) doesn't appear to give any signal that something is not working.

Hope someone can help me with this, thanks already!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Paul
Solved:
2007-11-01
Last query:
2007-11-01
Last reply:
2007-11-01
Massimo Forti (slackwarelife) said : #1

thanks for your question, I think your problem is in this line:

UUID=004E-CF25 /media/sda4 vfat defaults,utf8,umask=007,gid=46 0 1

you hace said the 4° partition is ntfs and not vfat. You must change it on this line. I think you must have:

UUID=004E-CF25 /media/sda4 ntfs defaults,umask=007,gid=46 0 1

like this (the ok partition):

UUID=127C5BBB7C5B97F5 /media/sda1 ntfs defaults,umask=007,gid=46 0 1

thanks .

Paul (treepata) said : #2

Dear Massimo,

Thank you for your quick response. I changed the fstab file as you said, then restarted my laptop. However, the problem is still there and thus the partition is not mounted on startup. Do you maybe have any other suggestions?

My fstab file now looks as follows:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=8f5d65e1-7ba6-4922-9f2b-503593e9d749 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=127C5BBB7C5B97F5 /media/sda1 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda4
UUID=004E-CF25 /media/sda4 ntfs defaults,utf8,umask=007,gid=46 0 1
# /dev/sda2
UUID=0390da11-2868-4a4f-8440-0809edb61a4f none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0

Thanks in advance!

Massimo Forti (slackwarelife) said : #3

Restart the PC, than open a shell and do:

mount /media/sda4

put the result. Thanks.

Paul (treepata) said : #4

Ok this is what I got. Have to do sudo and give my password before I can mount it. But in the end it did not mount at all this way. I can only mount it by right clicking on the disk icon on the desktop, and then select "mount" (and give my password again).

paul@paul-laptop:~$ mount /media/sda4
mount: only root can mount /dev/disk/by-uuid/004E-CF25 on /media/sda4
paul@paul-laptop:~$ sudo mount /media/sda4
[sudo] password for paul:
Failed to access '/dev/disk/by-uuid/004E-CF25': No such file or directory
paul@paul-laptop:~$

(BTW: Have to quit in 15 min., so you might not get a response the following hours. But I should be back online tomorrow.)

Paul (treepata) said : #5

One more thing I just remembered. Under Ubuntu 7.04, which I had previously installed, the media disk was FAT32 (I read somewhere on a install guide that this was good for a dual-boot system). But when Ubuntu 7.10 (and Xubuntu 7.10) came, it said somewhere that NTFS drives where fully supported.

So I first installed Xubuntu (fresh install from Live CD) and then changed (and formatted) the media disk from FAT32 to NTFS. And although I'm not sure anymore, I believe my problems started after that.

Maybe this extra info helps. Thanks!

Goatz (mikej-weaver) said : #6

Please
#cd /dev/disk/by-uuid
#ls
I think the line "UUID=004E-CF25 /media/sda4 ntfs defaults,utf8,umask=007,gid=46 0 1" got broke somewhere, 004E-CF25 seems allfull short for a uuid. If you find that your other three uuid's are listed but the fourth one is different, try updating your fstab to show it. You will probly see
8f5d65e1-7ba6-4922-9f2b-503593e9d749
127C5BBB7C5B97F5
0390da11-2868-4a4f-8440-0809edb61a4f
004E-CF25<withmorestuff>
Failed to access '/dev/disk/by-uuid/004E-CF25': No such file or directory - leads me to belive that it is actually a longer uuid.

Ricky Hewitt (rickyhewitt) said : #7

run 'sudo vol_id /dev/sda4' and then copy the UUID and replace it with the one you currently have (004E-CF25).

Paul (treepata) said : #8

Dear Goatz and Kahrn,

thank you for your input. I followed Kahrn's suggestion and that seemed to fix the problem. So thanks for helping me!

Ron O (ronouel) said : #9

I have a similar problem (another question posted), but in the meantime, Kahrn's command line has at least put me on the right track. Thanks.