Update with DVD stalled - where to start again

Asked by Piet Beukes

- I updated GG with a new bought DVD, using synaptic,
half way through, the system hung. On rebooting - after some initial problems (see #Q 16677) I get to the new GG screen which is working.

But there are still problems - the DVD disk image remain on the screen after it is taken out, and I cannot access the HP laptop with a flashdisk (it doesnt mount) and symantec is gone (probably part of installing GG it was removed).

I wish to re-update so that the full GG can load and hopefully get rid of the remaining problems!!!!!

At least now I can boot with the recovery mode, BUT what then?
I do not know how to re-update the part of GG which did not install. With semantic I could direct the process to the DVD. How do I do that with Adept Manager?

rusty - getting more gray hair by the moment

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Piet Beukes
Last query:
Last reply:
Revision history for this message
Qwerty Maniac (qwertymaniac) said :

Its 'Synaptic' and not Symantec or etc :)

You can perhaps run the following from the command line on Gutsy:
sudo apt-get install -f ubuntu-desktop

Revision history for this message
Piet Beukes (zabear1) said :

I tried it but it gave a E:dpkg was interupted, must manually run 'dpkg --confirure -a' to correct problem' answer.

Revision history for this message
Qwerty Maniac (qwertymaniac) said :

Give the command:
sudo dpkg --configure -a

And let it complete, then try sudo apt-get install ubuntu-desktop again just to double check.

Revision history for this message
Piet Beukes (zabear1) said :

I've given the 'sudo .... confire command and it is definitly updateing
- before I give the install ubuntu command - tell me must it be 'install ubuntu ' or should it be 'install kubuntu'? because I am loading KUBUNTU


Revision history for this message
Piet Beukes (zabear1) said :

THANX for all the advice and assistance - I know it is volenteer work and really appreciate it a lot.
I did not put in the '-f' in the 'install ubuntu' line as you did not give it the last time The installation went well - lots of lines rushing past - I then tried the kubuntu version (again without the -f) - it replied that kubuntu was already the newest version. it mentioned that some packages were automatically installed and were no longer required e.g. blt etc. and it told me I could remove them with apt-get autoremove' - is this necessary - because I have lots of space and it would not hurm me if it stayed.

Revision history for this message
Piet Beukes (zabear1) said :

I have now tested my laptop a few times and it starts OK and previous issues have been solved e.g. I can now use the memory stick again which I could not do previously. Open Office 2.3 is working well also. I do not heve the updated Firefox or Thunderbird - perhaps they were not on the DVD which I am using?

thanx again for the help
I would like to know what the -f stands for and if it was necessary
then I will close this as solved

Revision history for this message
Jim Qode (jimqode) said :

       -f, --fix-broken
           Fix; attempt to correct a system with broken dependencies in place.
           This option, when used with install/remove, can omit any packages
           to permit APT to deduce a likely solution. Any Package that are
           specified must completely correct the problem. The option is
           sometimes necessary when running APT for the first time; APT itself
           does not allow broken package dependencies to exist on a system. It
           is possible that a system’s dependency structure can be so corrupt
           as to require manual intervention (which usually means using
           dselect(8) or dpkg --remove to eliminate some of the offending
           packages). Use of this option together with -m may produce an error
           in some situations. Configuration Item: APT::Get::Fix-Broken.

You can usually get information about a command line program by typing 'man [program-name]'. In this case the command is 'man apt-get'.

Revision history for this message
Piet Beukes (zabear1) said :

Thanx for all the assistance - I really appreciate it