remove partition from places menu

Asked by Clóvis Fabrício on 2007-10-30

I have the following partition from my SATA disk registered in /etc/fstab:

UUID=46d90474-9fa1-47dc-82f8-1425c8430047 /media/sda1 ext3 defaults 0 2

It is being mounted correctly and I want it to be mounted automatically every boot which is happening as expected.

But it is showing up for the common user in the places menu on gnome panel.
I want it to disappear from the menu.

How can I remove a partition from places menu? I want it mounted transparently, without showing to the user that there is a different partition.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
cheics
Solved:
Last query:
Last reply:
Revision history for this message
John Bruno (jbalaska) said :
#1

You can edit the places menu somewhat with this file;
$ sudo gedit ~/.gtk-bookmarks

I'll leave this open in case someone has a better soloution.

Revision history for this message
John Bruno (jbalaska) said :
#2

sorry I hit the wrong button lol

Revision history for this message
Clóvis Fabrício (nosklo) said :
#3

Thanks John Bruno for your answer.

That file only record folder bookmarks... I need to remove the mounted partition...
Been doing some research but I still hasn't been able to hide the partition entry.

Revision history for this message
John Bruno (jbalaska) said :
#4

I believe it also gets entry's from the mounted drive(s) on your desktop, but it will load a new entry every time you re-login. If there is no other solution available (I could not find one) you may be able to write a small script to delete the entry at every boot time.

Hope you find a better solution. Good luck.

Revision history for this message
Clóvis Fabrício (nosklo) said :
#5

I don't see a way to write such script. Stuff appears on the Desktop but they are not in the ~/Desktop folder. They are somewhat "virtual" and I don't know how to remove by script. If you have a way, please show me an example.

Revision history for this message
Jan-Philipp Litza (jplitza) said :
#6

At least the volume icons on the desktop are removeable:
Exec gconf-editor and browse to /apps/nautilus/desktop, there you can uncheck volumes_visible

Revision history for this message
Clóvis Fabrício (nosklo) said :
#7

Thanks for your response Jan-Philipp.

But I need to remove the partition from the Places menu. I had already removed from desktop.
I have a bug report open linked to this question. Again, thank you.

Revision history for this message
FactTech (launchpad-facttechnologies) said :
#8

You might try altering the fstab entry for this partition to keep it from being automatically mounted. You could then add a command to mount it to the login script for any users that should be able to see it on the Places menu.

Revision history for this message
Best cheics (cheics) said :
#9

Mount to /mnt instead of /media

/media is used to create the entires

Revision history for this message
Bob/Paul (ubuntu-launchpad-bobpaul) said :
#10

My places menu looks thus:
username
Desktop
File System
Network
13 GB File System
234 GB File System
1000 GB File System

The final 3 are unmounted and don't contain file systems. They're the block devices that luks uses for my / /home and generalized storage location. If I click on them, I get errors like "Unable to mount 234 GB Filesystem: /dev/mapper/chome is mounted"

I would like to remove these 3 entries. They're useless.

Revision history for this message
Forage (forage) said :
#11

@Bob/Paul: The solution provided by cheics solves the initial problem. Yours is a different issue concerning encrypted drives, please file a different bug report for it.

Revision history for this message
Clóvis Fabrício (nosklo) said :
#12

Thanks cheics, that solved my question.