Dell Wireless 1390 on 11.04 not working

Asked by Alex Tarbox on 2011-07-14

I recently installed 11.04 side by side with Win 7, and I plugged the lan cable into the laptop and downloaded every possible update for ubuntu, but the wireless card doesn't work. It detects it and says it has the latest proprietary drivers installed, but the wireless light on the laptop itself is not turning on, and I cannot connect to any wireless networks, even manually. It works perfectly in Win 7 however, so I'm unsure if this is just an issue with Dell needing to update their drivers in order for it to work, or if there's something else I can do in ubuntu to get it going? I'm not really technical with ubuntu yet though so I don't know what to check for or type in a terminal.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-07-14
Last query:
2011-07-14
Last reply:
2011-07-14

Can you give the output of:

sudo lshw -C network; lsb_release -a; rfkill list

Thanks

Alex Tarbox (alextarbox) said : #2

PCI (sysfs)

*-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:17 memory:efdfc000-efdfffff
  *-network
       description: Ethernet interface
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 02
       serial: 00:15:c5:70:75:90
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=half latency=64 link=no multicast=yes port=twisted pair speed=10Mbit/s
       resources: irq:17 memory:ef9fe000-ef9fffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
0: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
1: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no

Alex Tarbox (alextarbox) said : #4

I've already done what it says to do under the "Additional Drivers" page and the wireless card shows the drivers are installed and activated, yet it doesn't work.

I am pretty sure that your wireless adapter is experiencing the following Broadcom driver bug in Ubuntu 11.04:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

I suggest installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5) from maverick (Ubuntu 10.10) using gdebi

Solution is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

Then reboot your PC and run the following commands to enable your wireless adapter:

rfkill unblock all
sudo rfkill unblock all

Then retest wireless using NetworkManager.

Alex Tarbox (alextarbox) said : #6

Thanks Mark Rijckenberg, that solved my question.