Ubuntu Natty doesn't boot anymore

Asked by Simon Hirscher

Hey there,
it just began this morning that my beloved ThinkPad with Ubuntu Natty wouldn't boot anymore. Instead, I am always greeted by the terminal, now. [Well, actually 3 of 4 times the screen just stays purple, which must be due to this bug here (https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/771905). In this case I cannot even switch to the tty and usually have to reboot a few times till I get to the terminal at last.]

Anyways, I noticed that X is not running when I get to the terminal, so I tried to start X (does it make a difference whether I use X or the startx script?). X promptly showed the Nvidia logo as always and then a black screen. So I went to another tty and attempted to start Unity which was obviously not running – I didn't know whether to start it as root or as normal user, so I tried both – with the same result: a segmentation fault. Switching back to tty7, however, I could see and move the cursur, now (+ it was in the correct resolution). Also, "$ ps aux | grep unity" now delivered the unity processes (window-decorator, applications-daemon, files-daemon, panel-service). But other than that nothing had changed.

Taking a look at the log files (/var/log/syslog, /var/log/Xorg.0.log, /var/log/boot.log) I couldn't find any error messages or severe warnings, either. To me it looks like the boot process just stops before starting the graphical frontend.
Or rather hangs? Because it has happened like 3 or 4 times, now, that after some minutes of waiting and doing stuff in the console the graphical frontend suddenly would start as if nothing had happened. (Which is the only reason why I'm able to write to you, now.)

I really don't know what to do anymore. I already tried to generate a new X config via nvidia-xconfig, did a unity --reset and purged and reinstalled unity and ubuntu-desktop…
So, I'd be glad if you could help me especially since I'm having a giant pile of university work waiting for me. :( I'll happily give you logs and every other information you need. :)

Question information

English Edit question
Ubuntu plymouth Edit question
No assignee Edit question
Solved by:
Simon Hirscher
Last query:
Last reply:
Revision history for this message
Paul Stewart (paulbrianstewart) said :

Hi Simon,

This is no doubt not the answer that you are looking for, but I would try to back up any important files you have and then do a complete reinstall from DVD.


Revision history for this message
Simon Hirscher (codethief) said :

I just set up the system a few weeks ago. :( Plus it's encrypted which means I've got to go through the whole process again…

As I assume it's got something to do with Plymouth: Isn't there a way to disable / replace Plymouth completely?

Revision history for this message
delance (olivier-delance) said :

gksudo gedit /etc/default/grub
Remove "quiet splash", and then do command
sudo update-grub
Have a look at: https://help.ubuntu.com/community/Grub2#Configuring%20GRUB%202

Revision history for this message
Simon Hirscher (codethief) said :

Sorry to disappoint you, but my config already looks like this:
GRUB_CMDLINE_LINUX_DEFAULT="noplymouth nosplash kopt=root=/dev/mapper/ubuntu-root"
(which is kind of a workaround for https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/771905)


Revision history for this message
delance (olivier-delance) said :

Please try my solution. The simpler the better.

Revision history for this message
Simon Hirscher (codethief) said :

Excuse me, I probably just don't get what you're telling me to do.
As I tried to point out in my previous post I already removed "quiet splash" and did a sudo update-grub (for reasons that had something to do with another bug). However, this did not have any effect on the booting issue we're talking about here.

Revision history for this message
Simon Hirscher (codethief) said :

You might also take a look at the bug I filed over here: https://bugs.launchpad.net/ubuntu/+source/alsa-utils/+bug/797950 . The booting issue seems to be ALSA-related.

Revision history for this message
Jeet (gour-jitendrasingh) said :


you got solution on your problem ??

if not {

- i seen related bug to your q.
- there some classification of your system and i observed some problem already persist with think pad related to linux system ... ( X system ) and u reported a bug related to X-System

so please look at these problems if there is something else.
attach all system log.

please let us know


Revision history for this message
Simon Hirscher (codethief) said :

Hey Jeet,
in the end I followed Paul Stewart's advice and reinstalled Ubuntu. So far, the bug hasn't reappeared (but I'm also on Oneiric, now).

Revision history for this message
Jeet (gour-jitendrasingh) said :

Hi simon