SATA drive mounting

Asked by Marcos Wasem

I have a SATA drive listed as /dev/sda, and I used to mount it by adding this line in /etc/fstab:

/dev/sda1 /media/SATA vfat iocharset=utf8,umask=000 0 0

I formated the drive to FAT 32, and I use it for storage. The mounting worked perfect under Feisty. I've just upgraded to Ubuntu Gusty, and the drive is no longer seen at the folder computer:///, nor appears the device /dev/sda or the partition sda1. The SATA drive is connected to a sata pci card (INI 1623 PCI SATA-II controller).

Some commands outputs:

 sudo fdisk -l

Disk /dev/hda: 40.0 GB, 40060403712 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xae41de88

   Device Boot Start End Blocks Id System
/dev/hda1 * 1 4869 39110211 7 HPFS/NTFS

Disk /dev/hdb: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1746fb1f

   Device Boot Start End Blocks Id System
/dev/hdb1 * 1 9777 78533721 83 Linux
/dev/hdb2 9778 9964 1502077+ 5 Extended
/dev/hdb5 9778 9964 1502046 82 Linux swap / Solaris

 mount
/dev/hdb1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

There must be a way to fix the problem and remount the drive, since everything went perfect under Feisty.

Regards,

Marcos

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Fran├žois Tissandier (baloo) said :
#1

You have 3 hard drives right? It seems that Ubuntu cannot recognize your SATA drive from what I see in the Fdisk command.

Can you check in the logs after booting if you see any error message related to an harddrive? Try to look in the boot log, or messages maybe.

Revision history for this message
Marcos Wasem (mwasem) said :
#2

Yes, I do have 3 drives. Two IDE, one with the Ubuntu file system and the second with Windows XP. The third one is the SATA, connected to an Initio SATA II 2-channel RAID PCI. I enabled today the boot log following these instructions at the Ubuntu forum:

http://ubuntuforums.org/showthread.php?t=49925

but this is all that I have in the /var/log/boot file:

(Nothing has been logged yet.)

I erased the line

/dev/sda1 /media/SATA vfat iocharset=utf8,umask=000 0 0

from /etc/fstab, but nothing happened.

Revision history for this message
Froy (froy02) said :
#3

Does your drive show in windows xp?

Revision history for this message
Marcos Wasem (mwasem) said :
#4

Yes, it does. Good news: I've chosen the kernel 2.6.20-16-lowlatency instead of kernel 2.6.22-14-generic (the one installed with the upgrade) and everything is fine again (the SATA drive is mounted). I'll keep using this one by now, until something new arise. In two of the reboots I did (using the 2.6.22-14-generic kernel) I have received a message saying "Hal initialization error". I guess it has to do with that. I reinstalled the hal package with Synaptic, but nothing changed.

Revision history for this message
Marcos Wasem (mwasem) said :
#5

More information that can be useful (I hope no one else is in trouble with this): I'm experiencing problems with USB storage devices too. I receive the following message:

CANNOT MOUNT VOLUME
Unable to mount volume

mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program or other error. In some cases, useful info is found in syslog - try dmesg | tail or so

And then, this is what appears with the command:

 dmesg | tail
[ 264.870407] sdb: Mode Sense: 43 00 00 00
[ 264.870410] sdb: assuming drive cache: write through
[ 264.873145] SCSI device sdb: 1981440 512-byte hdwr sectors (1014 MB)
[ 264.874018] sdb: Write Protect is off
[ 264.874023] sdb: Mode Sense: 43 00 00 00
[ 264.874025] sdb: assuming drive cache: write through
[ 264.874029] sdb: sdb1
[ 264.937005] sd 2:0:0:0: Attached scsi removable disk sdb
[ 264.937065] sd 2:0:0:0: Attached scsi generic sg1 type 0
[ 265.344916] FAT: Unrecognized mount option "usefree" or missing value

Now I'm using kernel 2.6.20-16-lowlatency, the SATA drive is mounted, but I cannot mount the USB drives. I'll check if I can mount those with kernel 2.6.22-14-generic (with that one the SATA disappears), and I'll tell you what happen.

Revision history for this message
Marcos Wasem (mwasem) said :
#6

Using kernel 2.6.22-14-generic, I received a message saying that I have no permissions to mount the drive when plugging an USB flashdrive. I can mount them by means of a command (sudo mount . . . etc.)

Revision history for this message
Fai Wong (lazyfai) said :
#7

I've got this sata adapter and a 80G sata drive, ubuntu 7.10 kernel message shows that as the card is inic162c and the LBA48 support is not good, so it disables the drive. This is the real reason of us, inic16x users.
I think we cannot install Ubuntu on it until 8.04, or until someone custom made a kernel and the install CD with the driver turned on.

Revision history for this message
Endolith (endolith) said :
#8

Maybe it will work if you remove "usefree" option? See https://bugs.launchpad.net/ubuntu/+source/gnome-mount/+bug/151025

Can you help with this problem?

Provide an answer of your own, or ask Marcos Wasem for more information if necessary.

To post a message you must log in.