Please help recover an Ubuntu installation after an upgrade attempt

Asked by alexsokol

How it happened

I was upgrading my Ubuntu system from 7.04 to 7.10 online. In the middle of this process it just crashed and turned off all of a sudden. (Though online upgrade using update-manager is the recommended upgrade method!)

What I have now

Now the system is loaded up to the point where a blue screen with a mouse pointer appears. A complete desktop should be next, but it doesn't appear.

What I tried to do

A) In the recovery mode (console)

1) apt-get install..., apt-get update etc.

Error: dpkg was interrupted, you must run 'dpkg --configure -a'

When I run 'dpkg --configure -a' it shows a lot of dependency problems, tries to solve them, but is finally aborted:

Error: too many errors, stopping

2) 'do-release-upgrade'

Error: unable to get exclusive lock, some other package management program must be running. (???)

B) Using the alternate CD 7.10

1) Tried to upgrade from the CD with 'sh /cdrom/cdromupgrade'

Error 32: gutsy not found

2) Chose the item 'Rescue a broken system' on the CD menu. There appeared a kind of console - and what now? Any utilities or commands to recover a broken system?

That's it. What can I do in this situation? I would be very grateful if some of more experienced guys out there gave me some advice.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
MAGreen (m-a-green) said :

Do you know if your /home is on a partition separate from the root (/) partition?

If so, you can download a CD of 7.10, install it, making sure you select "guided" in the partition section. Make sure you do not format your home partition, and when the installation is complete, you will have all your files and settings saved - you may have to install any non-vanilla software you use, but your settings for your software will be available when you've installed the applications.

Other that this, I think it's in your best interest to do a vanilla install, and recover your files and settings from your backup (you do have a backup?)

If you get to install a fresh copy, make sure you use guided and put /home on a seperate partition, so that if something like this happens in the future, you can recover much more simply.

Hope this helps?

Revision history for this message
Anders (andersja+launchpad-net) said :

Alex, I had some similar problems when upgrading (a while ago) to the (then) Gutsy Beta.

I recommend trying:

sudo aptitude update && sudo aptitude safe-upgrade


sudo aptitude update && sudo aptitude dist-upgrade

If you are still having problems, perhaps filing a bug at will get you more attention.

Good luck, hope it works out.

Revision history for this message
Germán Pablo Gentile (germanpablogentile) said :

Alex, i think your problem is related to a tzdata bug. Wich timexone do you have? Just change that to some capital of europe and try again. If you cannot comeback to feisty changing the repos and start over. I also lost my upgrade for that fail and work changing the time zone ONLY for the upgrade.


Can you help with this problem?

Provide an answer of your own, or ask alexsokol for more information if necessary.

To post a message you must log in.