I need iPod help!!!

Asked by Shreya

I am new to the whole ubuntu thing as well as banshee...
so i basically don't know a lot
I have a raid bug on my iPod nano, which is the original version, not the new kind, and its a 4 gig

function print_raid_bug_warning () {
 echo " ************************* WARNING *************************"
 echo " * This iPod suffers from the volume.fsusage=raid bug. *"
 echo " * As such, it cannot be used in Banshee. This is not a *"
 echo " * Banshee or gnome-volume-manager bug. And the issue is *"
 echo " * very well known. *"
 echo " * *"
 echo " * Please read the following web page for more information *"
 echo " * including possible fixes to the problem: *"
 echo " * *"
 echo " * http://banshee-project.org/Troubleshooting/iPod/RaidBug *"
 echo " ***********************************************************"

function hal_dump_ipods() {

 for udi in `hal-find-by-property \
  --key portable_audio_player.type \
  --string ipod`; do

  ipod_count=$((ipod_count + 1))

  echo "<---- iPod Device $ipod_count ---->"

  hal-device $udi

  for child_udi in `hal-find-by-property \
   --key info.parent \
   --string $udi`; do

   hal-device $child_udi

   volume_fsusage=$(hal-get-property \
    --udi $child_udi \
    --key volume.fsusage 2>/dev/null \

   if [ ! "x$volume_fsusage" = "xfilesystem" ]; then

  if [ "x$has_raid_bug" = "xyes" ]; then

if [ -x `which ipod` ]; then
 echo "[[------------ Output of 'ipod --list' ------------]]"

 ipod --list


 echo "[[-------------------- HAL Dump -------------------]]"


This is what it says....and i tried some patches that i found...the problem is I don't konw where to put the patches and the patches i found were for the new 2 gig nanos
so if anyone could help me out...that would be greatly appriciated
thank you

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Anders (andersja+launchpad-net) said :

Hi. Did you try the tricks listed at http://banshee-project.org/Troubleshooting/iPod/RaidBug ? What you list above is a shell script. Save it to a text file (or in Firefox right click the link http://banshee-project.org/files/ipod-debug-dump.sh select a folder location you can easily find e,g, your user's home folder or your desktop) then open a terminal (click Applications -> Accessories -> Terminal ) and type: (if it's in your home directory):

chmod u+x ipod-debug-dump.sh



and see what it says.

If your ipod is confirmed as buggy, this issue should have been fixed by this: https://launchpad.net/distros/ubuntu/+source/hal/+bug/66068

If you believe it is still not fixed, please add your comments to that bug or open a new bug here (include references to this question and the above bug for speedier processing!): https://bugs.launchpad.net/ubuntu/+source/hal/+filebug

Revision history for this message
Shreya (shreyap2006) said :

when i open terminal it says file is not found. And i saved it in my desktop and tried what you wrote!

Revision history for this message
Anders (andersja+launchpad-net) said :


if you saved it to the desktop, open a terminal and do:

cd Desktop


chmod u+x ipod-debug-dump.sh



Can you help with this problem?

Provide an answer of your own, or ask Shreya for more information if necessary.

To post a message you must log in.