resolution on ps3

Asked by jasonnita

How do i change my resolution on ubuntu linux for the ps3. Please give me the step by step solution. Im new to linux and have not used it in the past.

Someone here said to change it on the command prompt or something, but i dont know how to get there.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Gord Allott (gordallott) said :
#1

the playstation 3 is not an offically supported medium to use ubuntu on, and i am not familiar with it myself but running the command
xrandr -s <width>x<height>

so for example
xrandr -s 1024x768

you can usually find the terminal by going to the Applications menu, then Accessories and clicking Terminal

Revision history for this message
Ralph Ulrich (eulenreich) said :
#2

Do not use xrandr on ps3. Gutsy for ps3 is a totally broken release - missing modules, programs from non-ports that must not run (network-manager etc). It should have configured following (from http://www.psubuntu.com/forum/):

Edit kboot.conf to set the correct video mode in there:
sudo nano /etc/kboot.conf

video=ps3fb:mode:<video mode ID>
Drawing resolution can be set explicitly, if needed. If there is no video syntax, auto mode is used.
0: auto mode , default value
YUV 60Hz 1:480i 2:480p 3:720p 4:1080i 5:1080p
YUV 50Hz 6:576i 7:576p 8:720p 9:1080i 10:1080p
RGB 60Hz 33:480i 34:480p 35:720p 36:1080i 37:1080p
RGB 50Hz 38:576i 39:576p 40:720p 41:1080i 42:1080p
VESA 11:WXGA 12:SXGA 13:WUXGA

full screen mode: <video mode ID> + 128
dither ON mode : <video mode ID> + 2048

We want 1080p with full screen mode this means 5+128=133. Our paramater will be video=ps3fb:mode:133
The linux line should look like this:
linux='/boot/vmlinux initrd=/boot/initrd.img root=/dev/sda1 video=ps3fb:mode:133'

Revision history for this message
Tari Damni (tdamni) said :
#3

I've just put Ubuntu 8.10 on my ps3 and am trying to do the same thing I will use 1080i so I change the number to 131 my question is do I delete all the other information that comes up after putting this in

"linux='/boot/vmlinux initrd=/boot/initrd.img root=/dev/sda1 video=ps3fb:mode:133' " without commas

Revision history for this message
jakethesnake1982 (sjm8506) said :
#4

Hello, I'm kind of new to this, so hopefully I'm posting this in the correct spot.

Thanks for the great info Ralph. I am currently trying to setup my display resolution, and was wondering if there is a means by which to test the screen resolutions before choosing one. If not, then is there a way to transition back to the default settings with which ubuntu (7.10) installs with? I'm using a 37" LCD with HDMI input. I'm pretty sure it supports 1080i, but would like to test this first.

I found a walkthrough that details the information listed by Ralph above, and tells me to enter Applications > Accessories > Terminal

Then it says to enter "ps3-video-mode -h" which gives me a listing of the resolutions, and what to enter to change it.

When I try to enter "ps3-video-mode -v 131" (720p); "....... -v 132" (1080i); or "....... -v 133" (1080p); it only shows a small strip of distortion acrossthe top of the display. Luckily I have had success with getting it back to the default resolution without rebooting, but it's quite frustrating. I've been messing with different resolution numbers, and combinations for over an hour. Someone please point me in the right direction.

Revision history for this message
JD (david-recco) said :
#5

I am having the same problem as jakethesnake. can anyone help with this? kboot also boots in 480. i am using a 32" 720p tv as a monitor.

Can you help with this problem?

Provide an answer of your own, or ask jasonnita for more information if necessary.

To post a message you must log in.