No system sounds after updating to Ubuntu 7.10

Asked by TWO on 2007-10-22

I have recently updated from Feisty Fawn to Ubuntu Gutsy Gibbon 7.10 on a Dell Inspiron 1300 laptop.

My problems are that I can no longer play sounds via the ALSA option. On selecting it and testing the sound in the Sound menu, I am presented with he following error message:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open resource for writing.

I have reverted to the OSS option, and though I can play music the system sounds aren't working at all.

It might not be the most major issue, but I'd really like my system to be running as well as I had it before I upgraded.

If it helps, I think the sound card codec is: SigmaTel STAC9200

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
TWO
Solved:
2007-12-13
Last query:
2007-12-13
Last reply:
2007-10-25

I have the same problem on both my machines, a self-assembled desktop and an Acer aspire 1610 laptop.

NOTE:
the login sounds works (I can hear the sound before login and the sound immediately after login)
In System -> Preferences -> Sound the system sound are enabled and I can hear by the play button
All playing software (aplay, alsaplayer, timidity, xmms) work fine
The firefox Flash plugin by Adobe (not free) works
Only the Gnome system sounds don't work

FOUND A FIRST WORKAROUND!!
In both cases the system sounds restart if you REINSTALL ESOUND (and restart esd demon or reboot)
sudo apt-get install esound and reboot

Ok, I guess that Gibbon has a new sound server, right?
And maybe this sound server has an esound mode for backward compatibily...

TWO (two) said : #2

I wish I could be of more technical expertise but for whatever reason, a more recent attempt to upgrade to Gutsy Gibbon does not have the sound problem any more which has pleased me greatly.

I can confirm that the sound issue doesn't seem to exist any more for the Dell Inspiron 1300.

Calvin Lichtenstein (bouvier) said : #3

I'm running Gibon with the latest update on an ASUS mother board and a 3.0Ghz D processor with 2Gs of RAM. I have a seperate Turtle Beach Sound card. With the initial update to 7.10 the sound was fine until the latest update. Not being complete fluent with Ubuntu as I am with XP Pro, I'm finding it difficult to understand the what options are open to me to try and going into System -> Preferences -> Sound, there are a number a number of options open to me, but unsure what which ones I should be using. Can anyone inform me as the options they might have tried to get the sound running in the version of Ubuntu.

Thanks