Unable to dual boot to windows xp after installing ubuntu 11.04

Asked by T on 2011-05-11

I installed unbuntu 11.4 on top of my windows xp os and when I rebooted i did not see the option to boot to windows, only ubuntu os appearedd. I may have taken the wrong option when trying install along side windows as a dual boot. How do i reload my windows boot loader so i have a dual boot option? All of my windows files are still present. I tried booting to a windows CD to do a repair but that did not work. Any assistance would be much appreciated.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-12
Last reply:
2011-05-28

Can you give the output of:

sudo fdisk -l; lsb_release -a

Thanks

T (gracemercy54) said : #2

Results of sudo fdisk -l; lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

Can you run the command I gave please....

T (gracemercy54) said : #4

Disk /dev/sda: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x40824081

   Device Boot Start End Blocks Id System
/dev/sda1 1 5 40131 de Dell Utility
/dev/sda2 * 6 19028 152802247+ 7 HPFS/NTFS
/dev/sda4 19029 19452 3405780 db CP/M / CTOS / ...

Disk /dev/sdb: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7c2338eb

   Device Boot Start End Blocks Id System
/dev/sdb1 1 5 40131 de Dell Utility
/dev/sdb2 6 17276 138728659 7 HPFS/NTFS
/dev/sdb3 17276 19453 17479681 5 Extended
/dev/sdb5 17276 19323 16441344 83 Linux
/dev/sdb6 19323 19453 1037312 82 Linux swap / Solaris

Try:

sudo apt-get -y install os-prober; sudo os-prober; sudo update-grub

Should do it

T (gracemercy54) said : #6

sudo apt-get -y install os-prober
[sudo] password for tldixontl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
os-prober is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 81 not upgraded.
sudo os-prober
ERROR: isw: wrong number of devices in RAID set "isw_deadcfeccb_ARRAY" [1/2] on /dev/sda
/dev/sdb1:Dell Utility Partition:DellUtility:chain
sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.38-8-generic
Found initrd image: /boot/initrd.img-2.6.38-8-generic
Found memtest86+ image: /boot/memtest86+.bin
ERROR: isw: wrong number of devices in RAID set "isw_deadcfeccb_ARRAY" [1/2] on /dev/sda
Found Dell Utility Partition on /dev/sdb1
done

I don't use raid so am no use here, the os-prober should see the OSes and configure grub. Maybe others can help

T (gracemercy54) said : #8

I rebooted and the windowws boot option was not listed. Any other ideas. I have 2 hard drives that used to be in Raid 1 array. I broke up the array and now have 2 separate hard drives not being mirrored now.

T (gracemercy54) said : #9

After researching the error about the wrong number of devices in the Raid I found the following solution to fix that problem:

this error message came up

ERROR: isw: wrong number of devices in RAID set "isw_djcbaiedeg_RAID_Volume1" [1/2] on /dev/sdb

There is no RAID setup on my computer so this is probably caused by the disk (/dev/sdb) might have been used in a RAID setup before. The RAID medata still remains on the disk.

Fix this problem by using the dmraid command to remove this metadata

sudo dmraid -rE

After running this command and then re running the commands that you gave me and rebooting I was able to see the Windows XP boot option. But when I select it starts to boot but keeps looping back to the dual boot screen to select all over again. Any ideas?

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.