Dell Insprion 5100 - Cannot access BIOS after installing Ubuntu 7.04

Asked by Torian on 2007-10-14

Hi All,

I have recently installed Ubuntu 7.04 ("The Fiesty Fawn") on my Dell Inspiron 5100. Recently, I wanted to boot from the "Auditor" Live Security Tools cd. When I tried to boot from the CD, it seems that the computer bypassed the cd and loaded immediately into Grub. (I got the "Loading Grub 1.5" screen) Immediately, I thought it was a problem with my BIOS configuration, so as I proceed to press "F2" at the Phoenix Bios (Dell) screen, it just bypasses onto the "Loading Grub 1.5" screen again. I am sure that my keyboard nor my cd-rom drive is defective because I was able to press the "ESC" key and see my computer count RAM. In addition to that, I am able to load CDs without any problem in Ubuntu once it is loaded and I was able to install the Ubuntu without a hitch before.

Lastly, I have tried to choose the boot order by pressing "F12" during the same BIOS screen, but to no avail. I believe that somewhere along the line, the GRUB installation caused for the BIOS partition (which I would not think that there would be such a thing...but who knows) to be over-written or at least re-directed and is unable to be loaded. I have read on another forum where this exact problem occurred:

http://ubuntuforums.org/showthread.php?t=510324

Just to recap, I have pressed the correct buttons until I was blue in the face and was not able to get it to load. Could anyone possibly reproduce this and determine if there is a way to fix this. I am so appreciative of your help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Torian
Solved:
2007-10-14
Last query:
2007-10-14
Last reply:
2007-10-14

This question was reopened

Luke Faraone (lfaraone) said : #1

No idea how to fix the BIOS problem as although I have a dell box, I am not havign that issue.

However, it is possible to boot from a CD from within GRUB, and the steps to do so are gone over on this page : http://gentoo-wiki.com/TIP_Chainloading_a_bootable_CD-ROM_from_GRUB

Torian (torian) said : #2

Hi All,

Thanks for the response. After further review of the link that I posted, I just upgraded my BIOS from A06 to A22 and it resolved my issue. Thanks for the help though! :c)