Input Method switcher

Asked by Noahs.hub on 2005-10-01

I'm new to Linux and I would like to migrate to it from Microsoft. but I have some concern, particularly using the software with a default English language as default but can immediately switch between Korean,Japanese, or Chinese (like in XP where you can switch encoding text for these asian languages).

I downloaded the latest Ubuntu software and installed it in one of my PC. Also added the above languages in the Language Selector. However, I do not know how to switch between these languages when I would like to email using Korean, Japanese or Chinese text. Please help. Thank you and more power.

 you use ibus and it have default short cut control+space buttens it chage easily change between the languages

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Herman Bos
Solved:
2005-10-01
Last query:
2005-11-15
Last reply:
2005-10-16

What exactly do you want to do? Normally all three locales you gave will be activated. Do you want to run the programme in one specific language or do you want to enter text in that language?

Herman Bos (hbos) said : #2

You can use scimd to use chinese (and other asian languages) input support. Search for scim in synaptic.

You need to run scimd in the background (its in an howto somewhere how to add it to the sessions) If you can't work it out i can search for it later, but its a bit late now.

My chinese friends were quite happy with it. :)

Herman Bos (hbos) said : #3

Step 1: Search for scim in synaptic and install the needed packages. Also find search for language-support and install the desired languages.

After a quick look you probably need:
scim
scim-chinese
scim-chewing
scim-config-socket
scim-frontend-socket
scim-gtk2-immodule
scim-server-socket
xfonts-intl-chinese
scim-tables-ja
scim-tables-ko
scim-tables-zh
scim-chewing
language-support-zh
language-pack-zh

and maybe some additional fonts.

Step 2: Go to "System" -> "Perferences", and select "Sessions". In "Startup Programs", add the command "scim -d".

Step 3: Logout and Login.

If i'm not mistaken you can get the input by pressing ctrl+alt.

Herman Bos (hbos) said : #4

SCIM should also appear in your System -> preferences menu.

Herman Bos (hbos) said : #5

Font packages:

xfonts-intl-chinese
xfonts-intl-japanese
xfonts-intl-asian
ttf-arphic-gbsn00lp
ttf-arphic-gkai00mp
ttf-arphic-bkai00mp
ttf-arphic-bsmi00lp

search for xfont and ttf in synaptic ;)

Herman Bos (hbos) said : #6

CTRL-SPACE brings up the input dialog.

Currently i'm testing this in Breezy but some problems occur. AFAIK it should work on Hoary.

Herman Bos (hbos) said : #7

http://www.mrbass.org/linux/ubuntu/scim/

Sorry for all the comments :)

David Oftedal (rounin) said : #8

It should be mentioned that SCIM isn't currently working on Ubuntu. You'll have to compile it yourself or wait for a fix.

David Mandelberg (dseomn) said : #9

You could use uim if scim doesn't work. Install uim, uim-applet-gnome, uim-gtk2.0, and backend(s) (e.g. uim-skk, uim-canna, uim-prime, or uim-m17nlib).

ZhengPeng Hou (zhengpeng-hou) said : #10

If you want to use scim sa your default input method .do as below:

$sudo sh -c " echo 'export XMODIFIERS=@im=SCIM ; export GTK_IM_MODULE="scim" ;export QT_IM_MODULE="scim" ; scim -d ' > /etc/X11/Xsession.d/95xinput "

$sudo chmod +755 /etc/X11/Xsession.d/95xinput

then scim will start with your X .

Noahs.hub (noahs-hub) said : #11

Thank you very much!!

hi you use ibus it have default language shortcut key control+space