Can't write subfolders in shared partition

Asked by TWO on 2007-10-04

I have a FAT32 shared partition between Ubuntu Feisty Fawn and Win XP. The partition is correctly mounted- I have checked this many times- but I am unable to create or delete folders in the sub folders of the partition. I'm really not sure what to do. Furthermore, each of the folders I'm trying to write into have a padlock icon on them. What does that mean? I have gone through page after page of forums and I have not found a solution. I tried to change read only options from windows but this has changed nothing. I am a Linux newbie but I have done enough to be aware that I have mounted the drive correctly. Any help would be greatly appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-10-21
Last reply:
2007-10-21
Alan (mrintegrity) said : #1

Type the following in a terminal to ensure that the drive is mounted
read and write:

mount

this will display information about all the mounted file systems. On the
line describing the Fat partition you will see either "rw" for read and
write or "ro" for read only, it needs to be "rw" and if it's "ro" then
you can remount it. We will cover that later if you need it.

If it shows as "rw" already then you need to change the permissions
(fake, fat doesn't actually support permisisions) so that the owner is
the user that you try to access the drive with and the group is set to
"users" this will allow all users some level of access.

sudo chown YOURUSERNAMEHERE:users /media/FATDRIVEHERE

obviously you should replace "YOURUSERHERE" with the user account name
and replace FATDRIVEHERE with the name of the partition under the
"/media/" directory.

Be carefull to write the commands as I told you exactly as it is quite
possible to mess up the system with a typo in those commands.

Alan

On Thu, 2007-10-04 at 15:13 +0000, TWO wrote:
> New question #14507 on Ubuntu:
> https://answers.launchpad.net/ubuntu/+question/14507
>
> I have a FAT32 shared partition between Ubuntu Feisty Fawn and Win XP. The partition is correctly mounted- I have checked this many times- but I am unable to create or delete folders in the sub folders of the partition. I'm really not sure what to do. Furthermore, each of the folders I'm trying to write into have a padlock icon on them. What does that mean? I have gone through page after page of forums and I have not found a solution. I tried to change read only options from windows but this has changed nothing. I am a Linux newbie but I have done enough to be aware that I have mounted the drive correctly. Any help would be greatly appreciated.
>

Alan (mrintegrity) said : #2

Actually, that command should have been

"chown -R YOURUSERNAMEHERE:users /media/FATDRIVEHERE"

It won't do any harm to re run the command with the -R added.

Alan

On Thu, 2007-10-04 at 17:18 +0200, mrintegrity wrote:
> Type the following in a terminal to ensure that the drive is mounted
> read and write:
>
> mount
>
> this will display information about all the mounted file systems. On the
> line describing the Fat partition you will see either "rw" for read and
> write or "ro" for read only, it needs to be "rw" and if it's "ro" then
> you can remount it. We will cover that later if you need it.
>
> If it shows as "rw" already then you need to change the permissions
> (fake, fat doesn't actually support permisisions) so that the owner is
> the user that you try to access the drive with and the group is set to
> "users" this will allow all users some level of access.
>
> sudo chown YOURUSERNAMEHERE:users /media/FATDRIVEHERE
>
> obviously you should replace "YOURUSERHERE" with the user account name
> and replace FATDRIVEHERE with the name of the partition under the
> "/media/" directory.
>
> Be carefull to write the commands as I told you exactly as it is quite
> possible to mess up the system with a typo in those commands.
>
> Alan
>
>
>
> On Thu, 2007-10-04 at 15:13 +0000, TWO wrote:
> > New question #14507 on Ubuntu:
> > https://answers.launchpad.net/ubuntu/+question/14507
> >
> > I have a FAT32 shared partition between Ubuntu Feisty Fawn and Win XP. The partition is correctly mounted- I have checked this many times- but I am unable to create or delete folders in the sub folders of the partition. I'm really not sure what to do. Furthermore, each of the folders I'm trying to write into have a padlock icon on them. What does that mean? I have gone through page after page of forums and I have not found a solution. I tried to change read only options from windows but this has changed nothing. I am a Linux newbie but I have done enough to be aware that I have mounted the drive correctly. Any help would be greatly appreciated.
> >

TWO (two) said : #3

Thanks for your reply. I typed in the commands that you sent me. The 'mount' command gave me the list of the mounted drives, all of which stated that they were 'read and write.' I then entered in the command to change ownership and various file names appeared in the terminal. However, each file name was followed by the words "Operation not permitted.'

What could be missing?

Any suggestions would again be greatly appreciated.

Alan (mrintegrity) said : #4

Ah sorry, thats because it's FAT and doesn't actually support changing permissions. Please post the contents of your fstab here:

cat /etc/fstab

Alan (mrintegrity) said : #5

Also please post and "ls" output from the directory where the shared
folder is:

ls /media/

for example.. not "ls /media/fatdrive"

Alan

On Fri, 2007-10-05 at 09:04 +0000, Alan Mc wrote:
> Question #14507 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/14507
>
> Status: Open => Answered
>
> Alan Mc proposed the following answer:
> Ah sorry, thats because it's FAT and doesn't actually support changing
> permissions. Please post the contents of your fstab here:
>
> cat /etc/fstab
>

TWO (two) said : #6

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda3 -- converted during upgrade to edgy
UUID=edf5395f-e92c-49a5-819e-1b1461a062d7 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda1 -- converted during upgrade to edgy
UUID=07D6-0A17 /media/hda1 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/hda2 -- converted during upgrade to edgy
UUID=0094786494785E5A /media/hda2 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/cdrom /media/cdrom0 udf,iso9660 user,noauto 0 0
# /dev/hda4 -- converted during upgrade to edgy
UUID=46B7-CA47 /media/share vfat iocharset=utf8,umask=000 0 0

Alan (mrintegrity) said : #7

as I said, please also post the output of "ls -al" in the /media/directory, like so:

ls -al /media/

Alan

TWO (two) said : #8

Sorry for the late reply. This is the results of entering in the second piece of code you sent.

drwxr-xr-x 7 root root 4096 2007-10-10 14:09 .
drwxr-xr-x 24 root root 4096 2007-09-17 20:03 ..
lrwxrwxrwx 1 root root 6 2007-08-07 09:49 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2007-08-07 09:49 cdrom0
-rw-r--r-- 1 root root 0 2007-10-10 14:09 .hal-mtab
-r--r-s--- 1 root root 0 2007-09-17 20:06 .hal-mtab-lock
drwxrwx--- 3 root plugdev 16384 1970-01-01 09:00 hda1
dr-xr-x--- 1 root plugdev 4096 2007-10-10 13:35 hda2
drwxrwxrwx 13 root root 16384 1970-01-01 09:00 share
drwxr-xr-x 2 root root 4096 2007-08-07 10:35 windows

TWO (two) said : #9

Sorry. Posted the wrong information. I think this is correct. Brings up a list of the folders on the drive in various colours:

comcom sdk YOSHI'S FILE
dscn0041.avi Tachi-iri Kinshi YOSHI'S MUSIC
dscn0042.avi Thumbs.db YOSHI'S PICTURES
'Linux UBUNTU' Only Files 'WINDOWS' Only Files YOSHI'S VIDEO
Recycled YOSHI'S CLIPS

TWO (two) said : #10

Hello.

Were the details that I posted correct?

Alan (mrintegrity) said : #11

it should be fixable by typing this:

sudo chown YOURUSERNAME:users /media/share
sudo chown YOURUSERNAME:users /media/hda1

As for the NTFS partition thats a different matter, you can still get full read write with it however.

Make sure you change YOURUSERNAME to be whatever name you use to log in with, for example, you your username was "variant" like mine is then you would enter:

sudo chown variant:users /media/share

TWO (two) said : #12

Hello.

I entered the code in as you instructed and I was presented with the following message in the terminal:

chown: changing ownership of `/media/share': Operation not permitted

I don't know whether this effects too much but I have recently updated to the Gutsy Gibbon version of Ubuntu. This seems to have created a new situation in that I am now able to create a new folder or document in the subfolder of the shared partition, but no longer in the immediate 'share' folder.

There are still padlock symbols above some of the folders in the shared partition too. What does that mean?

Thanks for your suggestions.

TWO (two) said : #13

I think I might have just aggravated things a little more.

I accessed the files through the 'sudo nautilus' command and have subsequently made all the documents in the subfolders read-only as I was trying to change the permissions via that route...

Why is it so difficult to the change the permissions?

I hadn't even set up the shared partitions through Ubuntu, so why is it so difficult to modify it?

Alan (mrintegrity) said : #14

It's so difficult because the fat filesystem doesn't support permissions at
all therefore ubuntu has to apply "fake" permissions.

On 10/21/07, TWO <email address hidden> wrote:
>
> Question #14507 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/14507
>
> TWO gave more information on the question:
> I think I might have just aggravated things a little more.
>
> I accessed the files through the 'sudo nautilus' command and have
> subsequently made all the documents in the subfolders read-only as I was
> trying to change the permissions via that route...
>
> Why is it so difficult to the change the permissions?
>
> I hadn't even set up the shared partitions through Ubuntu, so why is it
> so difficult to modify it?
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Can you help with this problem?

Provide an answer of your own, or ask TWO for more information if necessary.

To post a message you must log in.