change operating system at boot up

Asked by firefox

I want to have win98 as the default at boot up but the help file says to go to app menu,system tools,boot. Well, there is no boot to go to.

I tried command line but it will not take "boot-admin" as suggested in the help file.
Now what to do?

Thanks, firefox

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Martin
Solved:
Last query:
Last reply:
Revision history for this message
Martin (martin10) said :
#1

you have to edit manually your /boot/grub/menu.lst configuration file.

Run the following commands in the terminal:

sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
(if prompted, enter your normal user password)

sudo gedit /boot/grub/menu.lst

Text editor should appear. Now, find the line:

default 1

and change it to:

default 2
(if you are not sure about the number, restart your computer and look at the menu on wich position is win98)

if something fails, run:

sudo cp /boot/grub/menu.lst.bak /boot/grub/menu.lst

regards

Revision history for this message
firefox (firefox-user2) said :
#2

Thanks for the quick response.

I tried your suggestion as well as others during the past few days I found in the help section without success.

I am using Ubuntu ver: 6.06 loaded on a slave drive with good old win 98 on the master drive.

After typing in the codes in terminal, the gedit box appears with two tabs showing.

One tab is " Menu.1st
Second tab is " Menu.1st.bak
The is no text appearing in the edit section, just blank.

I tried to open both tabs by clicking on them but no luck.

Keep in mind I am a neebie at this.

Any other suggestions?

THanks.

Revision history for this message
Olivier Cort├Ęs (olive) said :
#3

it is menu.Lst (a small L, not a "1" (one)). you could copy-and-paste the command suggested.

the "default" option number suggested is function of how many lines "title" you have in the file, which do not start with a #.
count the "title" lines (starting from 0, not 1) and change the "default" at the start of the file to point to the number of your Win98 partition.

Revision history for this message
firefox (firefox-user2) said :
#4

Success!!
I was sure that was a #1 and not an" L". But after following your directions I tried it again and it worked. Win 98 is now the default operating system.
I wish Ubuntu would include a simpler way to do this in the preference section as other Linux systems have done.
( Xandros) for example.

Thanks again for your help, now on to my next learning experience.
Have a nice day!

Firefox_user2