lost Network connection after uploading ubuntu 7.10

Asked by mremerpus furadu on 2007-09-27

Just uploaded Ubuntu 7.10, lost my connection to internet. Need help...

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-09-30
Last reply:
2007-10-22
Jim Hutchinson (jphutch) said : #1

7.10 is not an official release yet. It's still beta software and bugs like this are expected. If you don't feel comfortable troubleshooting problems, it's best to avoid beta (and even more so alpha) releases.

If you can be a bit more specific about the problem, what exactly happens when you try to connect, how you connect, what hardware you are running, whether this is wifi or ethernet and so on we might be able to help but no guarantees.

mremerpus furadu (mremerpus) said : #2

Dear Jim, Thank you for responding, I am running a ethernet connection DSL, having trouble loging in as user, so am using root. When loaded, desktop shows 'internal error' "failed to initialize HAL!". After closing error box, everything looks great, when I try to open firefox, drop down menu Server not found appears. Saying " Firefox can't find the server ....

Jim Hutchinson (jphutch) said : #3

my guess is that if you can't log in a regular user then something else is messed up and that may be part of your network problem. HAL stands for hardware abstraction layer. I don't know much about what it does but I suspect that hardware is not going to work well.

There isn't a root account enabled by default so unless you set that up it shouldn't work. Assuming you did set it up, how did you do it and did you make any changes to user accounts or permissions? Was there anything else you did that might account for users not being able to log in?

mremerpus furadu (mremerpus) said : #4

Dear Jim, Thanks again.. This computer was set up by a friend who has extensive knowledge of linux systems. He configured Ubuntu 7.4 on a Debian release of linux. using a Grub boot config. Where he named me as root. I can't get in touch with him as he has moved on. I subsequently added new user '1' & '2' at the outset it was
apparent to me that I didn't have control of permissions because I was never able to log-on using any account but the root, to make changes to how the system was operating. Recently I was informed that I could not reinstall different Ubuntu release unless it was later than the one I had. Therefor the idea of upgrading to 7.10. Hoping to get control. After 4 hours of download time before completing online upgrade. I was unable to access the internet as before, however I am able to access a terminal window from the same root account that he set up in the beginning. Recently I purchased a new release of Debian on a cd. But after trying to change the Bios boot order cannot get machine to boot from cd. Would like to wipe hard drive clean and start again, can you advise?

Jim Hutchinson (jphutch) said : #5

To be honest, I'm not sure where to start to fix this or if it's even possible. It sounds like you had a somewhat custom install and I suspect that the upgrade process may not have gone real well - hence the problems. If it were me, I'd wait for the official release and do a new, clean full install. That will clean things up and solve all of these problems. Obviously back everything important up before doing that.

Sorry I can't be more help but cleaning up an alpha upgrade over a custom install won't be pretty and out of my league.

The same problem, previous OS Ubuntu 7.4, I upgrade my Thinkpad T23 to Ubuntu 7.10 Beta with Internet and now it's not possible use internet.
The connection is wired and the ip address is keep correctly from DHCP ... bye

rowanrook (brentrowan) said : #7

 I just upgraded to 7.10 and I have the same problem. HAL won't initialize, network connections (ethernet, wireless, and usb) all lost. I tried to reconfigure them but then the system just hangs. This is a major problem which renders Ubuntu unusable. Right now I am inclined to categorize the upgrade as malware.

celticninja (jarrell-j-65) said : #8

I just upgraded to, and am having the same problem. But my version of Ubuntu 7.4 worked fine, and then i upgraded and i didn't get the message until i rebooted. and also for some reason it won't boot up in Xscript

John Seely (johntseely) said : #9

I upgraded to 7.10 Saturday and ran into some problems too. I haven't finished sorting it all out but I can add some detail that may help someone with more time or knowledge than I have.

I'm using a Dell D620 with the built-in wifi based on the Broadcom chipset. Prior to the upgrade I used an older Proxim RangeLAN wifi card that was recognized and worked fine without restricted drivers or ndis wrappers. Qwest is my ISP and I use the Actiontec (I don't like that thing!)DSL modem-router-accesspoint.

During the first boot after the upgrade, the built in wifi was recognized and I was offered the choice to use "restricted" drivers needed to make use of it... I decided to give that a go.

I didn't notice a problem until I tried to use Firefox with Google as my home page. The attempt to connect and I got a server not found error. Several attempts yielded the same thing. Interesting thing though - trying www.ask.com worked! Back to Google - server not found.

Seemed like a resolver issue to me so I tried a few things including changing the DNS settings on the Actiontec router and changing the resolve.conf file (via network manager). That seemed to improve things to the point that I could access Google, but it seemed way slower than before the upgrade and I'd still time out every few tries.

My desktop is running 7.04 still and all is good there - I don't see any change in it's performance or behaviour, even with my fiddling about with the Actiontec DNS settings.

I'll work on it again tonight... I'm thinking of re-installing, only this time I'll decline to install the restricted drivers and see how that goes.

celticninja (jarrell-j-65) said : #10

I researched on the Ubuntu forums and something is going on with HAL and the dbus, so I tried a soloution someone suggested pertaining to the dbus.

you login under root and then type this into the terminal:
"dpkg --configure -a" (without quotations)

And when i did the upgrade before there was a question about drivers and it gives some options with the default being "N", i put "Y" and that allowed me to at least get onto the network so i then went into Synaptic and reinstalled HAL

Ever since then it has been working great.

Can you help with this problem?

Provide an answer of your own, or ask mremerpus furadu for more information if necessary.

To post a message you must log in.