choosing default sound card

Asked by notoqueeltoro

as with many people in these forums, I'm trying to switch to Ubuntu (from winXP) and I'm having problems with my sound cards. I'm using Ubuntu Feisty (technically Kubuntu Feisty with Gnome added and set to default--if that matters) on a Compaq Evo n620c Laptop.

I have an onboard soundcard that was detected on startup (though, I just tried " sudo asoundconfig list " and my onboard sound card wasn't listed, so I'm not sure if I messed something up...

I also have a USB soundcard that I use when I'm at home--which is just called USB audio from " sudo asoundconfig list ". I tried editing


I added the lines

options snd-usb-audio index=0
options snd-intel8x0m index=1

to the end of the file. The problem is that sets the USB audio to my default card always. I only want it to be the default when my usb sound card is plugged in. Any suggestions?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
notoqueeltoro (m-gilson) said :

Addendum: I just restarted:

" sudo asoundconfig list " returns--
Names of available sound cards:

with the USB sound card unplugged and
Names of available sound cards:

with the USB sound card plugged in

Revision history for this message
Guillaume Martres (smarter) said :

You can try to comment line:
options snd-intel8x0m index=-2
in file /etc/modprobe.d/alsa-base and delete the lines you added, normally if your usb card is plugged in when you boot, it will take index 0, otherwise your built-in card will be used.

Revision history for this message
Stefan Bethge (kjyv) said :

Maybe this way of doing it is a help to some:

Can you help with this problem?

Provide an answer of your own, or ask notoqueeltoro for more information if necessary.

To post a message you must log in.