update problems maybe a bug

Asked by gerath32003 on 2007-09-20

I have this update problem i am not sure what is going on but the synaptic package keeps crashing and closing out. i have an update icon that appares but when i click it i get these errors.. If anyone can help me ..

Could not initialize the package information

A unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Dynamic MMap ran out of room, E:Error occurred while processing libgnomecanvas2-0 (NewFileVer1), E:Problem with MergeList /var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened.'

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
gerath32003
Solved:
2007-09-22
Last query:
2007-09-22
Last reply:
2007-09-20
Massimo Forti (slackwarelife) said : #1

Thanks for your post. If you want to open a bug report you can do it using this link:

https://answers.edge.launchpad.net/ubuntu/+question/13747/+makebug

But, before do it, you can tell us the version of your ubuntu.

Thanks

Wrwrwr (wrwrwr) said : #2

There seems to be a lot of reports for this, but it should be easy enough to solve.

Try typing this in terminal:
sudo apt-get update -o APT::Cache-Limit=16777216
If it still doesn't work insert some bigger number (it will be allocated on disk; in bytes).

Same thing can be done putting a line:
APT::Cache-Limit “16777216″;
in /etc/apt/apt.conf or in one of the files in /etc/apt/apt.conf.d/ (preferably 90perso, 70debconf or 20archive).

Alternatively you can disable some unneeded repositories using System-->Administration-->Software Sources-->Third Party Software.

This can also be accomplished editing /etc/apt/sources.list.

gerath32003 (gerath32003) said : #3

Thanks Wrwrwr and Massimo Forti you guys are great it working out with the terminal fix and i also removed all other repositories entries for now just have the security updates repositories and i also reported this bug and it appeared the a lot of people where having the same issue. BIG THANK YOU..

dannycrobo1 (dannycrobo1) said : #4

i have a little icon on the top of my screen, it is a red circle with a white line through it.

it says that i must run the pckage manager. when i do so, this error message appears:

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_jaunty-security_restricted_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

please what do i do because i cannot run my update tool or anything.

dan

When I'm trying to update or install a new program i get this message!

"There are broken dependecies on your system. Please use an advanced package manage e.g. Synaptic or aptitude to resolve this situation."

I'm not that god on the terminal thing

I have the latest Kubuntu 9.10 and updated everything until this came up.

What shall I do?

regards

Wrwrwr (wrwrwr) said : #6

I doubt you'll need terminal to fix that, with vanilla Ubuntu that would be: System --> Administration --> Synaptic Package Manager, and after typing your password, Edit --> Fix Broken Packages. I don't even know if Kubuntu 9.10 still uses Adept or if it's already KPackageKit, however if it's the latter, seems it doesn't have a similar function, so you'd need to use e.g. aptitude (type "sudo aptitude -f" in a terminal, without quotes, hit enter and confirm with your password).

Anyway, you'd do better creating a new question, rather than commenting on an old one (click "Answers" at the top, and "Ask a question" in the upper right corner"), better chance for an answer from someone who actually uses Kubuntu :-)

I'm new around here so.... I'm sorry!

 I fixed it!

Tried the "terminal thing" and wrote "aptitude" and that fixed it after some try and error!

Really proud over myself :-)

Regards