¿Cómo puedo colocar un ip alias a mi tarjeta de red?

Asked by cablop on 2007-09-20

Necesito crear un ip alias para mi tarjeta de red.

El problema es el siguiente, tengo una sola tarjeta de red y ella debe tener dos ips, una fija que se emplea en la intranet y una dinámica asignada por el proveedor de Internet.

Debo hacer que la configuración se mantenga pues puedo establecerla manualmente pero debo hacerlo cada vez que inicio sesión, lo cual ralentiza el trabajo si ninguno de los que sabemos hacerlo estamos en el área de trabajo, ya que el computador Ubuntu queda fuera del grupo de trabajo.

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Julián David Duque
Solved:
2007-09-23
Last query:
2007-09-23
Last reply:
2007-09-21
Best Julián David Duque (xphree) said : #1

Hola!

Tengo dos posibles soluciones para tu problema!

1. /etc/rc.local
En el archivo rc.local colocas la linea con la que configuras la interfaz virtual
ifconfig eth0:0 192.168.1.1
Por ejemplo, asi, cada que se inicie el sistema, esta linea se va a ejecutar (para eso es el rc.local)
Nota: Esta solucion la he probado y funciona!

2. /etc/network/interfaces
En este archivo podrias tener la siguiente configuracion
auto eth0
iface eth0 inet static
         address 62.43.238.38
         netmask 255.255.255.224
         network 62.43.238.32
         broadcast 62.43.238.63
         gateway 62.43.238.33

auto eth0:0
iface eth0:0 inet static
         address 62.43.238.56
         netmask 255.255.255.224
         network 62.43.238.32
         broadcast 62.43.238.63

auto eth0:1
iface eth0:1 inet static
         address 62.43.238.61
         netmask 255.255.255.224
         network 62.43.238.32
         broadcast 62.43.238.63

Asi automaticamente al inicio (o cuando se reinicie el servicio de network) el va a configurar las IP que tu le asignes !

cablop (cablop) said : #2

Thanks Julián David Duque, that solved my question.

cablop (cablop) said : #3

I'll check what you said and i'll try to use first option, cause something weird is working bad on this computer, and second option is not working...

cablop (cablop) said : #4

Ni idea de porque respondí en inglés, hahahaha, :")