Wireless woes with Atheros AR5212

Asked by Kẏra

I can't get my laptop to pick up any wireless networks. It has the Atheros AR5212 and i believe i had it working fine before. I am running Feisty 32-bit and since i reinstalled it, my wireless has not been functioning. I tried re-installing Ubuntu multiple times and i don't think i got wireless to work using the LiveCD either. My friend has the same thing but it works fine for him.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Gabz (gnoronha) said :

is there any external on off switch for your wifi .. stupied question but you'll be surprised make sure it's on

and run dmesg in terminal and look for the word atheros anywhere.

Revision history for this message
Kẏra (thekyriarchy) said :

There is no external on/off switch.

This is where Atheros appeared in the output from dmesg
[ 31.156000] wifi0: Atheros 5212: mem=0xd0200000, irq=19

Revision history for this message
Gabz (gnoronha) said :

in terminal as root

sudo -s

try the following ifconfig have a look at whats listed then try ifconfig -a

if there is a device named ath0 in ifconfig -a and not in ifconfig then all you have to do is ifconfig ath0 up

also check your restricted drivers manager and make sure you've allowed the use of the madwifi driver.

but because you said it didn't work in the live CD it makes me wonder if your wireless card has been turned off either by a external switch... ( most laptops have these please double check your manual) or somewhere in bios.

Revision history for this message
Kẏra (thekyriarchy) said :

I had my wirless working before i reinstalled Ubuntu and i don't believe there was any point which i could have turned off an external switch to my wireless. ifconfig and inconfig -a both have a device names ath0

I just found these insructions:

"Ethernet controller (ath0): Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

NOT recognized on boot.

Need to install MADWIFI-SOURCE MADWIFI-TOOLS packages.

To compile and install the modules, I use MODULE-ASSISTANT command.

#apt-get install madwifi-source madwifi-tools module-assistant

#m-a update

#m-a prepare

#m-a a-i madwifi"

but i ran into one problem--
E: Package madwifi-source has no installation candidate

Revision history for this message
Gabz (gnoronha) said :

if there is an ath0 in the output of ifconfig then the card is installed and operational (from what i can tell)

it could be a problem with network manager graphical program in the top right to configure your wireless card make sure it has wireless enabled ticked if you right click on it.

you can try connecting to your wireless network using the iwconfig terminal program

open a terminal

sudo -s


that should give you things like "eth0 no wireless extensions." that's normal you are looking for ath0 and there should be a whole lot of information there about which wireless network you are connected to

you can try doing a connection to your wireless network with iwconfig ath0 essid "ssid_of _your_network"
of course replace ssid_of _your_network with the real name

if your card (ath0) comes up in ifconfig and iwconfig it's installed .. you may just have to configure it to your wireless network..

Revision history for this message
Kẏra (thekyriarchy) said :

Okay so i guess it's installed,
but now in roaming more, it will not pick up any networks
and my laptop is currently situated less then three feet from my wireless router
and when i enter the information manually, that doesn't work.
 using the command you gave me to connect to my network also doesn't work

Revision history for this message
Gabz (gnoronha) said :

ok becuase it's faster to explain i'll give you some more terminal programs

in terminal

sudo -s

iwlist ath0 scanning

you use the iwlist program to scan for networks in range , this comes back with no data then we are back to square one.. if it comes back with data then we have progress.

if you want to know more about these terminal programs

man iwlist
man ifconfig
man iwconfig

will give you a basic help file press q to quit

you may also want to try iwconfig ath0 essid any

i suggest or experimental reason to turn off any security on your wireless router make sure it's broadcasting an SSID and even changing the ssid to make sure there is no old settings

Revision history for this message
Kẏra (thekyriarchy) said :

danny@danny-laptop:~$ sudo -s
root@danny-laptop:~# iwlist ath0 scanning
ath0 No scan results
root@danny-laptop:~# iwcofig aht0 essid any
bash: iwcofig: command not found

I am upgrading to the gutsy beta and i will continue to try to figure this out after that's complete. I will try tuning off security on my router but i don't think the router is the problem because i just recently installed a new one and this computer still can't connect.

Revision history for this message
Kẏra (thekyriarchy) said :

Yeah, still no luck.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.