X server won't load

Asked by N2Ubunutu on 2007-09-19

I'm very new to Linux, and this may be a dumb question? I'm having a problem with X server (it won't load), and its telling me that it cannot find the nvidia driver its looking for. So, I'm thinking what I need to do is from the command line -- download the nvidia driver, install it, and then reboot? Does anyone know how I can do this? -- Many thanks! --

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Wrwrwr
Solved:
2007-09-19
Last query:
2007-09-19
Last reply:
2007-09-19
Best Wrwrwr (wrwrwr) said : #1

You may try to change your driver to "vesa" for a while, so you can install nvidia with your windows manager. Edit your xorg.conf for that:
sudo nano /etc/X11/xorg.conf
and look for a Section "Device"-->Driver.

Another way (maybe more straightforward) is to reconfigure xserver all together:
sudo dpkg-reconfigure -phigh xserver-xorg

Please, make a copy of xorg.conf before applying any of this.
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.copy

Or also trying installing nvidia from command-line:
sudo apt-get install nvidia-glx (nvidia-glx-legacy or nvidia-glx-new)
sudo nvidia-glx-config enable
This is described in some more detail here:
https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

N2Ubunutu (rockshouse) said : #2

Thanks Wrwrwr, that solved my question.

N2Ubunutu (rockshouse) said : #3

Excellent -- Thanks for the help Wrwrwr!!

Ronald (theprestig3) said : #4

I have this problem, and I know what I did. I had nvidia-glx-legacy on and running fine. Then I saw nvidia-glx-new and like an idiot without checking it out, I installed nvidia-glx-new and removed legacy. Now when I reboot and start I get the error, cannot start X Server GUI.
I saw the commands for uninstalling the nvidia-glx-new and installing legacy. But it didn;t work, it seems it couldn't connect.

Wrwrwr (wrwrwr) said : #5

There are many, many reasons why x server won't start. Making a new question gives you a much better chance to get help. Please do that.

It probably displays something like "couldn't connect to display 0:0", in your case that most probably means that xserver is not running.

Ronald (theprestig3) said : #6

Nevermind I fixed it, It was actually easy. I just did what u said. then a few modifications of the xorg.conf got my resolution back to normal. Thanks!