Can't add/remove programs

Asked by Lucius on 2007-09-18

When I try to add/remove programs from the list and error comes up that says: /home/root/.synaptic - mkdir cannot be found. What do I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Lucius
Solved:
2007-10-24
Last query:
2007-10-24
Last reply:
2007-10-24

This question was reopened

Jensen Somers (jsomers) said : #1

Are you running Gnome or equivalent as root?
Which Ubuntu version are you using?

Lucius (kharlthealchmist) said : #2

I have no idea. <.<; I'm pretty sure it's just Ubuntu, but it might've been switched to Kbuntu, I'm not sure if it stayed that way or I switched it back. Sorry, I'm new to Ubuntu.

Lucius (kharlthealchmist) said : #3
François Tissandier (baloo) said : #4

Could you confirm if
"/home/root/.synaptic - mkdir cannot be found"

is the exact error message you are having?
It's important to have the complete error message first.

Lucius (kharlthealchmist) said : #5

It's not, I didn't have the full one because it wouldn't let me copy it, but here's the exact error message:

E: Error: could not create configuration directory /home/root/.synaptic - mkdir (2 No such file or directory)

Sorry for not having it before.

François Tissandier (baloo) said : #6

OK, what's your login in the system? Is it "root" ? It tries to write something in a file, but cannot find the file or directory (see the end of your message).
So maybe we can recreate the missing directory or file.

But that seems weird. The home directory for the root user is NOT in /home, it's just in /root.
If you tried to create a root user manually, maybe it messed up something?

Please confirm which user account you are using first, then we can try to understand what's wrong.

Lucius (kharlthealchmist) said : #7

Root is untouchable, it's a system safety program that you cannot be the root user because the root can easily make a mistake that can reconfigure the computer and destroy everything. My root folder is in fact in my default home folder, but I could not find a .synaptic folder in root, I know for a fact that I did not tamper with this folder, I'm not sure why it's not there all of a sudden, but I could not find any replacement files for mkdir or .synaptic.

Lucius (kharlthealchmist) said : #8

I amj using Gnome as root

François Tissandier (baloo) said : #9

I think the problem is related to your account. In Ubuntu you should never use Gnome as root. That's just not the philosophy behind it. You run gnome as a normal user, and you give him administrator privileges, then you can use "sudo" to run things as root.

Try this:

-create a new user, and give him admin privileges.
-open Gnome with this user, and try to run Synaptic to update your system. It will ask for your password. Give it, and NOT the root password. Anyway in Ubuntu, the root password should be unknown. When you enter your own password, you run as root in fact, even if you didn't give the root password (sorry if I'm not clear). Then you should be able to download updates.

Lucius (kharlthealchmist) said : #10

When I run Synaptic it comes up with that error message.

François Tissandier (baloo) said : #11

Could you give us the error message plz? Thx!

Lucius (kharlthealchmist) said : #12

It's this one that I already gave:

E: Error: could not create configuration directory /home/root/.synaptic - mkdir (2 No such file or directory)

François Tissandier (baloo) said : #13

The root user home in Ubuntu is not in /home, so I think you have a problem with the root user having the wrong home folder setting.
I don't know how to solve this honestly, you should try to change the home folder for the root account to /root instead of /home/root.

If you can't, I would just reinstall Ubuntu on another partition and move the files.

And if you tried to set this root account, remember that with Ubuntu it's created during the installation and you don't have to create a root account or modify it. In fact you should never use it, but use sudo instead.

Lucius (kharlthealchmist) said : #14

Well, nothing worked, but I have the package site for Ubuntu, and that works fine, so I'll just install it all through that, thank you very much for your time and effort I really appreciate!

gaspo (mhj-ballouchi) said : #15

hi there, i have the solution, it works 100%

Create the root directory first before creating .synaptic like below:
open the terminal and tape

sudo mkdir /root
sudo mkdir /root/.synaptic

then run synaptic or root terminal, and it will work :)
cheers.