Cannot get internet working using Intel DP35DP Motherboard

Asked by FrozenFlame22 on 2007-09-12

I've never had so many problems just connecting to the internet! For years, I've maintained a Windows LAN and kept computers running fairly well long past their prime. I've always considered myself more than computer literate. Heck, I've just built a computer last night with no problems... except...

I just can't connect to the internet.

I'm ready to toss the whole thing out the window. Especially with Ubuntu, the computer is nigh useless unless I can get the ethernet adapter working. Everything else works beautifully! Just can't connect.

Here is my specific build:
Intel Core 2 Duo Processor E6850
Intel DP35DP Motherboard
e-GeForce 8500 GT Graphics Card
Nspire 750W battery
G.Skill DDR2 1GB x 2 (Dual Channel)
Frankensteined DVD drive and 250GB SATA HDD

This is on a home LAN using a Linksys Wireless-G Broadband Router WRT54GS and DSL Actiontec Modem GT701. Both hardware firewalls are off. Other computer in the LAN connects just fine using wireless connection. I'm attempting a wired connection. I've tried using DHCP as well as giving it a static IP, but neither did anything.

I've tried downloading and installing the Gigabit Network Adapter Base Driver for Linux* with 2.4.18 to 2.6.x kernels (e1000-7.6.5.tar.gz) from the Intel download center, but I have several errors. While using Root in the terminal (if my terminology is off, please excuse me, I'm still learning Ubuntu), I followed the Readme instructions exactly. First error was after I typed the command "make install", to which it seemed to follow correctly until this line:

man:
cannot write to /var/cache/man/cat7/e10007.gz in catman mode
e1000.

and the install stops cold. I tried to continue the installation instructions with the command "modprobe e1000", but then I get no feedback. I recognize that some commands don't give any feedback, so I continue to the next: "ifconfig ethx <ip address>" which I entered with the ip address that this computer will have on my LAN. In response I get:

SOICSIFADDR: No such device
ethx: ERROR while getting interface flags: No such device

I've got too little experience with Linux, much less Ubuntu, to try to move forward with this method, so I tried popping in an old D-link ethernet PCI card. Still nothing.

Thinking that my motherboard might be just too new for Feisty Fawn, I tried installing Gutsy Gibbon, but that yielded identical results. I know it's not the cable, because I used this exact same cable to connect on my other desktop PC just two weeks ago (when it blew capacitors on it's motherboard, but that's another story).

Am I just missing something simple? I don't think I've ever been this frustrated with computers before now. I thought that building the dang thing would be the hard part, not connecting to the internet!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
FrozenFlame22
Solved:
2007-09-14
Last query:
2007-09-14
Last reply:
2007-09-13
FrozenFlame22 (frozenflame422) said : #1

Here's everything copied and pasted from the terminal. I saved it and moved it to my other computer via flash drive.

frozenflame@Erebor:~$ su -
Password:
root@Erebor:~# lspci
00:00.0 Host bridge: Intel Corporation Unknown device 29c0 (rev 02)
00:01.0 PCI bridge: Intel Corporation Unknown device 29c1 (rev 02)
00:03.0 Communication controller: Intel Corporation Unknown device 29c4 (rev 02)
00:19.0 Ethernet controller: Intel Corporation Unknown device 294c (rev 02)
00:1a.0 USB Controller: Intel Corporation Unknown device 2937 (rev 02)
00:1a.1 USB Controller: Intel Corporation Unknown device 2938 (rev 02)
00:1a.2 USB Controller: Intel Corporation Unknown device 2939 (rev 02)
00:1a.7 USB Controller: Intel Corporation Unknown device 293c (rev 02)
00:1b.0 Audio device: Intel Corporation Unknown device 293e (rev 02)
00:1c.0 PCI bridge: Intel Corporation Unknown device 2940 (rev 02)
00:1c.1 PCI bridge: Intel Corporation Unknown device 2942 (rev 02)
00:1c.2 PCI bridge: Intel Corporation Unknown device 2944 (rev 02)
00:1c.3 PCI bridge: Intel Corporation Unknown device 2946 (rev 02)
00:1c.4 PCI bridge: Intel Corporation Unknown device 2948 (rev 02)
00:1d.0 USB Controller: Intel Corporation Unknown device 2934 (rev 02)
00:1d.1 USB Controller: Intel Corporation Unknown device 2935 (rev 02)
00:1d.2 USB Controller: Intel Corporation Unknown device 2936 (rev 02)
00:1d.7 USB Controller: Intel Corporation Unknown device 293a (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation Unknown device 2916 (rev 02)
00:1f.2 IDE interface: Intel Corporation Unknown device 2920 (rev 02)
00:1f.3 SMBus: Intel Corporation Unknown device 2930 (rev 02)
00:1f.5 IDE interface: Intel Corporation Unknown device 2926 (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0421 (rev a1)
03:00.0 IDE interface: Marvell Technology Group Ltd. Unknown device 6101 (rev b1)
07:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
root@Erebor:~# cd /home/frozenflame
root@Erebor :/home/frozenflame# tar xvzf e1000-7.6.5.tar.gz
e1000-7.6.5/
e1000-7.6.5/src/
e1000-7.6.5/src/Makefile
e1000-7.6.5/src/e1000.h
e1000-7.6.5/src/e1000_80003es2lan.c
e1000-7.6.5/src/e1000_80003es2lan.h
e1000-7.6.5 /src/e1000_82540.c
e1000-7.6.5/src/e1000_82541.c
e1000-7.6.5/src/e1000_82541.h
e1000-7.6.5/src/e1000_82542.c
e1000-7.6.5/src/e1000_82543.c
e1000-7.6.5/src/e1000_82543.h
e1000-7.6.5/src/e1000_82571.c
e1000-7.6.5 /src/e1000_82571.h
e1000-7.6.5/src/e1000_api.c
e1000-7.6.5/src/e1000_api.h
e1000-7.6.5/src/e1000_defines.h
e1000-7.6.5/src/e1000_ethtool.c
e1000-7.6.5/src/e1000_hw.h
e1000-7.6.5/src/e1000_ich8lan.c
e1000-7.6.5 /src/e1000_ich8lan.h
e1000-7.6.5/src/e1000_mac.c
e1000-7.6.5/src/e1000_mac.h
e1000-7.6.5/src/e1000_main.c
e1000-7.6.5/src/e1000_manage.c
e1000-7.6.5/src/e1000_manage.h
e1000-7.6.5/src/e1000_nvm.c
e1000-7.6.5 /src/e1000_nvm.h
e1000-7.6.5/src/e1000_osdep.h
e1000-7.6.5/src/e1000_param.c
e1000-7.6.5/src/e1000_phy.c
e1000-7.6.5/src/e1000_phy.h
e1000-7.6.5/src/e1000_regs.h
e1000-7.6.5/src/kcompat.c
e1000-7.6.5/src/kcompat.h
e1000-7.6.5/src/kcompat_ethtool.c
e1000-7.6.5/COPYING
e1000-7.6.5/README
e1000-7.6.5/ldistrib.txt
e1000-7.6.5/pci.updates
e1000-7.6.5/e1000.spec
e1000-7.6.5/e1000.7
e1000-7.6.5/SUMS
root@Erebor :/home/frozenflame# cd e1000-7.6.5/src
root@Erebor:/home/frozenflame/e1000-7.6.5/src# make install
make -C /lib/modules/2.6.20-15-generic/build SUBDIRS=/home/frozenflame/e1000-7.6.5/src modules
make[1]: Entering directory `/usr/src/linux- headers-2.6.20-15-generic'
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_main.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_82540.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_82542.o
  CC [M] /home/frozenflame/e1000- 7.6.5/src/e1000_82571.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_82541.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_82543.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_ich8lan.o
  CC [M] /home/frozenflame/e1000- 7.6.5/src/e1000_80003es2lan.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_mac.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_nvm.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_phy.o
  CC [M] /home/frozenflame/e1000- 7.6.5/src/e1000_manage.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_param.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/e1000_ethtool.o
  CC [M] /home/frozenflame/e1000-7.6.5/src/kcompat.o
  CC [M] /home/frozenflame/e1000- 7.6.5/src/e1000_api.o
  LD [M] /home/frozenflame/e1000-7.6.5/src/e1000.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC /home/frozenflame/e1000-7.6.5/src/e1000.mod.o
  LD [M] /home/frozenflame/e1000- 7.6.5/src/e1000.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-15-generic'
gzip -c ../e1000.7 > e1000.7.gz
# remove all old versions of the driver
find /lib/modules/2.6.20-15-generic -name e1000.ko -exec rm -f {} \; || true
find /lib/modules/2.6.20-15-generic -name e1000.ko.gz -exec rm -f {} \; || true
install -D -m 644 e1000.ko /lib/modules/2.6.20-15-generic/kernel/drivers/net/e1000/e1000.ko
/sbin/depmod -a || true
install -D -m 644 e1000.7.gz /usr/share/man/man7/e1000.7.gz
man -c -P'cat > /dev/null' e1000 || true
man:
cannot write to /var/cache/man/cat7/e1000.7.gz in catman mode
e1000.
root@Erebor:/home/frozenflame/e1000- 7.6.5/src#

Simos Xenitellis  (simosx) said : #2

It's great you got this far, though new to Linux. Congratulations.

The error above is in producing the documentation file. It should be uninportant.

Typing "lsmod" should show you if the kernel module "e1000" has been loaded.

Typing "modprobe e1000" will try to load the kernel module you just installed.
Check the output of this command for any errors.
To remove a module, type "rmmod e1000" (so you can add/remove/etc).

If you get a result here, then there is a process to make this addition permanent.

Going back to the start of the problem; I am not sure why your network card is not supported. I do not have such a motherboard.
I am not sure if the specific model of network card needs special firmware that has not made it into Ubuntu yet.
You can get hints by googling for "e1000 ubuntu" (without the quotes). As far as I know, the e1000 driver has been in Ubuntu for some time.

It is quite possible that similar issues with e1000 and your type of motherboard have already been reported. Search http://bugs.launchpad.net/ for hints, then join the debate.

Hope this helps.

FrozenFlame22 (frozenflame422) said : #3

Thank you very much for responding! :D

I didn't get any feedback from "modprobe e1000" and no errors either. I typed "lsmod" immediately after and got a long list of... something. I tested the internet connection, but I'm still not getting anything.

I wouldn't be surprised if this motherboard isn't supported by Fiesty yet, since it was released by Intel in midsummer 2007. Not being supported by Gutsy surprised me, since I found a blog detailing another DP35DP owner using Gutsy with no problems. Of course, that user is much more knowledgeable about Linux than I am, so it's possible he did have problems, but knew how to fix them. I'll do a bit more poking around the internet and see if I can find anything else about the issue.

For completeness, here's what my terminal is looking like after the section that I've already posted (It was prettier before the cut/paste):

root@Erebor:/home/frozenflame/e1000-7.6.5/src# modprobe e1000
root@Erebor:/home/frozenflame/e1000-7.6.5/src# lsmod
Module Size Used by
e1000 191552 0
nls_iso8859_1 5120 1
nls_cp437 6784 1
vfat 14208 1
fat 53916 1 vfat
usb_storage 72256 1
libusual 17936 1 usb_storage
ipv6 268704 10
binfmt_misc 12680 1
rfcomm 40856 0
l2cap 25728 5 rfcomm
bluetooth 55908 4 rfcomm,l2cap
ppdev 10116 0
acpi_cpufreq 10056 1
cpufreq_stats 7360 0
cpufreq_powersave 2688 0
cpufreq_conservative 8200 0
cpufreq_ondemand 9228 2
cpufreq_userspace 5408 0
freq_table 5792 3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
sony_acpi 6284 0
dev_acpi 12292 0
tc1100_wmi 8068 0
pcc_acpi 13184 0
battery 10756 0
sbs 15652 0
i2c_ec 5888 1 sbs
asus_acpi 17308 0
ac 6020 0
button 8720 0
container 5248 0
video 16388 0
dock 10268 0
backlight 7040 1 asus_acpi
af_packet 23816 4
sbp2 23812 0
parport_pc 36388 0
lp 12452 0
parport 36936 3 ppdev,parport_pc,lp
fuse 46612 0
snd_hda_intel 21912 1
snd_hda_codec 205440 1 snd_hda_intel
snd_pcm_oss 44544 0
snd_mixer_oss 17408 1 snd_pcm_oss
xpad 9988 0
snd_pcm 79876 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
agpgart 35400 0
i2c_core 22784 1 i2c_ec
snd_seq_dummy 4740 0
serio_raw 7940 0
pcspkr 4224 0
snd_seq_oss 32896 0
snd_seq_midi 9600 0
snd_rawmidi 25472 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 52592 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23684 2 snd_pcm,snd_seq
snd_seq_device 9100 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54020 12 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 8672 1 snd
psmouse 38920 0
shpchp 34324 0
pci_hotplug 32576 1 shpchp
snd_page_alloc 10888 2 snd_hda_intel,snd_pcm
tsdev 8768 0
evdev 11008 4
ext3 133128 1
jbd 59816 1 ext3
mbcache 9604 1 ext3
sd_mod 23428 5
sg 36252 0
sr_mod 17060 0
cdrom 37664 1 sr_mod
usbhid 26592 0
hid 27392 1 usbhid
ata_piix 15492 2
pata_marvell 7936 0
ata_generic 9092 0
libata 125720 3 ata_piix,pata_marvell,ata_generic
scsi_mod 142348 6 usb_storage,sbp2,sd_mod,sg,sr_mod,libata
ohci1394 36528 0
ieee1394 299448 2 sbp2,ohci1394
uhci_hcd 25360 0
generic 5124 0 [permanent]
ehci_hcd 34188 0
usbcore 134280 7 usb_storage,libusual,xpad,usbhid,uhci_hcd,ehci_hcd
thermal 14856 0
processor 31048 2 acpi_cpufreq,thermal
fan 5636 0
fbcon 42656 0
tileblit 3584 1 fbcon
font 9216 1 fbcon
bitblit 6912 1 fbcon
softcursor 3200 1 bitblit
vesafb 9220 0
capability 5896 0
commoncap 8192 1 capability
root@Erebor:/home/frozenflame/e1000-7.6.5/src#

FrozenFlame22 (frozenflame422) said : #4

Just tried pinging from each computer and both are responding to pings, but the internet is not working. I'm using http://www.google.com to test, but it doesn't even try communicating with the server, and goes directly to the "server not found" page. I've checked in Network Tools to make sure that eth0 is selected, but internet still doesn't work.

Simos Xenitellis  (simosx) said : #5

Thanks for adding the output of the "lsmod" command.

If you notice,

root@Erebor:/home/frozenflame/e1000-7.6.5/src# lsmod
Module Size Used by
e1000 191552 0 <-----------
.......

the "e1000" module has been loaded. Which takes us to the next step, did it report that a Gigabit ethernet card has been detected?

To do that, type "dmesg". Again, you get lots of information. The important point is at the end. For my computer without such a card I just get the standard message,

[ 2421.864000] Intel(R) PRO/1000 Network Driver - version 7.3.15-k2-NAPI
[ 2421.864000] Copyright (c) 1999-2006 Intel Corporation.

Do you get something more than that? (extra few lines)

As a final command, you can run "ifconfig" and post the result here.

FrozenFlame22 (frozenflame422) said : #6

Thank you so very much for continuing to help me! I would be absolutely lost in this stuff without your help.

When I ran dmesg, I got quite a bit more than a few extra lines... So many that they don't all display in the terminal! Here is part of that display:

[ 11.128000] Intel(R) PRO/1000 Network Driver - version 7.6.5-NAPI
[ 11.128000] Copyright (c) 1999-2007 Intel Corporation.
[ 11.128000] ACPI: PCI Interrupt 0000:00:19.0[A] -> GSI 20 (level, low) -> IRQ 18
[ 11.128000] PCI: Setting latency timer of device 0000:00:19.0 to 64
[ 11.180000] e1000: 0000:00:19.0: e1000_probe: (PCI Express:2.5Gb/s:Width x1) 00:19:d1:fa:f2:59
[ 11.216000] input: PC Speaker as /class/input/input1
[ 11.248000] e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
[ 11.268000] usbcore: registered new interface driver hiddev
[ 11.288000] Linux agpgart interface v0.102 (c) Dave Jones
[ 11.308000] sr0: scsi3-mmc drive: 0x/40x cd/rw xa/form2 cdda tray
[ 11.308000] Uniform CD-ROM driver Revision: 3.20
[ 11.308000] sr 4:0:0:0: Attached scsi CD-ROM sr0
[ 11.384000] sr1: scsi3-mmc drive: 53x/48x writer cd/rw xa/form2 cdda tray
[ 11.384000] sr 4:0:1:0: Attached scsi CD-ROM sr1
[ 11.452000] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 23
[ 11.452000] PCI: Setting latency timer of device 0000:00:1b.0 to 64
[ 11.464000] input: HID 1241:1166 as /class/input/input2
[ 11.464000] input: USB HID v1.10 Mouse [HID 1241:1166] on usb-0000:00:1a.2-1
[ 11.532000] input: CHESEN USB Keyboard as /class/input/input3
[ 11.532000] input: USB HID v1.10 Keyboard [CHESEN USB Keyboard] on usb-0000:00:1a.2-2
[ 11.560000] input: CHESEN USB Keyboard as /class/input/input4
[ 11.560000] input: USB HID v1.10 Device [CHESEN USB Keyboard] on usb-0000:00:1a.2-2
[ 11.560000] usbcore: registered new interface driver usbhid
[ 11.560000] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
[ 11.560000] usbcore: registered new interface driver xpad
[ 11.560000] drivers/usb/input/xpad.c: driver for Xbox controllers v0.1.6
[ 12.004000] fuse init (API version 7.8)
[ 12.032000] lp: driver loaded but no devices found
[ 12.068000] Adding 6024332k swap on /dev/disk/by-uuid/beef11a2-bd46-448c-af25-d44657546ca1. Priority:-1 extents:1 across:6024332k
[ 12.200000] EXT3 FS on sda1, internal journal
[ 12.868000] e1000: eth0: e1000_watchdog_task: NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[ 12.868000] e1000: eth0: e1000_watchdog_task: 10/100 speed: disabling TSO

and the ifconfig:

frozenflame@Erebor:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:19:D1:FA:F2:59
          inet addr:192.168.1.125 Bcast:192.168.1.255 Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:56 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:4944 (4.8 KiB) TX bytes:10979 (10.7 KiB)
          Base address:0x30e0 Memory:93200000-93220000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

I've already disabled IPv6 in firefox and globally as suggested by another Ubuntu user in the forums.
I'm also unable to ping Google through either domain or ip address.

FrozenFlame22 (frozenflame422) said : #7

Not sure what changed, if anything, but I can ping Google by ip (the one I used was 64.233.167.99), but I still cannot ping by domain. Still can't access the internet either.

FrozenFlame22 (frozenflame422) said : #8

I got it working!!! I'm actually posting this from inside Ubuntu on the new computer!

On the Ubuntu forums, a user suggested I use OpenDNS for my DNS servers, and I changed that on this computer, however I didn't adjust the modem or router. Later this evening, I went back to the OpenDNS website and read some more about it, then I set their DNS on my router and modem. That did the trick! Previously, both the router and modem had dynamic DNS rather than static DNS.

Thank you very much for your help and especially for your patience! I've actually learned quite a bit about the inner workings of Ubuntu through this, and I've gotten much more comfortable with the command line.
Thank you! :)

FrozenFlame22 (frozenflame422) said : #9

Just one more note in case someone else has the same problem:

When Ubuntu updated for the first time, it knocked out the ethernet adapter driver. I just had to reinstall it and it worked just fine.

labinnsw (labinnsw) said : #10

Is there any chance that you might be able to say how you did this?

dwhyte (david-whyte-symology) said : #11

This might be a stupid question, but have you plugged in the Network lead? I got this message myself. However, after the network lead was connected. I typed modprobe e1000 from within /etc/modprobe.d my networking started up immediately.

dwhyte (david-whyte-symology) said : #12

This might be a stupid question, but have you plugged in the Network lead? I got this message myself. However, after the network lead was connected. I typed modprobe e1000 from within /etc/modprobe.d my networking started up immediately.

labinnsw (labinnsw) said : #13

That is not the problem. It would have been the first thing that I checked and when I saw that is was connected, I checked that is was connected to the modem and I checked that it was connected to the modem properly, then I checked that is was connected to the computer properly. Then I checked that other computers on the same modem are working. I tried a different port on the modem. I tested another operating system on the same computer.

In the end I backed up what I could (which was practically everything) and reinstalled Ubuntu.

Previously I was hesitant to do this but these days I will do it at the drop of a hat, as I now know that re installation can be done without any data loss, (provided you have enough storage for backing up data) and in a fairly short time. It usually solves any problems as well.

dwhyte (david-whyte-symology) said : #14

Did you try run the commands as root?

labinnsw (labinnsw) said : #15

I don't remember if I did but I usually sudo my commands. It does not matter now anyway because when I since the reinstallation I have not had a problem.

Thanks for showing an interest anyway.