wireless not working on CQ61 Presario laptop under 10.04

Asked by Gary Trujillo on 2010-09-25

The problem described below exists under Ubuntu 1.04, Mint9 and Debian 5.04 (all 64 bit versions), but not under Knoppix or Win7, so I know it's not simply a hardware problem. The following posting is a copy of something i posted to a Linux Mint forum several days ago (but have as yet received no useful replies - only one seeking more information). I intend to post the solution, if I find one, both here and there, for the benefit of any others who may be having similar problems.

From http://forums.linuxmint.com/viewtopic.php?f=53&t=56040 :

Greetings. I am presently experiencing a problem in using my new Compaq
CQ61 laptop's wireless communications circuitry. I found a posting from
a year ago at http://ubuntuforums.org/showthread.php?p=7717667 that
describes the problem with another model of the CQ61 and gives a
solution, which involves installing a package called "linux-backports-
modules-jaunty," which I can't find, and probably doesn't apply to newer
versions of Ubuntu Linux anyway, to say nothing of Linux Mint.

I'm wondering whether finding a more recent version of this package
could be expected to fix the problem also, or if "all bets are off" at
this point. I did find something called "linux-backports-modules-
wireless-2.6.32-24-generic," but it fails to install, apparently due to
dpkg not liking the downloaded module (see http://pastebin.ca/1943245
for the details of what happens when I try doing that installation).

Has anyone heard of this problem, and/or does someone maybe have any
suggestions for approaching it?

Thanks much in advance!

"mintwifi" produces (run with wifi enabled, but with an Ethernet
cable plugged into my router and wifi turned off on the router,
though it was enabled for the later tests shown below):

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

eth0 Link encap:Ethernet HWaddr 00:26:9e:bf:c1:1d
inet6 addr: fe80::226:9eff:febf:c11d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:198573 errors:0 dropped:0 overruns:0 frame:0
TX packets:304369 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:106730371 (106.7 MB) TX bytes:292321135 (292.3 MB)
Interrupt:27

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3845 errors:0 dropped:0 overruns:0 frame:0
TX packets:3845 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:284096 (284.0 KB) TX bytes:284096 (284.0 KB)

wlan0 Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/90:4c:e5:37:e2:c5
Sending on LPF/wlan0/90:4c:e5:37:e2:c5
Listening on LPF/eth0/00:26:9e:bf:c1:1d
Sending on LPF/eth0/00:26:9e:bf:c1:1d
Sending on Socket/fallback
DHCPREQUEST of 192.168.2.12 on eth0 to 255.255.255.255 port 67
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPACK of 192.168.2.12 from 192.168.2.1
bound to 192.168.2.12 -- renewal in 2147483648 seconds.
Server: 192.168.2.1
Address: 192.168.2.1#53

Non-authoritative answer:
Name: google.com
Address: 173.194.34.104

-------------------------
* I. scanning WIFI PCI devices...
-- Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
==> PCI ID = 168c:002b (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
-------------------------
* IV. querying ifconfig...
-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...

--

"iwconfig" produces:

| lo no wireless extensions.
|
| eth0 no wireless extensions.
|
| wlan0 IEEE 802.11bgn ESSID:off/any
| Mode:Managed Access Point: Not-Associated Tx-Power=off
| Retry long limit:7 RTS thr:off Fragment thr:off
| Power Management:off

"lspci" says:

| 00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate
| 00:01.0 PCI bridge: Hewlett-Packard Company Device 9602
| 00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
| 00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
| 00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
| 00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
| 00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
| | wlan0 IEEE 802.11bgn ESSID:off/any
| 00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
| 00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
| 00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
| 00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
| 00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
| 00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
| 00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
| 00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
| 00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
| 00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
| 00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
| 00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
| 00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
| 01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
| 02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
| 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

lsusb:

| Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
| Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
| Bus 001 Device 003: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
| Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

ifconfig:

| eth0 Link encap:Ethernet HWaddr 00:26:9e:bf:c1:1d
| inet addr:192.168.2.12 Bcast:192.168.2.255 Mask:255.255.255.0
| inet6 addr: fe80::226:9eff:febf:c11d/64 Scope:Link
| UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
| RX packets:8918904 errors:0 dropped:0 overruns:0 frame:0
| TX packets:7194461 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:10896896641 (10.8 GB) TX bytes:1614876717 (1.6 GB)
| Interrupt:27 Base address:0x2000
|
| lo Link encap:Local Loopback
| inet addr:127.0.0.1 Mask:255.0.0.0
| inet6 addr: ::1/128 Scope:Host
| UP LOOPBACK RUNNING MTU:16436 Metric:1
| RX packets:929734 errors:0 dropped:0 overruns:0 frame:0
| TX packets:929734 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:0
| RX bytes:11629535731 (11.6 GB) TX bytes:11629535731 (11.6 GB)
|
| wlan0 Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| UP BROADCAST MULTICAST MTU:1500 Metric:1
| RX packets:0 errors:0 dropped:0 overruns:0 frame:0
| TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
|
| wlan0:avahi Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| inet addr:169.254.11.29 Bcast:169.254.255.255 Mask:255.255.0.0
| UP BROADCAST MULTICAST MTU:1500 Metric:1

ifconfig -a:

| eth0 Link encap:Ethernet HWaddr 00:26:9e:bf:c1:1d
| inet addr:192.168.2.12 Bcast:192.168.2.255 Mask:255.255.255.0
| inet6 addr: fe80::226:9eff:febf:c11d/64 Scope:Link
| UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
| RX packets:8920635 errors:0 dropped:0 overruns:0 frame:0
| TX packets:7196588 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:10897146449 (10.8 GB) TX bytes:1616088591 (1.6 GB)
| Interrupt:27 Base address:0x2000
|
| lo Link encap:Local Loopback
| inet addr:127.0.0.1 Mask:255.0.0.0
| inet6 addr: ::1/128 Scope:Host
| UP LOOPBACK RUNNING MTU:16436 Metric:1
| RX packets:930486 errors:0 dropped:0 overruns:0 frame:0
| TX packets:930486 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:0
| RX bytes:11638366706 (11.6 GB) TX bytes:11638366706 (11.6 GB)
|
| wlan0 Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| UP BROADCAST MULTICAST MTU:1500 Metric:1
| RX packets:0 errors:0 dropped:0 overruns:0 frame:0
| TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
| collisions:0 txqueuelen:1000
| RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
|
| wlan0:avahi Link encap:Ethernet HWaddr 90:4c:e5:37:e2:c5
| inet addr:169.254.11.29 Bcast:169.254.255.255 Mask:255.255.0.0
| UP BROADCAST MULTICAST MTU:1500 Metric:1

the output of "iwlist wlan0 scan" is fairly long, so it's at http://pastebin.ca/1945985 .

"dhclient" (with the appropriate SSID) says:

| Internet Systems Consortium DHCP Client V3.1.3
| Copyright 2004-2009 Internet Systems Consortium.
| All rights reserved.
| For info, please visit https://www.isc.org/software/dhcp/
|
| Listening on LPF/wlan0/90:4c:e5:37:e2:c5
| Sending on LPF/wlan0/90:4c:e5:37:e2:c5
| Listening on LPF/eth0/00:26:9e:bf:c1:1d
| Sending on LPF/eth0/00:26:9e:bf:c1:1d
| Sending on Socket/fallback
| DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
| DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
| DHCPOFFER of 192.168.2.12 from 192.168.2.1
| DHCPREQUEST of 192.168.2.12 on eth0 to 255.255.255.255 port 67
| DHCPACK of 192.168.2.12 from 192.168.2.1
| bound to 192.168.2.12 -- renewal in 2147483648 seconds.

/etc/network/interfaces contains:

| # The loopback network interface
| auto lo
| iface lo inet loopback
|
| # The primary network interface
| allow-hotplug eth0
| iface eth0 inet dhcp

/etc/resolv.conf:

| nameserver 192.168.2.1

"lsmod" gives a bunch of output. But since I don't know which bit is
relevant for our purposes, I'll omit it for now.

I hope this info helps. Please let me know if there is anything else I
can do to provide more details and/or point me to sources of what might
be useful in the way of background reading.

Thanks again!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-nettool Edit question
Assignee:
No assignee Edit question
Solved by:
Gary Trujillo
Solved:
2010-09-26
Last query:
2010-09-26
Last reply:
2010-09-25

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Please copy-paste the following command from this page in browser Firefox into the Linux Terminal.
Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command.
The command STARTS with the word sudo and ENDS with the word dist-upgrade;
So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>,
then enter password when sudo asks for password, then press enter again.

sudo dpkg --configure -a; sudo apt-get -f install; sudo apt-get update; sudo apt-get dist-upgrade;

Then reboot your pc and test if your wireless card is detected, if not continue from the step 3 below

Step 3: Please copy-paste the following command from this page in Firefox into the Linux Terminal.
Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command.
The command STARTS with the word sudo and ENDS with the word restart.
So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>,
then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'ound|irmware|eth|ath|wl|ipw|rtl|rt2|b43|witch|ndiswrapper'; iwconfig; grep b43 /etc/modprobe.d/*; grep wl /etc/modprobe.d/*; sudo hwinfo --netcard ; sudo lsmod; sudo /etc/init.d/networking restart

Step 4: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Step 5: Step 4: Please also specify the exact model and make of your PC (if known).

Gary Trujillo (gst-btlonline) said : #2

Well, I have mixed results to report - and a new variable
thrown into the mix. Here's what happened:

I followed the first two steps late last night, within a
few minutes of Marco's posting. I executed the commands
he listed, which seem to have replaced a few files.

In /boot:
  initrd.img-2.6.32-24-generic
  initrd.img-2.6.32-24-preempt

as well as /boot/grub/grub.cfg .

(I know about these files, having had some boot problems
not long ago, which resulted in my having had to get a
new copy of a lost "initrd.img-2.6.32-24-generic" file -
and I had to use "grub-mkconfig" and "grub-install" to
generate a new grub.cfg file and re-write the bootloader
in the MBR of the internal drive of my laptop.)

After I followed the first two steps of the instructions
Marco provided, and found myself in a freshly booted state,
I was able to connect immediately to the wireless router
via the wlan0 device. I was delighted, of course, and
decided to take the laptop into my bedroom, now that I was
free of the Ethernet cable hookup to the router. So I
left the machine running, unplugged the AC charger to take
with me, unplugged an external drive's USB cable, since I
wouldn't need to use that device, closed the lid of the
laptop, and took it and the charger into the bedroom. It
took a few minutes of fiddling with the AC charger, since
I needed an adaptor to plug it into the (ungrounded) wall
outlet, plugging in the USB mouse I'd brought from the
other room, arranging myself on the bed, etc. When I
opened the lid, I wasn't surprised when I saw a blank
screen and some flashing LEDs, but I was surprised when I
found that hitting a key did not bring the machine into a
state of displaying a login screen, as I had previously
experienced when closing the lid and opening it again a
while later (even if "later" meant the next morning).
Nothing I did could restore the system (I tried hitting
various key, ctl-alt-DEL, etc., and clicking the mouse
buttons). Finally, I hit the power button to turn off
the machine altogether. I was further surprised when the
machine didn't reboot when I turned it back on. It went
back into that same state, blank screen and LEDs flashing
in a regular pattern (flash, flash, wait, wait, flash,
flash, etc.). I reckon the machine was in a sleep or
hibernate state, or some such - but I had no idea how to
get it out of that state, since I had never experienced
such a thing previously.

Since the machine is fairly new and still under warrantee,
I decided to call HP tech support, and spent over an hour
talking with Mohammed in India. The first thing he asked
me to do was to turn off the machine, remove the battery,
and hold down the power button for a full minute (to dis-
charge the capacitors in the internal power supply circuit,
which seems to have had the side effect of wiping out some
internal memory, since after I booted into Windoze so the
tech support guy could connect to the machine and have a
look around, I got a popup asking me if I wanted to create
a recovery disk, which I had already done a few weeks ago,
being told by a popup at that time that I would be able to
write only ONE recovery disk - EVER. So I learned a trick
to fake out the recovery disk software, apparently. Both
Mohammed and I had a chuckle over that phenomenon.

Anyway, and now I come to the main point of the story, when
I finally rebooted into Linux (a great relief, I might add,
since I don't care much for Windoze, even in its Win 7 re-
incarnation), I found that not only could I not get a wire-
less connection as before - even the previously reliable
connection via an Ethernet cable would not work! However,
it had been working just previously under Windoze (both
cable and wireless connections), and I found that Knoppix,
which I have on a USB stick, was also able to connect via
both methods with no problems, so there's no problem with
the hardware nor with Linux drivers being able to talk to
it successfully. But I am wondering whether there's some-
thing in that internal memory chip whose existence I have
postulated that might have something to do with the failure,
since that's the only change I'm aware of that might have
resulted from what the machine had just been through.

Well, at this point, I guess I might as well follow the
remainder of the steps in Marco's list, though it seems to
me somehow that I am now dealing with a new problem. I
hope the above narrative isn't too long - I just wanted to
give a complete accounting of events. Now that the laptop
can't talk to the network at all, it will be rather more
difficult to post this item, but I'll do what I must...

Arggg. I just realized - without an Internet connection,
I can't do the further software installations required in
the subsequent steps in Marco's list. Well, in that case,
I'll just offer a few more thoughts and post this report,
which I'm having to carry over to another machine via USB
memory stick. :-)

I'll start by saying there's one possibly-relevant bit of
information I neglected to mention above, which is that
now, I find when I mouse over the icon at the right side
of the KDE taskbar, in the "tray" section - an icon that
shows an image of an RJ-45 wall jack and an Ethernet cable
ready to plug into it - a popup appears on the screen that
says "Unmanaged." Previously, that popup would display an
indication that there was a connection (via cable, since
that sort of connection was all I had been able to use).
A left click on the icon produces another popup that says
"Network Management disabled." A right click does the
same thing.

For whatever it's worth, my speculation about what caused
the machine to go into a funny mode last night had some-
thing to do with my having unplugged the AC charger after
I had closed the lid of the laptop. I'm guessing that the
power management software is set up to take the system out
of the ordinary screensaver locked-screen mode and into a
sleep or hibernate state when it senses a loss of AC power
under a closed lid condition. I assume there's some key-
press combination of which I'm now unaware that wakes the
system up again. I'd appreciate getting more information
on that subject also, if anyone happens to know. Thanks.

Lastly, I'm wondering whether there might be a way to get
the software Marco's later steps call for without an active
Internet connection. Could I use another machine, like my
Debian box, to pick up what's required and bring it back
via USB stick?

Thanks much to Marco, who I know is on the right track,
and to anyone else who might have some thoughts!

Gary Trujillo (gst-btlonline) said : #3

Another addendum - I've found what to me look like very interesting entries in my syslog file that bear on this matter. They show the wlan0 device being recognized for the first time, what happened when I closed the laptop lid and removed the battery charger, and what happened on a subsequent reboot. Perhaps Marco or someone else can use the information contained in the snipped I've uploaded to http://filebin.ca/agbdwb to figure out what's going on.

I've used bzip2 compression on the file, since it's over 1MB of text, too big to post to pastebin. It contains UNIX newlines to terminate each line.

Gary Trujillo (gst-btlonline) said : #4

I should also say that actually, I followed the procedure Marco recommended while running Mint9 ("Isadora"), but I experienced this same problem while running Ubuntu 10.04 ("Feisty"). My main reason for not booting into Ubuntu before following Marco's instructions is that, due to what I think is a BIOS problem, it is very difficult to boot - except for Knoppix, all the other Debian-derived systems I've tried lock up right after I log in to an X session under KDE. I get lucky once in a while - maybe in one attempt out of eight or ten. I found a posting on the net from about a year ago that reports this same problem with another model of the Compaq Presario CQ61. I have installed several versions of Linux - Debian, Ubuntu and Mint - onto an external drive, so if I have a working Internet connection, I can boot into any of those systems - subject to the problem just reported. I suppose it might be worthwhile to try one of those other systems and see if the current problem with both cabled and wireless connections are specific to the Mint9 system that's now running on that machine. However, I am presently inclined to think there is some network management utility that has gotten into a state where network access is disabled, and it's just a matter of re-enabling it, so I'll wait until I hear from someone with some knowledge on the subject before I proceed.

Gary Trujillo (gst-btlonline) said : #5

I should also say that actually, I followed the procedure Marco recommended while running Mint9 ("Isadora"), but I experienced this same problem while running Ubuntu 10.04 ("Feisty"). My main reason for not booting into Ubuntu before following Marco's instructions is that, due to what I think is a BIOS problem, it is very difficult to boot - except for Knoppix, all the other Debian-derived systems I've tried lock up right after I log in to an X session under KDE. I get lucky once in a while - maybe in one attempt out of eight or ten. I found a posting on the net from about a year ago that reports this same problem with another model of the Compaq Presario CQ61. I have installed several versions of Linux - Debian, Ubuntu and Mint - onto an external drive, so if I have a working Internet connection, I can boot into any of those systems - subject to the problem just reported - and do a further test. I suppose it might be worthwhile to try one of those other systems and see if the current problem with both cabled and wireless connections are specific to the Mint9 system that's now running on that machine. However, I am presently inclined to think there is some network management utility that has gotten into a state where network access is disabled, and it's just a matter of re-enabling it, so I'll wait until I hear from someone with some knowledge on the subject before I proceed.

Gary Trujillo (gst-btlonline) said : #6

Now I'm very confused - or maybe I've been confused all along and am just now realizing the fact. :-) I finally managed to boot into Kubuntu, which was rather difficult, for reasons that aren't important in this context. I discovered when I got in that in face the wireless interface *does work*, so it's looking as if the problem I had earlier is Mint-specific. I guess I abandoned Kubuntu simply due to the booting problem I was having at the time, and wanted to see if Mint might be free of the problem, rather than for any reason relating to the wireless system not working. I now think that Marco's procedure did solve the problem under Mint, but I've somehow managed to get the wlan0 device into a non-working state due to some bit of administrative software not being set right - it must have happened as a result of the system going into a sleep state and not being able to emerge from that state cleanly. I found that I can produce the same situation under Kubuntu by bringing up the Ethernet control panel (whatever it's called) and deselecting the "Enable wireless" item. For unknown reasons, that menu popup is inactive under Mint, so I have to figure out how to reactivate it. I expect that if and when I do, I'll be able to get back to where I was last night just after doing what Marco suggested, and will then have a working wireless connection.

I think part of my present confusion comes from realizing that it's probably no more difficult to boot into Kubuntu than into Mint - but Kubuntu is living on an external drive that I don't want to have to carry around with me. I'll probably stick with Mint for now, assuming I can get the wireless connection back in working order, and then play with Kubuntu and Debian as time permits over the course of the next several months, comparing the features of each.

Since I'm not "out of the woods" yet, I still welcome comments, one off which, I expect, might be - take this question to a Mint forum, which is probably what I'll do if I can't figure out how to answer it myself.

Gary Trujillo (gst-btlonline) said : #7

Yup. It was just as I had thought. After booting back into Linux Mint (an Ubuntu derivative), I found that things were just as I had left them - no connection possible using either the cable or wireless method. Then using another machine, I did a search, and got very lucky - the first item I clicked on has the solution. And the article is from someone who had it on an Ubuntu system and reported it here on Launchpad:

https://bugs.launchpad.net/ubuntu/+bug/555571

Here's as much as I had to read of the somewhat longer item:

Bug Description

Network Manager worked in the beginning after patching and rebooting the KNetworkManager showed "Network Management disabled". No option to enable it again was available.

The issue was caused by
  NetworkingEnabled=false
in
 /var/lib/NetworkManager/NetworkManager.state

After changing it back to
 NetworkingEnabled=true
in
 /var/lib/NetworkManager/NetworkManager.state
and running
 sudo service network-manager restart
everything worked fine again.

Thanks again to Marco, and to Dani Rey, who posted the aforementioned item in April of this year!